Manjaro update... but electrical shutdown happened, and everything is broken

Hey there,

I experience something that I never had before due to an unexpected electrical shutdown during an update.

Several things at once:

  • sudo does not work: e.g. when I type sudo ls, nothing happened. The prompt is gone and it is not coming back, which is pretty annoying. I can use su but not sudo.
  • wifi and ethernet are gone.
  • reboot or shutdown are gone: when I try to reboot it will take a very long time to execute several things, trying to kill sudo, and other things but eventually cannot.

I tested several other similar posts but that did not solve this issue.

For inxi --admin --verbosity=7 --filter --no-host:

  Kernel: 6.1.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=6d03be4a-7423-4153-9bc8-13c2e3f77fab rw nowatchdog quiet
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20XK0015US v: ThinkPad T14 Gen 2a
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: LENOVO model: 20XK0015US serial: <filter> UEFI: LENOVO
    v: R1MET39W (1.09 ) date: 06/21/2021
  ID-1: BAT0 charge: 47.9 Wh (99.8%) condition: 48.0/50.5 Wh (95.2%)
    volts: 12.8 min: 11.5 model: SMP 5B10W51827 type: Li-poly serial: <filter>
    status: not charging cycles: 45
  RAM: total: 14.46 GiB used: 1.1 GiB (7.6%)
  Array-1: capacity: 64 GiB slots: 2 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM 0 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 16 GiB speed: 3200 MT/s volts: curr: 1.2 min: 1.2 max: 1.2
    width (bits): data: 64 total: 64 manufacturer: Micron Technology
    part-no: 4ATS2G64HZ-3G2B1 serial: N/A
  Device-2: DIMM 0 type: no module installed
  Info: model: AMD Ryzen 5 PRO 5650U with Radeon Graphics socket: FP6 bits: 64
    type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 1775 high: 2300 min/max: 1600/4288 boost: enabled
    base/boost: 2300/4250 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1600 2: 2300 3: 1600 4: 1600
    5: 2300 6: 1600 7: 1600 8: 1600 9: 1600 10: 2300 11: 1600 12: 1600
    bogomips: 55122
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300
    temp: 33.0 C
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-2:2 chip-ID: 04f2:b6d0 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 compositors: 1: xfwm v: 4.18.0
    2: Picom v: git-b700a driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x573d built: 2018
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.11-1-MANJARO) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_pci_ps,snd_sof_amd_renoir,snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k6.1.11-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: no

The inxi command does not send the whole result (stops at Network it seems), nothing else prints out and the prompt never comes back.

I tried completing the update with manjaro-chroot -a through a usb live but nothing has changed.

Timeshift / Snapper snapshot available?

Unfortunately, no. Not for this one.

Since you said no backup/Timeshift exists, then you can take the time to figure out each and every app that’s been affected and fix them or reinstall.

I once had the same thing happen to me, and while my system booted and most things worked, there were some applications that wouldn’t launch and others would crash. I discovered many blank files/executables (probably the files the were in the process of updating when the power went out), and who knows if there were other non-blank files that were corrupted, so I decided it would be quicker to start fresh and reinstall than to fix.

Yes, I was afraid of that, but well… Not so much options.
Thanks for your help and comments.

Then you need to use the Manjaro USB stick, chroot into the system and reinstall the base system.

1 Like

when you run update from chroot were there any errors? or are you up to date?
if there were no errors and you are up to date, you can reinstall all packages, so first refresh mirrros (you do this from chroot of course):
pacman-mirrors -f 5 && pacman -Syyu
then run this:

pacman -Qqn | pacman --overwrite=* -S -

exit chroot and reboot


You are not the first and you will not be the last - so I think there is mini tutorials on what to do to recover from such situation.

Did you search before asking?

The steps are roughly

  1. boot a live system - either Manjaro or a System Rescue CD
  2. mount your partitions
  3. manjaro-chroot or arch-chroot into the non functional system
  4. run pacman -Syu
  5. exit chroot
  6. reboot
1 Like

I’d rather have this and just reinstall the OS and everything than be just about done with sa bios update and the power go out toasting the bios in the process. Needless to say I was not happy.

Hi, yes I already tried it.
The commands went well but no changes were visible when I rebooted no the base system.
I suppose it was because I am unable to shut down the system correctly.

Hi yes also tried this but also to no avail.

I will just extract all my data and start a fresh install.
My bad, I should have had a timeshift config no this one.
Many thanks for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.