Manjaro UEFI entry missing and doesn't boot

Hello, I have a HP 250 G6 Laptop with a 1TB HDD, and have Windows (300GB), KDE Neon (100GB) installed. Now I had also Manjaro KDE installed in the same machine (for 2 months) which was broken in an update. So today, I downloaded the latest iso, burned it to a thumbdrive and Manjaro installed totally fine, without any error. But when I went to boot the laptop, there was no Manjaro entry in UEFI and couldn’t even boot it up from neon (after sudo update-grub added Manjaro to grub, but no use) :sob: :sob:. I again tried to install but in vain. Please help.

Welcome to the forum! :slight_smile:

That’s because when you reinstalled Manjaro, you installed it in legacy BIOS mode, not in UEFI mode. There is a huge difference in how this works, and what partition layout it requires.

With legacy BIOS mode, you can use either an MS-DOS MBR partition table or a GPT partition table, but if you choose GPT, then you need an unformatted partition of type bios_grub and about 2 MiB in size, and this partition must bear the boot flag.

In a native-UEFI-booting system, you need a GPT partition table, and instead of a bios_grub partition, you need a 512 MiB EFI system partition, formatted as vfat (FAT32), and marked with the esp flag.

You cannot have both legacy-booting and UEFI-booting operating systems on the same drive. If they’re on separate drives, then that’ll work, but if you install multiple operating systems on the same drive, then they must either all boot in legacy BIOS mode or all in native UEFI mode.

If you’re going to install Manjaro in native UEFI mode, then you must disable CSM (legacy BIOS compatibility support) in the UEFI settings, because most UEFIs will, when CSM is enabled, attempt to boot in legacy BIOS mode first. As such, when the Manjaro installer boots, it detects whether it has been booted in legacy BIOS mode or in native UEFI mode, and it will not offer a UEFI-style installation if it’s running in legacy BIOS mode.

Thank you for such a quick response. In my laptop bios is disabled by default, during install partition scheme was GPT, I created - 1. a 512 MB fat32 partition (/boot/efi) with flag boot, 2. an 150 GB ext4 partition (/). Could you please elaborate keeping this in mind ? (The esp option was absent)

It is possible that Manjaro’s GRUB ─ which needs to be the one in control of the drive ─ wasn’t properly installed. Try booting up from the live CD/USB, open up a terminal and issue the following commands… :arrow_down:

sudo su -
modprobe efivars
manjaro-chroot -a

Select your Manjaro installation from the menu you’re being presented.

Next, issue the command… :arrow_down:

nano /etc/default/grub

In the editor, look for a line that reads…

GRUB_DISABLE_OS_PROBER=true

… and change that to false. Save the file with Ctrl+O and Enter, and exit the editor with Ctrl+X.

Next, try reinstalling GRUB, like so… :arrow_down:

grub-install --no-rs-codes --recheck --target="x86_64-efi" --modules="part_gpt part_msdos /dev/nvme0n1
update-grub

Replace the string /dev/nvme0n1 in the command above by the designation for your drive. For instance, it might also be /dev/sda or /dev/sdb, or perhaps even something else, depending on how the drive interfaces with the motherboard.

If all went well, you can exit the chroot by pressing Ctrl+D or typing… :arrow_down:

exit

It should now be safe to reboot your system, and if all goes well, then everything should now work.

:crossed_fingers:

Again, it did not work out. Perhaps something’s wrong with my laptop :disappointed_relieved: . One thing, btw, when I finished installing from live media and ran efibootmgr from within the live usb, a Manjaro UEFI entry was showing, but after reboot …

Sir, I am curious about a thing. As I said earlier, if I run efibootmgr from my KDE Neon installation, I am still getting the Manjaro EFI entry, but it is not showing up in the HP bootloader (pressing f9). Could you please tell me what this may be related to? (I have tried reordering the entries in efibootmgr)

The only thing I can think of ─ but I have no experience with this, really ─ is that your UEFI firmware has Secure Boot enabled.

KDE Neon is based upon Ubuntu LTS, and Ubuntu supports Secure Boot. Manjaro however does not, so if Secure Boot is enabled, then you must switch that off. And while you’re at it, also switch off Fast Boot, because it’s going to lead to problems if you’re going to be accessing your Windows partition(s) from within Manjaro.

OK. Thank you very much, I will try turning off fast boot. The secure boot is already disabled.
:slightly_smiling_face:

1 Like