Manjaro stuck while loading

Hi, my system is loading for ever:

For now there are 2 situations that can cause this problem:

  1. I have a nv4060 and amd cpu, currently I just enabled nv graphic card. When I try to enable both, it stucked in the loading process
  2. If I installed more than 1 linux kernel

Both of them are revertible, which means if I undo them, the system can boot normally.

Furthermore, pressing ESC while the three dot is no use.

System info:

[shore@shore-82wm manjaro_note]$ inxi -F
System:
  Host: shore-82wm Kernel: 6.8.12-3-MANJARO arch: x86_64 bits: 64
  Desktop: Xfce v: 4.18.1 Distro: Manjaro Linux
Machine:
  Type: Laptop System: LENOVO product: 82WM v: Legion R9000P ARX8
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76479 WIN
    serial: <superuser required> UEFI: LENOVO v: LPCN51WW date: 04/22/2024
Battery:
  ID-1: BAT0 charge: 84.9 Wh (100.0%) condition: 84.9/80.0 Wh (106.2%)
CPU:
  Info: 16-core model: AMD Ryzen 9 7945HX with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 16 MiB
  Speed (MHz): avg: 1375 min/max: 400/5461 cores: 1: 400 2: 3591 3: 400
    4: 400 5: 400 6: 3670 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
    14: 400 15: 400 16: 400 17: 400 18: 400 19: 3346 20: 400 21: 400 22: 3590
    23: 3510 24: 400 25: 4959 26: 4622 27: 3527 28: 400 29: 4005 30: 400
    31: 400 32: 400
Graphics:
  Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] driver: nvidia
    v: 550.90.07
  Device-2: Syntek Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.org v: 1.21.1.13 driver: X: loaded: nvidia
    gpu: nvidia resolution: 1: 2560x1600~60Hz 2: 3440x1440~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce RTX 4060 Laptop GPU/PCIe/SSE2
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_rpl_pci_acp6x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.8.12-3-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp4s0 state: up mac: a8:3b:76:73:83:77
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp5s0 state: down mac: fc:5c:ee:24:71:de
  IF-ID-1: docker0 state: down mac: 02:42:c7:9f:7b:ac
Bluetooth:
  Device-1: Foxconn / Hon Hai Bluetooth 5.2 Adapter [MediaTek MT7922]
    driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 2.75 TiB used: 483.28 GiB (17.2%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL21T0HCLR-00BL2
    size: 953.87 GiB
  ID-2: /dev/nvme1n1 vendor: Seagate model: WDC WDS200T2B0C-00PXH0
    size: 1.82 TiB
Partition:
  ID-1: / size: 1.74 TiB used: 483.28 GiB (27.1%) fs: ext4 dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 300 KiB (0.1%) fs: vfat
    dev: /dev/nvme1n1p1
Swap:
  ID-1: swap-1 type: partition size: 51.4 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme1n1p3
Sensors:
  System Temperatures: cpu: 72.2 C mobo: 52.0 C gpu: nvidia temp: 46 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 48 GiB available: 46.73 GiB used: 5.17 GiB (11.1%)
  Processes: 524 Uptime: 4m Shell: Bash inxi: 3.3.35

Looks like the Plymouth bug:

Open /etc/default/grub and remove the word splash & quiet from the Grub command line.

Then save the File and use this command:
sudo grub-mkconfig -o /boot/grub/grub.cfg

In addition you can also remove plymouth hook from /etc/mkinitcpio.conf

Then save the File and use this command:
sudo mkinitcpio -P

1 Like

Please do remove that picture - it serves no purpose

Do not post images or screenshots as part of your topic. The forum is a technical forum not an image gallery.
Forum Rules - Manjaro

You should check KMS (kernel mode setting) as Nvidia GPU need to manually enable it.

Edit:- Title spelling.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.