Manjaro stuck on boot screen: libidn2.so.4 missing


#22

Unpack libidn2 pkg from cache manualy, and copy libidn2.so.4 in /usr/lib/


#23

@crimson-daemon
You saved me. Thank you so much.
I really need to learn this stuff more.

What does the -Syyuu actually do? I have never seen it. Is it some kind of variation of -Syu?
Weird that it is not explained on https://wiki.archlinux.org/index.php/Pacman


#24

Same like, you find in post #2,
pamac upgrade --enable-downgrade

:smiley:

You can read what it does :wink:

Somebody m-i-s-100 !

Or I will do :slight_smile:


#25

Mihael, thank you much for this…

so I did this, get into my system everything seems fine…

the icon is red saying I have updates…

I sync mirrors and then run ‘sudo pacman -Syyuu’…

and it say I have 3 lib pkgs and 2 system d pkgs to instal…

I type yes and get the following error…

"error: failed to commit transaction (conflicting files)
libidn2: /usr/lib/libidn2.so.4 exists in filesystem
libidn2: /usr/lib/libidn2.so.4.0.0 exists in file system

any ides?.. by the way, I did copy both in there because wasn’t sure which was needed


Still down from sysd downgrade
#26

got it… dalto helped me here

just needed to use an overwrite command since I moved it manually.

Thanks everyone!


split this topic #27

A post was split to a new topic: Simply unacceptable fk-up


#28

Hi, i have managed to solve this issue that can’t run pacman at all because of error:
error while loading shared libraries: libidn2.so.4: cannot open shared object file: No such file or directory
So, i ‘fake’ that file from the other available libidn2 this step:

  • chroot
  • cd /usr/lib
  • ln -s libidn2.so.0.3.5 libidn2.so.4
  • sudo reboot

Then i can boot the system, but still stuck while loading the display, so i switch to tty, and then run pacman -Syyuu.

I’m new to arch, it’s my fault i didn’t read the announcement. Hope that help.


Latest stable update: Libidn2.so.4 not found
Manjaro broken after todays update
Software update stalled, blank screen, had to reboot, now Network Manager fails, hangs on boot
Manjaro broken after todays update
[Solved] No working terminal or network manager after update
#29

I’m in a little bit of a loop here…

I have successfully chroot’d into my system, but after doing that all of the advice I’m seeing says to run pacman or wget related commands to retrieve the libidn file. Predictably, none of these work, and throw the error:

pacman: error while loading shared libraries: libidn2.so.4: cannot open shared object file: No such file or directory

I also tried using the ln -s libidn2.so.0.3.5 libidn2.so.4 command, but that is just resulting in unable to lock databases errors, I believe because it isn’t the real file? Or is that unrelated?

[manjaro-gnome /]# sudo pacman -S systemd
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck

Is there a step I’m missing? I’ve read through a few of these threads and I’m not sure what I’m missing.


#30

reinstalling systemd shouldnt be necessary
boot live media, connect to network and chroot in, once your in:
ln -s /usr/lib/libidn2.so.0.3.5 /usr/lib/libidn2.so.4
sudo pacman -Syyu

to symlink you needed the directories. if -Syyu doesnt work then -Syyuu


#31

Aren’t the libidn pathes in your command backwards? They’re the opposite of what is written above.

Regardless, that still results in:

[manjaro-gnome /]# sudo pacman -Syyuu
:: Synchronizing package databases…
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases


#32

Sigh. The answer was in my own dumbass post. I needed to run:

sudo rm /var/lib/pacman/db.lck


#33

everything working again?


#34

Hi everybody.
I just messed up my system in chroot so I did a fresh installation from the live USB.
Now everything is working fine except for the language pack - I cannot install it because it requires my system to be updated, but I cannot update systemd or libidn2 because my system will break again.
So, any ideas on how to solve this?
Regards :slight_smile:


#35

I reinstalled from a USB-stick taken late nov 2018. After that I ran an update about 660 packages to become up to date without any problems.
So I am current without any serious problems.


#36

What versions of libidn2 and systemd do you have installed?


#37

you cant just not update. run the update, if it does not finish all the way, dont reboot. ask for help then. if it fails at libidn , symlink and run update again.

iirc someone else just created a /usr/lib/libidn2.so.4 with no content and then ran update and it worked so take your pick and dive in. just dont reboot if it fails and then ask for further help. i think you’ll be fine


#38

None of the solutions or guides above worked for me, this is how I fixed it.

Boot via a live USB and connect to the internet:

Update

sudo pacman -Sy

find the root disk you are trying to solve (usually the biggest /dev/ partition for me it was sda2)

sudo fdisk -l

mount the disk

sudo mount /dev/sda2 /mnt

install arch install-scripts

sudo pacman -S arch-install-scripts

Download the clean libidn2 file

https://pkgs.org/download/libidn2

Restoring libind2* files

Extract the files
copy the /usr/ folder and it's contents over to the /usr/ folder on the root drive
Merge the contents

chroot into the drive

sudo mhwd-chroot-shell

Force the new merged files

pacman -S libidn2 --force

Update

pacman -Syu

Repair

pacman -S systemd

This can be done before or after the boot ( I did it before the boot because without it it wouldn’t boot)

sudo pacman -Syyuu

To be sure check the commands again

pacman -S libidn2 --force
pacman -Syu
pacman -S systemd
sudo pacman -Syyuu(optional)

Exit the terminal

exit

Shutdown

sudo shutdown now

Remove the Live USB

Pull it out of your machine

Boot up

and after a few seconds it should start booting normally

Pro tips:

  1. Read the documentation before you update
  2. Never reboot during updates
  3. https://github.com/teejee2008/timeshift (Back-ups)
  4. Manjaro Spin (https://www.youtube.com/watch?v=B--je--m0VI&t=48s) or Persistent Live USB (https://www.howtogeek.com/howto/14912/create-a-persistent-bootable-ubuntu-usb-flash-drive/) (<works on Manjaro as well) to keep working when you break your pc.

#39

libidn2: version 2.1.1-2
systemd: 241.159-1


#40

I tried the arch-install-scripts (example from another thread) and that did not work for me. Then I thought it was getting too complicated and re-installed from USB.


#41

and you were right, doing all that is not necessary. either symlink or a fake file seems to be enough, i’d go with symlink but either way should be enough.