Manjaro Stuck on Boot at "Starting Wait for Plymouth Boot Screen to Quit"

bumblebee
plymouth
update
kde
nvidia

#1

I did around 222 updates which octopi suggested me and I also installed powertop. But when I restarted my laptop it got stuck on Boot at “Starting Wait for plymouth Boot screen”. I’m still relatively new to Linux and my work is stuck. Please help me.


System Specs :

Desktop: KDE Plasma 5.9.3 (Qt 5.8.0) Distro: Manjaro Linux
Machine:   Device: portable System: Alienware product: Alienware 15 v: A06
           Mobo: Alienware model: Alienware 15 v: A00
           UEFI: Alienware v: A06 date: 07/24/2015
Battery    BAT1: charge: 21.9 Wh 42.2% condition: 51.8/64.0 Wh (81%)
           model: TOSHIBA PABAS0241231 status: Discharging
CPU:       Quad core Intel Core i7-4720HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20792
           clock speeds: max: 3600 MHz 1: 2600 MHz 2: 2603 MHz 3: 2600 MHz
           4: 2733 MHz 5: 2599 MHz 6: 2712 MHz 7: 2652 MHz 8: 2600 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller                                                                            
           bus-ID: 00:02.0                                                   
           Card-2: NVIDIA GM204M [GeForce GTX 970M] bus-ID: 01:00.0          
           Display Server: X.Org 1.19.2 driver: intel                        
           Resolution: 1920x1080@60.02hz                                     
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 17.0.1 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.13-1-MANJARO
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: 20:47:47:b8:79:93
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: 40:b8:9a:4f:97:13
           Card-3: Qualcomm Atheros usb-ID: 003-003
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (1.6% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 58G used: 6.4G (12%) fs: ext4 dev: /dev/sda10
           ID-2: /home size: 41G used: 311M (1%) fs: ext4 dev: /dev/sda11
           ID-3: swap-1 size: 8.98GB used: 0.00GB (0%) fs: swap dev: /dev/sda12
Sensors:   System Temperatures: cpu: 62.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 199 Uptime: 50 min Memory: 1476.2/7873.2MB
           Init: systemd Gcc sys: 6.3.1
           Client: Shell (bash 4.4.121) inxi: 2.3.8


Which updates to install and which not to?
#2

You are not alone with this after the last update - the change in the mesa stack and stuff killed quite a view installs with dedicated GPUs (and switchable ones).
Have a look at this post:

And every other thread with “stuck on black screen”

Also in the update announcement thread a view solutions are given:


#3

I’m unable to understand the stuff given in the links. Can you please provide a detailed solution?
Also I can connect to the internet via WIFI only.


#4

First of - can you switch to another tty try using ctrl+alt+F3 which should give you a text console asking for username and password.

There you login than use sudo -s to become root

than try pacman -Syyu

Wait, you have no way of getting online without wifi? - can try to do that from the CLI but first plz confirm that you can loginto your box after all (see above, the tty part)


#5

As @Th3Z0ne suggest, but I want to add that you can try to connect to WiFi from TTY with the command nmtui.


#6

I did what you asked (I connected to the net via USB tethering from my phone) but when I restarted again, it got stuck at the same message “Starting Wait for Plymouth boot screen to quit”.


#7

As you have switchable graphics - you most likely have bumblebeed also - have you tried what is said here:

What is it that you do not understand?


#8

It says:

For instance on my update this morning

$ cat /var/log/pacman.log | grep pacnew
[2017-04-03 10:31] [ALPM] warning: /etc/bumblebee/bumblebee.conf installed as /etc/bumblebee/bumblebee.conf.pacnew

What exactly do I need to do here? Do I have to first switch to another tty using ctrl+alt+F3 and then type the command “cat /var/log/pacman.log | grep pacnew”


It also says:
You will need to manually replace your old conf file with the conf.pacnew, just make sure you backup the old one first.

sudo mv [conf-file] [conf-file].bak
sudo mv [conf-file].pacnew [conf-file]

How do I manually replace my old conf file? Do I just exactly copy the above commands into that another tty ?


#9

From here I can start explaining :slight_smile:

Yes switch to a tty where you actually can login and get a text console (and become root = sudo -s) where you have to work as root now:

There issue the command cat /var/log/pacman.log | grep pacnew to see if pacman actually gave you a new bumblebee.conf.pacnew this step is to confirm that your error is the same one =) [ there could be more lines - but its about bumblebee now]

If there is that line about pacnew than navigate to /etc/bumblebee/bumblebee.conf (cd) than there doublecheck with ls if there are bumblebee.conf and bumblebee.conf.pacnew if so use mv (move) to rename the old bumblebee.conf into bumblebee.conf.OLD (mv bumblebee.conf bumblebee.conf.OLD);
That way there now is no bumblebee.conf in the /etc/bumblebee directory anymore (wich you can confirm with ls again)
Now that this has happened use mv to rename bumblebee.conf.pacnew into bumblebee.conf (mv bumblebee.conf.pacnew bumblebee.conf) this way it takes the place of the old not working config.


#10

I did exactly as told me


It still got stuck but this time at “Starting terminate Plymouth Boot Screen to Quit”. Also, this time steps before getting stuck were slightly different.


#11

Ok, now lets try this:

ctrl+alt+F3 (switch the tty again) -> login -> sudo pacman -Syyu

This should hopefully update all packages that are still not properly done and resolve it for you too. - if that’s not it plz post the error messages - of the pacman update =)


#12


#13

uhm … yeah … so we moved the pacnew config into place for bumblebee, we ran pacman -Syyu and it says its done… ugh… I am not certain what to do next. Paging someone much more knowledgeable than me ^^

@eugen-b do you have any idea what still could halt the system from booting - or what else to do to find out?


#14

@eugen-b @Th3Z0ne Please help me out. I need to submit a project on Monday and my work is stuck due to this.


#15

I have no idea about bumblebee and nvidia stuff. :frowning: If nobody can help, reinstall with non-free option.


#16

:sweat: :sweat: :sweat:
Do you know someone who could ?


#17

I added nvidia and bumblebee tags so knowledgeabale people will notice. But at the moment there are many users with problems.


#18

@geekyJock if your in a time hurry - either as already suggested do a re-install or just run from a liveUSB and finish your project that way (live CD if absolutely needed) and when that is done - we can try to work that out for you.

One last idea I got - force bumblebee to be reinstalled:

sudo pacman -S bumblebee - it will ask you that that will be a reinstall confirm and proceed.

And do my a favour - run

sudo cat /var/log/pacman.log | grep pacnew again and show me the output if there is any
and
sudo find / -name “*.pacnew” as well, that way - maybe there is still some config that needs update


#19


#20

Alright alright - lets see if it now bootsup in the graphic UI; sudo reboot now =)

That also helped somone else on the forum sudo pacman -S video-hybrid-intel-nvidia-bumblebee also worth trying.

If that wasnt it I would now go and adjust the wrong directory permissions so

chmod 755 /usr/
chmod 755 /usr/lib/
chmod 755 /usr/bin/
chmod 755 /usr/share/
chmod 755 /usr/share/doc/
chmod 755 /usr/lib/systemd/
chmod 755 /usr/lib/systemd/system/

I have no clue why or how they changed but 700 means ONLY root has access read/write/execute but also other “users” need to at least read and execute in those directorys - so that is what 750 does = it means user=rwx group=rx others=nothing - not sure if thats fatal but could be corrected.

-= sadly its 10:30pm now - i need to see my bed - all the best luck for tnight =-