Manjaro Strange Error - not detecting SSD UUID to update



I am currently using Hp elitebook 840r g4 dual boot (windows + manjaro kde)

My laptop has two disks, 1 ssd and 1 hard-disk

Manjaro is installed on hard-disk, but the boot-loader of whole system is in SSD. Last night while i was using laptop (inside manjaro), I felt some lag so i tried to restart the laptop. Almost everything works fine, but there was some error on screen “failed on unmount /run/user/1000”. But laptop automatically reboots, and next thing i know it is showing “3f0” error that is boot device not found. I tried to diagnose the system and found out that laptop is not detecting SSD, where the boot loader is installed. I checked that first by running Hardware diagnostic test from bios where ssd was showing up and the boot into the system using live USB.

So now I have 2 questions

  1. How I can install boot loader on my hard disk?
  2. What could be the reason of not detecting SSD, because I can remember that SSD was working fine before reboot?

I managed to install bootloader by live usb and manjaro-chroot. But when I turned on the system, it ran into emergency mode.

The “emergency-mode” problem is fixed now, It was due to a wrong entry in the /etc/fstab file. Atleast now I can use my system. For SSD , I think I should look for hardware support .

if you have created a partition EFI ,
you have get new UUID that are required to be updated in /etc/fstab

see your edit2 , to close

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.