Manjaro stop booting [LUKS+LVM]

I have this PC where my Manjaro stop booting. Everything that I'm gonna tell is about this PC.
It has BIOS (not UEFI).

I have installed Manjaro using Manjaro Architect and I have set up one partition that uses the full disk (through cfdisk), put that partition with LUKS, and inside of LUKS I have LVM with 2 volumes - one for / and the other for /home.

This system was working fine.
But with the last update (that included and linux kernel update and I followed with a reboot) my machine stop booting sucessfully. I now get this error message (on boot):

The device /dev/mapper/vg-raiz is my LVM volume that mounts for / .

When I have done this last update, it led to make a Grub - I think it is - update (automatically made by pacman) and in that update I got a message similiar to this:

... something about lvm or vgs ... leaked
(maybe it was)
... leaked on vgs invocation.... 

So, now it is not booting. Need help, please

  1. Backup?

  2. Refresh mirrors - pacman Syyu

  3. Wrong UUID cat /etc/fstab

  1. This is the second time that this happens since I decided to use LUKS+LVM on this computer. The decision of using LUKS+LVM was less then 1.5 months ago, so this is happening very often (for some reason) and can't afford to always 'backup&restore' when this happens.
  2. I will, but with my system broken, in what way would this help?
  3. I haven't changed the UUID in /etc/fstab (and don't know which is the right UUID, so I can't make this verification) so I doubt the problem comes from here and also this is option is not helpful for me

with a live distro, on a chroot of my PC installed system, I have also tried changing to this on /etc/lvm/lvm.conf

use_lvmetad = 0

made a pvscan --cache and also

grub-install /dev/sda
update-grub

and still I get the same (boot) error... (which is on the image above)

Also, my system is BIOS and the partition table is dos (i guess MBR?).

sudo blkid
cat /etc/fstab

If that happened all the time, I'd think about my backup strategy.

That's all I can do here. Good luck fixing it.

I have installed using the manjaro-architect tool, no deviation was made by me, and now I have to fix it?
@SGS shouldn't manjaro-architect produce a not-breakable-system when doing an update?
Good luck fixing your system? You might as well be honest and say f*ck you

No, "That's all I can do here. Good luck fixing it."

Do you check fstab and blkid?

Yup. All correct.
Also done the pacman-mirrors -f 0 and pacman -Syyu and was not helpful

Well, can anyone give me any help?
Any pointers?

From the error message from the image above, I have solve the error message of the first line (which was: ERROR: device '/dev/mapper/vg'-raiz' not found. Skipping fsck by going to /etc/mkinitcpio.conf and adding to HOOKS the 'lvm2' word (I have put it before 'filesystems') and removing the 'fsck' word. Then, inside chroot, I have done mkinitcpio -p linux419

Now I still get a boot error, with the message:

mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

The error might be on the new, and updated, systemd.
I'm trying to downgrade systemd, from a chroot, but I always get a cannot downgrade, missing DOWNGRADE_FROM_ALA stuff.

So I have tried doing (from chroot) DOWNGRADE_FROM_ALA=1 downgrade systemd... still get the same downgrade error... and adding (inside chroot) 'DOWNGRADE_FROM_ALA=1' to /etc/environment but still the downgrade command DOES NOT WORK!

What the hell is happening? Help, educated me, why is not working? Am I missing something? (I'm following all the documentation)

I have tried everything. Nothing that I have tried have worked.

I can help you improve Manjaro but you need to help me

This situation needs someone that really knows what he/she is talking about, to do a proper debug of my system error

I'm really no expert on encrypted volumes but I guess your fstab could be helpful.

As fsck shall not applied to an encrypted voume I would assume that "pass" could be required to be "0" for your partition containing /.

https://wiki.archlinux.org/index.php/Dm-crypt/Encrypting_an_entire_system

@Wollie I don't know what "pass" is, but my /etc/fstab is:

#/dev/mapper/vg-raiz
UUID=c3..........  /  reiserfs  rw,relatime,notail  0 0

#/dev/mapper/vg-casa
UUID=97..........  /  reiserfs  rw,relatime,notail  0 0

OK, that looks to be OK.

Also my LVM on LUKS has the /boot inside the encrypted (through LUKS) LVM Volume.

my inspiration for this was https://www.pavelkogan.com/2014/05/23/luks-full-disk-encryption/ , although I have used manjaro-architect to configure this set-up (not the commands that Pavel Kogan says)

Next time setting up the system, better try to keep it outside.

Yeah. Ain't it a security risk? (unencrypted /boot)

I don't think so, as long as you are not protecting the system against certain agencies... :sunglasses:

Forum kindly sponsored by