Manjaro (Stable) Update Confusion

yesterday, I decided to update my system(stable) today.
I do not use anything for it but pamac-manager.

So, yesterday, I run:
Add/Remove Software -> Preferences -> Official Repositories
Use mirrors from Germany -> Refresh Mirrors List
and then Refresh databases.

Result: A long list of packages to update. So far so good!

I canceled the update process, postponed it to today.

Add/Remove Software -> Updates

Message: Your system is up-to-date ??? huh?

Well, for sure, it is not!

Lets check what Manjaro Settings think:

Manjaro Settings -> Kernel
Linux 5.4.85 Running, Installed ??? huh?

$ uname -a
Linux … 5.4.80-1-MANJARO …
Thats right!

OK then, again:
Add/Remove Software -> Preferences -> Official Repositories
Use mirrors from Germany -> Refresh Mirrors List
Refresh databases

This time I run the update immediately! No issues!

No issues? I guess because I just have one kernel version installed(LTS 5.4)
and Nvidia 440.100, which got updated to 455.45.01 seamlessly.

(This is true for GNOME as well as for KDE (second environment),
XOrg 1.20.10, no sddm or gdm issues, applications start,run).

Thank you very much, Manjaro Team, for working hard for stabilizing this complex distribution.

Does someone know why pamac-manager(and manjaro settings) thought the system was up-to-date?

I do not use pacman(maybe pamac does?). There I read:
Every run of pacman-mirrors requires you to syncronize your database and update your system.
Well, I got a Database Refresh after Mirroring from one server in the list yesterday
and did not change the list again today.

What was it doing when you cancelled it?

If it was still downloading packages and hadn’t started installing yet, that would have been fine. However, it sounds like it got a little further than that.

Canceled via button (Cancel instead of Apply).
It was doing nothing because it was waiting for confirmation.
Nothing got downloaded.
The (not started(applied) update) process stopped and the Browse window came back.

I did not cancel/interrupt a running download/install process. Instead, I denied the start of the update process

Type sudo pacman -Sc in the terminal and confirm the query with YES. This removes old packages from the /var/cache/pacman/pkg/ buffer, which could potentially interfere with a fresh update. After that try again sudo pacman -Syyu.

It’s just an idea of mine …

Thanks for the hint.
I don’t keep old packages in that cache and I prefer to use pamac-manager:

Add/Remove Software -> Preferences -> Cache
Number of versions of each package to keep in the cache: 0
To delete: 0 files (0 bytes)

Also the update has been finished now without any issues(no need to apply pacman).
The bug is that the system thinks it is up-to-date in between, that is
after refreshing mirrors/databases and … (cancel/do not apply update but pause until next day) …
before doing the real update.