Manjaro Stable/KDE HP Pavilion Gaming resume issues

HP Pavilion Gaming dual boot system w/ Manjaro Stable, KDE desktop… the system is

Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.23.4
Distro: Manjaro Linux
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A
Mobo: HP model: 87B2 v: 31.23 serial: UEFI: AMI v: F.25
date: 08/18/2021
ID-1: BAT0 charge: 35.5 Wh (68.7%) condition: 51.7/51.7 Wh (100.0%)
volts: 11.8 min: 11.6
Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
type: MT MCP cache: L2: 4 MiB
Speed (MHz): avg: 1400 min/max: 1400/2900 cores: 1: 1400 2: 1400 3: 1400
4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400 11: 1400 12: 1400
13: 1400 14: 1400 15: 1400 16: 1400
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
v: 495.44
Device-2: AMD Renoir driver: amdgpu v: kernel
Device-3: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB
driver: uvcvideo
Display: x11 server: driver: loaded: amdgpu,ati,nvidia
unloaded: modesetting,nouveau resolution: <missing: xdpyinfo>
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.7-1-MANJARO LLVM 13.0.0)
v: 4.6 Mesa 21.2.5

Have 10GB /swap. In troubleshooting this I find that /etc/systemd/sleep.conf has all of the options commented out. Without taking a wild stab at commenting in stuff without fully understanding I wanted to ask those wiser than am I. Sleep.conf looks like this

#SuspendState=mem standby freeze
#HibernateMode=platform shutdown
#HybridSleepMode=guides on this suspend platform shutdown

I am working my way through the Manjaro and Arch guides on this and thought I would ask…


OK Issue solved. Hibernator was NOT installed during the original install.

sudo pacman -S hibernator

then reboot and all is good. Hibernates and wakes up. Interestingly when I installed Manjo on this laptop the installer didnt ask for nor did I intervene in not creating /swap. When no resume, the research on the problem led me to the importance of a properly designated /swap file and this may have been the problem and the reason hibernator wasnt installed. All good. thanks for the excellent wikis. For those so curious I found this thread

with excellent outlining of what hibernator seems to do step by step so hopefully this will help.
Regards and thanks Manjaro for the great documentation.

Not solved. Works well with the laptop plugged in. On battery no. Wont resume and has to be done by a hard power down. Removed tlp and problem solved. Now where is the culprit… reinstalled tlp with its default settings instead of where I had been changing things and now we are able to resume from sleep (lid closed) so far without any problem… note----one is well served to install the tlpui which brings desktop control. be aware of either when configuring tlp with cli… or under general settings on tlpui, third item down, tlp default mode… if on a laptop… needs be set to bat. then next item down, tlp persistent default should be 0 “depends on power source”. This so far is working for me.

What I believe caused my problem was what I changed in an effort to insure the NVidia 1650Ti was completely powered down when not needed—various tlp settings on the PCIe bus… causing a fail to resume. . Hope this helps.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.