Manjaro-specific packages which need an update

liri-browser development has moved to https://github.com/lirios/browser

previously at https://github.com/liri-project/liri-browser

Does Manjaro really need this package?

And also this https://github.com/manjaro/packages-community/tree/master/chromium-pepper-flash-manjaro

chromium-pepper-flash-manjaro infact doesn’t exist as a package in the repo any more.
liri-browser is a good question! :wink: @Kirek do you remember why we have this?

We added it waaay back to test it as a browser for the minimal kde edition.
I don’t think we ever used it, at that time it still needed a lot of work to be good. I think it can be removed now.

I have noticed that xtitle package required by bspwm-scripts and lemonpanel is quite old (2014) in Manjaro repo. There are xtitle and xtitle-git in the AUR.

I tried xtitle-git. It seemed to work just like always. The only difference I noticed was that the package was smaller. But yes, it could use some upgrading.

What you want ? Stable or git version ?

I found that xtitle from repo doesn’t work with negative truncate option (e.g. -t -20). I looked at github page of the project and saw that the issue was connected with utf-8 support and that the developer closed this issue about a month ago. So I installed git version. Now truncation with negative values works with utf-8 locale. I haven’t tried xtitle from AUR, but it seems recently updated.

No problem if git version works fine i can grab from there :wink:
Edit : yes stable release on aur is up to date …
Edit2 : update : in unstable now

2 Likes

hmm… it seems xitle update breaks limepanel horribly… to fixing it then. I suggest xtitle does not move to stable before limepanel is updated.

I composed a list of community packages (testing branch, x86_64) sorted by the year of build date using this one-liner:
for i in $(pacman -Sql community); do printf "%s\t%s\n" "$(pacman -Si $i | grep '^Build Date' | grep -o '[[:digit:]]\{4\}$')" "$i"; done | sort > community_dates.txt

Some of them are quite old. The result is here:

http://pastebin.com/YGYYgMuG

EDIT. And here is a list of community packages that are in AUR (with the same name) generated with
for i in $(pacman -Sql community); do package-query -A --nameonly -f '%n' $i; done > community_in_AUR.txt

http://pastebin.com/vxXq6MiJ

And the same with dates:

http://pastebin.com/yacNmMqE

1 Like

Something is not ok on my recent KDE install, when I want to install kde-servicemenus-rootactions I get this:

     Enter a number between 0..24 and press [Enter] - 0 Exit Pacli
3

[sudo] password for eugen: 
error: could not parse package description file 'zathura-ps-0.2.4-1/desc' from db 'community'
resolving dependencies...
looking for conflicting packages...

Packages (2) kdialog-16.12.1-1  kde-servicemenus-rootactions-2.9-2

Total Download Size:   0,02 MiB
Total Installed Size:  0,22 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from repo.stdout.net : The requested URL returned error: 404
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from ftp.tu-chemnitz.de : The requested URL returned error: 404
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from mirrors.cicku.me : The requested URL returned error: 404
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from repo.rhindon.net : The requested URL returned error: 404
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from mirror.netzspielplatz.de : The requested URL returned error: 404
error: failed retrieving file 'kde-servicemenus-rootactions-2.9-2-any.pkg.tar.xz' from mirror.ragenetwork.de : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
Repository      : community
Name            : kde-servicemenus-rootactions
Version         : 2.9-2
Description     : Allows admin users to perform several root only actions from dolphin via kdesu/kdesudo
Architecture    : any
URL             : http://www.kde-apps.org/content/show.php?content=48411
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : dolphin  kdialog
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Download Size   : 19,73 KiB
Installed Size  : 115,00 KiB
Packager        : Ramon Buldó <ramon@manjaro.org>
Build Date      : Sa 17 Dez 2016 15:17:44 CET
MD5 Sum         : 4ddac339cec571e59b59d645659442e6
SHA-256 Sum     : 5c8b841b2c2743806c3a2e03617aee9c87202957b5a9c042ee43fa8cc5336183
Signatures      : 2C089F09AC97B894

Update: I switched to unstable and was able to install the following version:

Name            : kde-servicemenus-rootactions
Version         : 2.9.1-1
Description     : Allows admin users to perform several root only actions from dolphin via kdesu/kdesudo
Architecture    : any
URL             : https://www.kde-look.org/content/show.php/Root+Actions+Servicemenu?content=48411
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : dolphin  kdialog
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 104,00 KiB
Packager        : Ramon Buldó <ramon@manjaro.org>
Build Date      : Sa 28 Jan 2017 11:21:27 CET
Install Date    : Di 07 Feb 2017 13:12:00 CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
Backup Files    :
(none)

And it works fine! Thanks @Kirek!

This is usually because the package has been removed/updated/downgraded in the repo, since you last got an updated database.
Doing a “sudo pacman -Syy” should fix that for you.

You are probably right, I switched back to testing and now the new version is there, too.

Hi thank you for this list :slight_smile: only we need help : i don’t think we know all of this pkgs … i want know what can be removed and what can be updated :slight_smile: we need community help :wink:

I think a package from AUR should be kept in community repository if it is included in any of official or community Manjaro editions. All other packages might just be installed from AUR. So a list of all packages from all Manjaro iso profiles can help to decide what should be kept in repo.

Xboomx can be removed unless jwm or some other edition has started to use it.

I think juffed-qt5 needs an update

/tmp >>> juffed                                                                                                                                                                              
juffed: error while loading shared libraries: libqscintilla2-qt5.so.12: cannot open shared object file: No such file or directory

/tmp >>> ls /usr/lib | grep libqscintilla2                                                                                                                                                [1]
libqscintilla2_qt5.so
libqscintilla2_qt5.so.13
libqscintilla2_qt5.so.13.0
libqscintilla2_qt5.so.13.0.0

So, the current version is 13.

Or consider dropping juffed-qt5 and package featherpad or featherpad-git instead. To build featherpad-git you need qt5-tools as dependency which is not mentioned in AUR.

If there is a point release available, it should always be preferred over git or svn version for the repos.

I have packed for @Esclapion request . @artoo what you want use in lxqt ?

The AUR version is V0.5.8, the git version is V0.5.9: https://github.com/tsujan/FeatherPad/blob/master/ChangeLog
I was not able to download the .tar.gz for V0.5.9

/tmp >>> wget 'https://github.com/tsujan/FeatherPad/archive/V0.5.9.tar.gz'                                                                                                              [127]
--2017-03-02 18:47:50--  https://github.com/tsujan/FeatherPad/archive/V0.5.9.tar.gz
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving github.com... 192.30.253.113, 192.30.253.112
Connecting to github.com|192.30.253.113|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/tsujan/FeatherPad/tar.gz/V0.5.9 [following]
--2017-03-02 18:47:52--  https://codeload.github.com/tsujan/FeatherPad/tar.gz/V0.5.9
Resolving codeload.github.com... 192.30.253.120, 192.30.253.121
Connecting to codeload.github.com|192.30.253.120|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-03-02 18:47:53 ERROR 404: Not Found.

/tmp >>> wget 'https://github.com/tsujan/FeatherPad/archive/V0.5.8.tar.gz'                                                                                                                [8]
--2017-03-02 18:48:08--  https://github.com/tsujan/FeatherPad/archive/V0.5.8.tar.gz
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving github.com... 192.30.253.112
Connecting to github.com|192.30.253.112|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/tsujan/FeatherPad/tar.gz/V0.5.8 [following]
--2017-03-02 18:48:10--  https://codeload.github.com/tsujan/FeatherPad/tar.gz/V0.5.8
Resolving codeload.github.com... 192.30.253.121
Connecting to codeload.github.com|192.30.253.121|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 116910 (114K) [application/x-gzip]
Saving to: ‘V0.5.8.tar.gz’

V0.5.8.tar.gz                                   100%[=====================================================================================================>] 114,17K   273KB/s    in 0,4s    

2017-03-02 18:48:12 (273 KB/s) - ‘V0.5.8.tar.gz’ saved [116910/116910]