Manjaro-specific packages which need an update

development
package
manjaro

#270

paper-icon-theme could be removed, is not used anymore by jade, unless someone wants to keep it.

also webdad-workspaces package.


#271

Maybe it’s time to update
cower 17-1 --> 18-1 and
pacaur 4.7.10-1 --> 4.7.90-1
so that pacaur could work with pacman 5.1.0 (libalpm.so.11). I’ve installed them from AUR and they seem to work OK.


#272

Done, thank you :wink:


#273

was pacaur picked up by someone?


#274

I think not. AUR page has a pinned comment

[2017-12-15] This project is now unmaintained. Users are encouraged to move to another solution (see wiki for alternatives).

Nevertheless Spyhawk, its (former) maintainer has updated it

Last Updated: 2018-05-30 14:21


#275

I noticed that acetoneiso2 is still present in Arch Linux’s repos, but is missed in manjaro stable brach repos. Can you consider to update and re-introduce it?


#276

I assecond this, old url has been removed https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/acetoneiso2&id=4d527af0bff4fa337bf656500a6bad097826f24f


Was removed for Cryptocurrency ads in acetoneiso2 from repo!


#277

Ok. I have removed it from our exclude list. Will be synced again.


#278

It seems the snapd package is outdated. The snapd is currently at version 2.30 in the community Repository.

The Github page suggest the newest version is 2.33.1, which is also the current AUR version of snapd .


How to find out what version of a package is in Manjaro?
#279

June 30, 2018 (Europe: Paris), June 29, 2018 (America: Los Angeles)

snapd and snapd-git

Rebuild from AUR and uploaded to unstable


#280
manjaro:~ >>> pacman -Dkk
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-elegant'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-elegant-hidpi'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-very-elegant'
error: missing 'plymouth' dependency for 'plymouth-theme-sonar-elegant'
error: missing 'linux-hardened' dependency for 'usbctl'
error: missing 'deepin-artwork-themes' dependency for 'deepin-artwork-themes-manjaro'
error: missing 'sdlmame' dependency for 'gnome-video-arcade'
error: missing 'jade-dashboard' dependency for 'jade-desktop-mode'
error: missing 'dropbox' dependency for 'kde-servicemenus-dropbox'
error: missing 'linux416-rt-rt3562sta' dependency for 'linux-rt-manjaro-rt3562sta'
error: missing 'manjaro-wallpaper-17.0' dependency for 'manjaro-openbox-theme-17.0'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-cinnamon'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-circle'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-deepin'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-deepin-circle'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-extra-elegant'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-fancy-budgie'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-gnome'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-gnome-17.0'
error: missing 'plymouth' dependency for 'plymouth-theme-manjaro-redefined-bsplash'
error: missing 'polkit-qt' dependency for 'razor-qt'

I think that every Plymouth theme can be removed from repositories, idem for kde-servicemenus-dropbox since there is no dropbox in repositories anymore.

gnome-video-arcade I think it has been included by @Ste74 for Manjaro GNOME and deepin-artwork-themes-manjaro included by @oberon for Manjaro Deepin, maybe manjaro-openbox-theme-17.0 has been included for Manjaro Openbox by @fhdk?
razor-qt packaged by @philm , are you considering a new Manjaro spin? :grin:

jade-dashboard should be added if Jade Desktop is officially supported by Manjaro.

I do not know what linux-rt-manjaro-rt3562sta is used for, it has been packaged by @oberon.

At last usbctl has been packaged by Arch guys so it is their fault. :grinning:

I am not familiar with tools used by Manjaro repository, but it could be a good choice to include an automatic check with email notification to the packager.
Linus would answer me: “Words are cheap, give me the code!


[Stable Update] 2018-07-13 - Kernels, Firefox, Octopi, Adapta, Haskell, Python
#281

I can answer only for plymouth-themes and for gnome-video-arcade:

  • i have removed plymouth some time ago but not the themes because if an user want use plymouth why not leave free to install manjaro theming

  • for gnome-video-arcade i have packaged for Sonar project but since seem not developed at now we remove all packages related at Sonar at some point

:wink:


#282

I have thought about this case, probably the best choice is to upload them on AUR, not really funny but you achieve a more consistent organization. :wink:

How can they install a package without a needed dependency? They have an indipendent Sonar repository?
In any case this application is out of place in a repository without its dependencies.

In both cases above I have expressed my point of view, obviously you have a more general overview of the situation and you can evaluate it differently.


#283

Remember what mean AUR ( Arch User Repository ) so Manjaro is compatible with AUR but AUR is build for Arch… in the past TU deleted themes packages because not branding or related at Arch :sweat_smile: so in AUR is not possible host pkgs with manjaro brand :grinning:


#284

Mmm… this makes almost sense, I do not know any alternative but neither I like the actual situation, it’s a draw, I leave the field. :zipper_mouth_face:


#285

I dont think thats entirely true - atleast not for themes and such:

268 aur/papirus-maia-icon-theme-git 20180417.6d88bb2-1 (+0 0.00%) (Orphaned) 
    Manjaro variation of Papirus icon theme (git version)
267 aur/kdeartwork-wallpapers-manjaro-redefined 1.0-2 (+1 0.00%) (Out-of-date 2017-12-19) 
    Manjaro Redefined Wallpaper.
266 aur/numix-manjaro-borders 1.0.1-1 (+2 0.00%) 
    Variant of Numix-Manjaro with larger borders (coming from Straight variant)
265 aur/openbox-theme-menda r91.2759ebc-1 (+4 0.00%) 
    Manjaro's Openbox theme
264 aur/xcursor-maia 20160417-1 (+5 0.00%) (Orphaned) 
    Cursor theme - part of the Manjaro Maia set
263 aur/arc-dark-lxqt-manjaro 1-6 (+7 0.00%) 
    Arc-dark theme for lxqt panel
262 aur/archey-plus 0.2.8-1 (+9 0.02%) 
    Based on Archey 0.2.8, adding support for Manjaro, Cinnamon dm/me, and bug fixes
261 aur/xcursor-menda-git r4.e350325-2 (+13 0.00%) 
    Cursor theme - part of the Manjaro Menda set
260 aur/yaourt-gui-manjaro 1.4.5-2 (+23 0.62%) (Out-of-date 2017-10-24) 
    A bash GUI for yaourt (Manjaro theming) and Romanian translation added
259 aur/compiz-manjaro 0.9.13.0-5 (+26 0.07%) (Out-of-date 2017-01-20) 
    OpenGL compositing window manager. Includes friendly defaults, GWD theme selector and autostart for Xfce & MATE.
258 aur/menda-themes-dark-git r85.0ee4e31-3 (+42 0.83%) 
    Manjaro's official Gtk2, Gtk3, Metacity, Xfwm, Openbox, Cinnamon and GNOME Shell themes. Dark version.
257 aur/menda-themes-git r85.0ee4e31-3 (+42 0.83%) 
    Manjaro's official Gtk2, Gtk3, Metacity, Xfwm, Openbox, Cinnamon and GNOME Shell themes

#286

Well seem i m in the black list of TU :joy:
https://lists.archlinux.org/pipermail/aur-requests/2017-December/020994.html
https://lists.archlinux.org/pipermail/aur-requests/2017-December/020996.html
https://lists.archlinux.org/pipermail/aur-requests/2017-December/020997.html
https://lists.archlinux.org/pipermail/aur-requests/2017-December/020998.html
I think TU don’t see the other in AUR :wink:


#287

The more useful item is this one: https://lists.archlinux.org/pipermail/aur-requests/2017-December/021035.html

Manjaro themes are fine. Manjaro trademarked themes are not.


#288

@oberon

Cinnamon 3.8.7 released 9 days ago: https://github.com/linuxmint/Cinnamon/releases/tag/3.8.7 .


#289

Sure thing. And I added our version on July 11 :laughing:

Build Date      : Wed 11 Jul 2018 19:47:27 CEST

Just somehow it got stuck on our testing branch - @philm something you need to adjust in your clean-script?
I’ve forwarded it to stable now manually.