Manjaro-specific packages which need an update

Trizen is at version 1.61, but the Manjaro package for it is 1.58.

I will get a new version out tonight/tomorrow with this and some other fixes in place.

3 Likes

systemd-boot-manager is now at 0.8 and needs a rebuild.

I also updated the PKGBUILD to pull from a release tag. I would recommend we update the Manjaro PKGBUILD to do the same since it seems we accidentally pulled in some not ready for release changes somewhere along the way.

My PKGBUILD is here.

Done :wink:

1 Like

@philm spectre-meltdown-checker is now at v0.43.

nautilus-typeahead has not been updated for 3.34.2, are there plans to? All it requires is a version / commit bump.

menulibre needs to be updated urgently. On Testing, system upgrades may be blocked because of the following error.

installing python (3.8.0-1) breaks dependency 'python<3.8' required by menulibre

Last packager is @schinfo .

EDIT: I only have access to menulibre 2.2.8-1 for now. Perhaps I spoke too soon. I'll wait a while.

EDIT2: For some unknown reasons, Pamac (version 9.1.1) does not detect any upgrade for menulibre, while I can see the upgrade with the checkupdates command. I wonder if the transition from -1 to -1.0 is actually handled properly by Pamac.

[froggy@pixel-stable Desktop]$ pamac checkupdates
338 available updates:
alsa-firmware                      1.2.1-1                  extra
alsa-lib                           1.2.1.2-2                extra
alsa-plugins                       1.2.1-1                  extra
alsa-utils                         1.2.1-1                  extra
apparmor                           2.13.3-5                 extra
archlinux-appstream-data           20191128-1               extra
archlinux-keyring                  20191018-2               core
argon2                             20190702-2               core
audit                              2.8.5-6                  core
autoconf                           2.69-6                   core
automake                           1.16.1-2                 core
avahi                              0.7+18+g1b5f401-3        extra
b43-fwcutter                       019-3                    core
bash                               5.0.011-2                core
bashrc-manjaro                     5.0.011-2                core
binutils                           2.33.1-2                 core
bison                              3.4.2-2                  core
blas                               3.9.0-2                  extra
btrfs-progs                        5.4-1                    core
bubblewrap                         0.4.0-1                  extra
ca-certificates                    20181109-2               core
ca-certificates-mozilla            3.48-1                   core
ca-certificates-utils              20181109-2               core
cracklib                           2.9.7-2                  core
crda                               4.14-3                   core
cryptsetup                         2.2.2-1.1                core
cups-filters                       1.25.13-1                extra
dav1d                              0.5.2-1                  extra
db                                 5.3.28-5                 core
device-mapper                      2.02.186-3               core
dhcpcd                             8.1.2-1                  core
diffutils                          3.7-3                    core
ding-libs                          0.6.1-3                  core
dmraid                             1.0.0.rc16.3-12          core
dnssec-anchors                     20190629-2               core
dosfstools                         4.1-3                    core
e2fsprogs                          1.45.4-2                 core
efibootmgr                         16-2                     core
efivar                             37-3                     core
exo                                0.12.10-1                extra
expat                              2.2.9-2                  core
faad2                              2.9.1-2                  extra
fakeroot                           1.24-2                   core
farstream                          0.2.8-3                  extra
file                               5.37-5                   core
file-roller                        3.32.3-1                 extra
filesystem                         2019.10-4                core
firefox                            71.0-1                   extra
flatpak                            1.5.1-1                  extra
flex                               2.6.4-3                  core
gc                                 8.0.4-3                  extra
gdbm                               1.18.1-3                 core
gettext                            0.20.1-3                 core
ghostscript                        9.50-2                   extra
glib2                              2.62.3-1                 core
glibc                              2.30-3                   core
gmp                                6.1.2-3                  core
gnupg                              2.2.18-2                 core
gnutls                             3.6.11.1-1               core
gobject-introspection-runtime      1.62.0-3                 extra
gpgme                              1.13.1-3                 core
gpm                                1.20.7.r27.g1fd1941-2    core
grep                               3.3-3                    core
groff                              1.22.4-2                 core
grub                               2.04-9                   core
gssproxy                           0.8.2-2                  core
gst-libav                          1.16.2-1                 extra
gst-plugins-bad                    1.16.2-1                 extra
gst-plugins-base                   1.16.2-1                 extra
gst-plugins-base-libs              1.16.2-1                 extra
gst-plugins-good                   1.16.2-1                 extra
gst-plugins-ugly                   1.16.2-1                 extra
gstreamer                          1.16.2-1                 extra
gtk-update-icon-cache              1:3.24.13-1              extra
gvfs                               1.42.2-1                 extra
gvfs-afc                           1.42.2-1                 extra
gvfs-gphoto2                       1.42.2-1                 extra
gvfs-mtp                           1.42.2-1                 extra
gvfs-nfs                           1.42.2-1                 extra
gvfs-smb                           1.42.2-1                 extra
gzip                               1.10-3                   core
harfbuzz                           2.6.4-2                  extra
harfbuzz-icu                       2.6.4-2                  extra
hdparm                             9.58-3                   core
hplip                              1:3.19.11-4              extra
hwids                              20191025-2               core
iana-etc                           20191123-1               core
icu                                65.1-2                   core
imagemagick                        7.0.9.7-1                extra
imlib2                             1.6.0-1                  extra
inetutils                          1.9.4-8                  core
intel-ucode                        20191115-2               extra
iproute2                           5.4.0-1                  core
iptables                           1:1.8.3-3                core
iputils                            20190709-2               core
ipw2100-fw                         1.3-10                   core
ipw2200-fw                         3.1-8                    core
iw                                 5.4-1                    core
java-environment-common            3-2                      extra
java-runtime-common                3-2                      extra
jfsutils                           1.1.15-7                 core
json-c                             0.13.1-3                 core
kauth                              5.64.0-2                 extra
kbd                                2.2.0-5                  core
kcoreaddons                        5.64.0-2                 extra
keyutils                           1.6.1-3                  core
kitemmodels                        5.64.0-2                 extra
krb5                               1.17-2                   core
lapack                             3.9.0-2                  extra
ldb                                1:1.5.6-2                extra
ldns                               1.7.1-2                  core
lensfun                            0.3.2-9                  extra
less                               551-3                    core
lib32-alsa-lib                     1.2.1.2-1                multilib
lib32-alsa-plugins                 1.2.1-1                  multilib
lib32-glib2                        2.62.3-1                 multilib
lib32-glibc                        2.30-3                   core
lib32-gnutls                       3.6.11.1-1               multilib
lib32-harfbuzz                     2.6.4-2                  multilib
lib32-icu                          65.1-2                   multilib
lib32-libepoxy                     1.5.4-1                  multilib
lib32-libpng                       1.6.37-2                 multilib
lib32-librsvg                      2.46.4-1                 multilib
lib32-libtiff                      4.1.0-1                  multilib
lib32-libva-mesa-driver            19.2.7-1                 multilib
lib32-libxml2                      2.9.10-1                 multilib
lib32-mesa                         19.2.7-1                 multilib
lib32-nspr                         4.24-1                   multilib
lib32-nss                          3.48-1                   multilib
lib32-systemd                      242.153-2                multilib
libaio                             0.3.112-2                core
libarchive                         3.4.0-3                  core
libassuan                          2.5.3-2                  core
libblockdev                        2.23-3                   extra
libbytesize                        2.1-3                    extra
libcap                             2.27-2                   core
libcap-ng                          0.7.10-1                 core
libelf                             0.177-2                  core
libepoxy                           1.5.4-1                  extra
libevent                           2.1.11-3                 core
libffi                             3.2.1-4                  core
libgcrypt                          1.8.5-2                  core
libgpg-error                       1.36-3                   core
libgusb                            0.3.1-1                  extra
libibus                            1.5.21-3                 extra
libical                            3.0.6-2                  extra
libidn                             1.35-2                   core
libidn2                            2.3.0-1                  core
libimobiledevice                   1.2.0+87+g92c5462-6      extra
libksba                            1.3.5-2                  core
libldap                            2.4.48-2                 core
liblouis                           3.12.0-1                 extra
libmm-glib                         1.12.0-2                 extra
libmnl                             1.0.4-3                  core
libmpc                             1.1.0-2                  core
libnftnl                           1.1.5-1                  core
libnghttp2                         1.39.2-2                 core
libnl                              3.5.0-2                  core
libnm                              1.20.8-1                 extra
libnsl                             1.2.0-2                  core
libpcap                            1.9.1-2                  core
libpipeline                        1.5.1-2                  core
libplist                           2.1.0-2                  extra
libproxy                           0.4.15-13                extra
libpsl                             0.21.0-2                 core
libpurple                          2.13.0-9                 extra
librsvg                            2:2.46.4-1               extra
libsasl                            2.1.27-2                 core
libseccomp                         2.4.1-3                  core
libsecret                          0.19.1-2                 core
libsoup                            2.68.3-1                 extra
libssh2                            1.9.0-2                  core
libsynctex                         2019.51075-4             extra
libtasn1                           4.15.0-1                 core
libteam                            1.29-4                   extra
libtirpc                           1.1.4-2                  core
libtool                            2.4.6+42+gb88cebd5-8     core
libunistring                       0.9.10-2                 core
libusb                             1.0.23-2                 core
libusbmuxd                         2.0.0-2                  extra
libutil-linux                      2.34-8                   core
libva-mesa-driver                  19.2.7-1                 extra
libvoikko                          4.3-1                    extra
libwbclient                        4.10.10-2                extra
libwpe                             1.4.0.1-1                extra
libxml2                            2.9.10-1                 extra
libxslt                            1.1.34-2                 extra
licenses                           20191011-2               core
linux-api-headers                  5.3.1-2                  core
linux-firmware                     20191118.e8a0f4c-2       core
linux53                            5.3.15-1                 core
linux53-virtualbox-guest-modules   6.0.14-12                extra
llvm-libs                          9.0.0-4                  extra
logrotate                          3.15.1-2                 core
lvm2                               2.02.186-3               core
lz4                                1:1.9.2-2                core
lzo                                2.10-3                   core
m4                                 1.4.18-3                 core
make                               4.2.1-4                  core
man-pages                          5.04-2                   core
manjaro-hello                      0.6.3-1                  extra
manjaro-release                    18.1.4-1                 core
manjaro-settings-manager           0.5.6-6                  extra
manjaro-settings-manager-notifier  0.5.6-6                  extra
manjaro-system                     20191208-1               core
mdadm                              4.1-2                    core
mesa                               19.2.7-1                 extra
mhwd                               0.6.3-15                 core
mhwd-db                            0.6.3-16                 core
mhwd-nvidia-440xx                  440.36-1                 core
mkinitcpio-busybox                 1.30.1-2                 core
mlocate                            0.26.git.20170220-2      core
modemmanager                       1.12.0-2                 extra
mpfr                               4.0.2-2                  core
nano                               4.6-1                    core
ncurses                            6.1-7                    core
nettle                             3.5.1-2                  core
networkmanager                     1.20.8-1                 extra
nfs-utils                          2.4.2-1                  core
nfsidmap                           2.4.2-1                  core
npth                               1.6-2                    core
nspr                               4.24-1                   core
nss                                3.48-1                   core
openal                             1.20.0-1                 extra
openexr                            2.4.0-6                  extra
openresolv                         3.9.2-2                  core
openssh                            8.1p1-2                  core
openssl                            1.1.1.d-2                core
ostree                             2019.5-1                 extra
p11-kit                            0.23.18.1-2              core
pacman                             5.2.1-2                  core
pacman-mirrors                     4.15.1-2                 core
pam                                1.3.1-2                  core
pamac-cli                          9.2.0-1                  extra
pamac-common                       9.2.0-1                  extra
pamac-gtk                          9.2.0-1                  extra
pamac-snap-plugin                  9.2.0-1                  extra
pambase                            20190105.1-2             core
patch                              2.7.6-8                  core
pciutils                           3.6.2-2                  core
pcre                               8.43-2                   core
pcre2                              10.34-2                  core
perl                               5.30.1-1                 core
pidgin                             2.13.0-9                 extra
pinentry                           1.1.0-5                  core
pkcs11-helper                      1.25.1-2                 core
pkgconf                            1.6.3-3                  core
poppler                            0.82.0-1                 extra
poppler-glib                       0.82.0-1                 extra
poppler-qt5                        0.82.0-1                 extra
popt                               1.16-12                  core
ppp                                2.4.7-6                  core
pptpclient                         1.10.0-2                 core
procps-ng                          3.3.15-2                 core
protobuf                           3.10.1-1                 extra
psmisc                             23.3-2                   core
pygobject-devel                    3.34.0-3                 extra
pyqt5-common                       5.13.2-3                 extra
python                             3.8.0-1                  extra
python-appdirs                     1.4.3-5                  extra
python-cairo                       1.18.2-3                 extra
python-chardet                     3.0.4-4                  extra
python-dbus                        1.2.14-1                 extra
python-dbus-common                 1.2.14-1                 extra
python-gobject                     3.34.0-3                 extra
python-idna                        2.8-3                    extra
python-packaging                   19.2-5                   extra
python-pep517                      0.6.0-3                  extra
python-pip                         19.2.3-3                 extra
python-pycups                      1.9.74-3                 extra
python-pycurl                      7.43.0.3-3               extra
python-pyparsing                   2.4.5-1                  extra
python-pyqt5                       5.13.2-3                 extra
python-requests                    2.22.0-3                 extra
python-retrying                    1.3.3-6                  extra
python-setuptools                  1:41.6.0-1               extra
python-sip-pyqt5                   4.19.19-3                extra
python-six                         1.13.0-2                 extra
python-urllib3                     1.25.7-1                 extra
python-xdg                         0.26-4                   extra
python2-cairo                      1.18.2-3                 extra
python2-gobject2                   2.28.7-4                 extra
qpdf                               9.1.0-1                  extra
qt5-base                           5.13.2-3                 extra
raptor                             2.0.15-12                extra
readline                           8.0.001-2                core
reiserfsprogs                      3.6.27-3                 core
rpcbind                            1.2.5-3                  core
run-parts                          4.8.6.1-2                core
s-nail                             14.9.15-2                core
samba                              4.10.10-2                extra
sed                                4.7-3                    core
shadow                             4.7-3                    core
smbclient                          4.10.10-2                extra
snapd                              2.42.4-1                 extra
sqlite                             3.30.1-2                 core
srt                                1.4.1-1                  extra
subversion                         1.13.0-1                 extra
sysfsutils                         2.1.0-11                 core
system-config-printer              1.5.12-2                 extra
systemd                            242.153-2                core
systemd-libs                       242.153-2                core
systemd-sysvcompat                 242.153-2                core
talloc                             2.3.0-1                  extra
tar                                1.32-3                   core
tcl                                8.6.10-1                 extra
tdb                                1.3.18-4                 extra
tevent                             1:0.9.39-4               extra
texinfo                            6.7-2                    core
thin-provisioning-tools            0.8.5-3                  core
thunar                             1.8.11-1                 extra
thunderbird                        68.3.0-1                 extra
tzdata                             2019c-3                  core
unrar                              1:5.8.4-1                extra
usbutils                           012-2                    core
util-linux                         2.34-8                   core
vi                                 1:070224-4               core
volume_key                         0.3.12-2                 extra
vte-common                         0.58.3-1                 extra
vte3                               0.58.3-1                 extra
vulkan-icd-loader                  1.1.129-1                extra
webkit2gtk                         2.26.2-2.1               extra
which                              2.21-5                   core
wireless-regdb                     2019.06.03-2             core
wpa_supplicant                     2:2.9-2                  core
wpebackend-fdo                     1.4.0-2                  extra
x264                               3:0.157.r2980.34c06d1-2  extra
xcb-proto                          1.13-4                   extra
xdg-desktop-portal                 1.5.3-1                  extra
xdg-desktop-portal-gtk             1.5.1-1                  extra
xdg-utils                          1.1.3+18+g0547886-4      extra
xfsprogs                           5.2.1-3                  core
xorg-server                        1.20.6-1                 extra
xorg-server-common                 1.20.6-1                 extra
xz                                 5.2.4-2                  core
yelp-xsl                           3.34.2-1                 extra
zlib                               1:1.2.11-4               core
zstd                               1.4.4-1                  core
[froggy@pixel-stable Desktop]$ checkupdates
alsa-firmware 1.0.29-2 -> 1.2.1-1
alsa-lib 1.1.9-2 -> 1.2.1.2-2
alsa-plugins 1.1.9-2 -> 1.2.1-1
alsa-utils 1.1.9-1 -> 1.2.1-1
apparmor 2.13.3-4 -> 2.13.3-5
archlinux-appstream-data 20191027-1 -> 20191128-1
archlinux-keyring 20191018-1 -> 20191018-2
argon2 20190702-1 -> 20190702-2
audit 2.8.5-3 -> 2.8.5-6
autoconf 2.69-5 -> 2.69-6
automake 1.16.1-1 -> 1.16.1-2
avahi 0.7+18+g1b5f401-2 -> 0.7+18+g1b5f401-3
b43-fwcutter 019-2 -> 019-3
bash 5.0.011-1 -> 5.0.011-2
bashrc-manjaro 5.0.011-1 -> 5.0.011-2
bauh 0.7.0-1 -> 0.7.3-1
binutils 2.33.1-1 -> 2.33.1-2
bison 3.4.2-1 -> 3.4.2-2
blas 3.8.0-2 -> 3.9.0-2
blueman 2.1.1-1 -> 2.1.1-2
brotli 1.0.7-1 -> 1.0.7-3
btrfs-progs 5.3.1-1 -> 5.4-1
bubblewrap 0.3.3-3 -> 0.4.0-1
ca-certificates 20181109-1 -> 20181109-2
ca-certificates-mozilla 3.47-1 -> 3.48-1
ca-certificates-utils 20181109-1 -> 20181109-2
catfish 1.4.10-1 -> 1.4.10-2
cpupower 5.3-1 -> 5.4-3
cracklib 2.9.7-1 -> 2.9.7-2
crda 4.14-2 -> 4.14-3
cryptsetup 2.2.1-1.1 -> 2.2.2-1.1
cups-filters 1.25.11-1 -> 1.25.13-1
dav1d 0.5.1-1 -> 0.5.2-1
db 5.3.28-4 -> 5.3.28-5
device-mapper 2.02.186-2 -> 2.02.186-3
dhcpcd 8.1.1-2 -> 8.1.2-1
diffutils 3.7-2 -> 3.7-3
ding-libs 0.6.1-2 -> 0.6.1-3
dmraid 1.0.0.rc16.3-11 -> 1.0.0.rc16.3-12
dnssec-anchors 20190629-1 -> 20190629-2
dosfstools 4.1-2 -> 4.1-3
e2fsprogs 1.45.4-1 -> 1.45.4-2
efibootmgr 16-1 -> 16-2
efivar 37-1 -> 37-3
exo 0.12.8-1 -> 0.12.10-1
expat 2.2.9-1 -> 2.2.9-2
faad2 2.9.1-1 -> 2.9.1-2
fakeroot 1.24-1 -> 1.24-2
farstream 0.2.8-2 -> 0.2.8-3
file 5.37-3 -> 5.37-5
file-roller 3.32.2-1 -> 3.32.3-1
filesystem 2019.10-3 -> 2019.10-4
firefox 70.0.1-1 -> 71.0-1
flatpak 1.5.0-1 -> 1.5.1-1
flex 2.6.4-2 -> 2.6.4-3
game-devices-udev 0.4-1 -> 0.5-1
gc 8.0.4-2 -> 8.0.4-3
gdbm 1.18.1-2 -> 1.18.1-3
gettext 0.20.1-2 -> 0.20.1-3
ghostscript 9.50-1 -> 9.50-2
glib2 2.62.2-1 -> 2.62.3-1
glibc 2.30-2 -> 2.30-3
gmp 6.1.2-2 -> 6.1.2-3
gnupg 2.2.17-2 -> 2.2.18-2
gnutls 3.6.10-1 -> 3.6.11.1-1
gobject-introspection-runtime 1.62.0-1 -> 1.62.0-3
gpgme 1.13.1-1 -> 1.13.1-3
gpm 1.20.7.r27.g1fd1941-1 -> 1.20.7.r27.g1fd1941-2
grep 3.3-2 -> 3.3-3
groff 1.22.4-1 -> 1.22.4-2
grub 2.04-8 -> 2.04-9
gssproxy 0.8.2-1 -> 0.8.2-2
gst-libav 1.16.1-1 -> 1.16.2-1
gst-plugins-bad 1.16.1-4 -> 1.16.2-1
gst-plugins-base 1.16.1-1 -> 1.16.2-1
gst-plugins-base-libs 1.16.1-1 -> 1.16.2-1
gst-plugins-good 1.16.1-1 -> 1.16.2-1
gst-plugins-ugly 1.16.1-2 -> 1.16.2-1
gstreamer 1.16.1-1 -> 1.16.2-1
gtk-update-icon-cache 1:3.24.12+32+g39e28ab933-1 -> 1:3.24.13-1
gufw 19.10.0-1 -> 19.10.0-2
gvfs 1.42.1-1 -> 1.42.2-1
gvfs-afc 1.42.1-1 -> 1.42.2-1
gvfs-gphoto2 1.42.1-1 -> 1.42.2-1
gvfs-mtp 1.42.1-1 -> 1.42.2-1
gvfs-nfs 1.42.1-1 -> 1.42.2-1
gvfs-smb 1.42.1-1 -> 1.42.2-1
gzip 1.10-2 -> 1.10-3
harfbuzz 2.6.4-1 -> 2.6.4-2
harfbuzz-icu 2.6.4-1 -> 2.6.4-2
hdparm 9.58-2 -> 9.58-3
hexchat 2.14.2-4 -> 2.14.2-6
hplip 1:3.19.11-1 -> 1:3.19.11-4
hwids 20190818-1 -> 20191025-2
iana-etc 20191030-1 -> 20191123-1
icu 64.2-1 -> 65.1-2
imagemagick 7.0.9.2-3 -> 7.0.9.7-1
imlib2 1.5.1-1 -> 1.6.0-1
inetutils 1.9.4-7 -> 1.9.4-8
intel-ucode 20191115-1 -> 20191115-2
inxi 3.0.36-1 -> 3.0.37-1
iproute2 5.3.0-1 -> 5.4.0-1
iptables 1:1.8.3-1 -> 1:1.8.3-3
iputils 20190709-1 -> 20190709-2
ipw2100-fw 1.3-9 -> 1.3-10
ipw2200-fw 3.1-7 -> 3.1-8
iw 5.3-1 -> 5.4-1
java-environment-common 3-1 -> 3-2
java-runtime-common 3-1 -> 3-2
jfsutils 1.1.15-6 -> 1.1.15-7
json-c 0.13.1-2 -> 0.13.1-3
kauth 5.64.0-1 -> 5.64.0-2
kbd 2.2.0-4 -> 2.2.0-5
kcoreaddons 5.64.0-1 -> 5.64.0-2
keyutils 1.6.1-1 -> 1.6.1-3
kitemmodels 5.64.0-1 -> 5.64.0-2
krb5 1.17-1 -> 1.17-2
lapack 3.8.0-2 -> 3.9.0-2
ldb 1:1.5.6-1 -> 1:1.5.6-2
ldns 1.7.1-1 -> 1.7.1-2
lensfun 0.3.2-7 -> 0.3.2-9
less 551-2 -> 551-3
lib32-alsa-lib 1.1.9-1 -> 1.2.1.2-1
lib32-alsa-plugins 1.1.9-1 -> 1.2.1-1
lib32-glib2 2.62.2-1 -> 2.62.3-1
lib32-glibc 2.30-2 -> 2.30-3
lib32-gnutls 3.6.10-1 -> 3.6.11.1-1
lib32-harfbuzz 2.6.4-1 -> 2.6.4-2
lib32-icu 64.2-1 -> 65.1-2
lib32-libepoxy 1.5.3-1 -> 1.5.4-1
lib32-libpng 1.6.37-1 -> 1.6.37-2
lib32-librsvg 2.46.3+6+g4735bd07-1 -> 2.46.4-1
lib32-libtiff 4.0.10-1 -> 4.1.0-1
lib32-libva-mesa-driver 19.2.6-0.1 -> 19.2.7-1
lib32-libxml2 2.9.9-2 -> 2.9.10-1
lib32-mesa 19.2.6-0.1 -> 19.2.7-1
lib32-nspr 4.23-1 -> 4.24-1
lib32-nss 3.47-1 -> 3.48-1
lib32-systemd 242.153-1 -> 242.153-2
libaio 0.3.112-1 -> 0.3.112-2
libarchive 3.4.0-2 -> 3.4.0-3
libassuan 2.5.3-1 -> 2.5.3-2
libblockdev 2.23-1 -> 2.23-3
libbytesize 2.1-1 -> 2.1-3
libcap 2.27-1 -> 2.27-2
libcap-ng 0.7.9-1 -> 0.7.10-1
libelf 0.177-1 -> 0.177-2
libepoxy 1.5.3-1 -> 1.5.4-1
libevent 2.1.11-2 -> 2.1.11-3
libffi 3.2.1-3 -> 3.2.1-4
libgcrypt 1.8.5-1 -> 1.8.5-2
libgexiv2 0.12.0-2 -> 0.12.0-4
libgpg-error 1.36-2 -> 1.36-3
libgusb 0.3.0-1 -> 0.3.1-1
libibus 1.5.21-1 -> 1.5.21-3
libical 3.0.6-1 -> 3.0.6-2
libidn 1.35-1 -> 1.35-2
libidn2 2.2.0-1 -> 2.3.0-1
libimobiledevice 1.2.0+87+g92c5462-4 -> 1.2.0+87+g92c5462-6
libksba 1.3.5-1 -> 1.3.5-2
libldap 2.4.48-1 -> 2.4.48-2
liblouis 3.11.0-1 -> 3.12.0-1
libmm-glib 1.12.0-1 -> 1.12.0-2
libmnl 1.0.4-2 -> 1.0.4-3
libmpc 1.1.0-1 -> 1.1.0-2
libnewt 0.52.21-1 -> 0.52.21-3
libnftnl 1.1.4-1 -> 1.1.5-1
libnghttp2 1.39.2-1 -> 1.39.2-2
libnl 3.5.0-1 -> 3.5.0-2
libnm 1.20.6-1 -> 1.20.8-1
libnsl 1.2.0-1 -> 1.2.0-2
libpcap 1.9.1-1 -> 1.9.1-2
libpipeline 1.5.1-1 -> 1.5.1-2
libplist 2.1.0-1 -> 2.1.0-2
libproxy 0.4.15-10 -> 0.4.15-13
libpsl 0.21.0-1 -> 0.21.0-2
libpurple 2.13.0-7 -> 2.13.0-9
librsvg 2:2.46.3+6+g4735bd07-1 -> 2:2.46.4-1
libsasl 2.1.27-1 -> 2.1.27-2
libseccomp 2.4.1-2 -> 2.4.1-3
libsecret 0.19.1-1 -> 0.19.1-2
libsoup 2.68.2-1 -> 2.68.3-1
libssh2 1.9.0-1 -> 1.9.0-2
libsynctex 2019.51075-3 -> 2019.51075-4
libtasn1 4.14-2 -> 4.15.0-1
libteam 1.29-1 -> 1.29-4
libtirpc 1.1.4-1 -> 1.1.4-2
libtool 2.4.6+42+gb88cebd5-6 -> 2.4.6+42+gb88cebd5-8
libunistring 0.9.10-1 -> 0.9.10-2
libusb 1.0.23-1 -> 1.0.23-2
libusbmuxd 1.0.10+29+g9db5747-1 -> 2.0.0-2
libutil-linux 2.34-3 -> 2.34-8
libva-mesa-driver 19.2.6-0.1 -> 19.2.7-1
libvoikko 4.2-1 -> 4.3-1
libwbclient 4.10.10-1 -> 4.10.10-2
libwpe 1.4.0-1 -> 1.4.0.1-1
libxml2 2.9.9-3 -> 2.9.10-1
libxslt 1.1.33-1 -> 1.1.34-2
licenses 20191011-1 -> 20191011-2
lightdm-gtk-greeter-settings 1.2.2-3 -> 1.2.2-4
linux-api-headers 5.3.1-1 -> 5.3.1-2
linux-firmware 20191022.2b016af-1 -> 20191118.e8a0f4c-2
linux53 5.3.12-1 -> 5.3.15-1
linux53-virtualbox-guest-modules 6.0.14-9 -> 6.0.14-12
llvm-libs 9.0.0-3 -> 9.0.0-4
logrotate 3.15.1-1 -> 3.15.1-2
lvm2 2.02.186-2 -> 2.02.186-3
lz4 1:1.9.2-1 -> 1:1.9.2-2
lzo 2.10-2 -> 2.10-3
m4 1.4.18-2 -> 1.4.18-3
make 4.2.1-3 -> 4.2.1-4
man-pages 5.03-1 -> 5.04-2
manjaro-application-utility 1.2.1-1 -> 1.2.2-2
manjaro-hello 0.6.2-2 -> 0.6.3-1
manjaro-release 18.1.3-1 -> 18.1.4-1
manjaro-settings-manager 0.5.6-3 -> 0.5.6-6
manjaro-settings-manager-notifier 0.5.6-3 -> 0.5.6-6
manjaro-system 20190429-1 -> 20191208-1
manjaro-xfce-gtk3-settings 20191031-1 -> 20191204-1
mdadm 4.1-1 -> 4.1-2
menulibre 2.2.1-1 -> 2.2.1-1.0
mesa 19.2.6-0.1 -> 19.2.7-1
mhwd 0.6.3-1 -> 0.6.3-15
mhwd-db 0.6.3-13 -> 0.6.3-16
mhwd-nvidia-440xx 440.31-1 -> 440.36-1
mkinitcpio-busybox 1.30.1-1 -> 1.30.1-2
mlocate 0.26.git.20170220-1 -> 0.26.git.20170220-2
modemmanager 1.12.0-1 -> 1.12.0-2
mpfr 4.0.2-1 -> 4.0.2-2
mugshot 0.4.1-1 -> 0.4.2-1
nano 4.5-1 -> 4.6-1
ncurses 6.1-6 -> 6.1-7
nettle 3.5.1-1 -> 3.5.1-2
networkmanager 1.20.6-1 -> 1.20.8-1
nfs-utils 2.4.1-2 -> 2.4.2-1
nfsidmap 2.4.1-2 -> 2.4.2-1
npth 1.6-1 -> 1.6-2
nspr 4.23-1 -> 4.24-1
nss 3.47-1 -> 3.48-1
openal 1.19.1-2 -> 1.20.0-1
openexr 2.4.0-4 -> 2.4.0-6
openresolv 3.9.2-1 -> 3.9.2-2
openssh 8.1p1-1 -> 8.1p1-2
openssl 1.1.1.d-1 -> 1.1.1.d-2
ostree 2019.4-1 -> 2019.5-1
p11-kit 0.23.18.1-1 -> 0.23.18.1-2
pacman 5.2.1-1 -> 5.2.1-2
pacman-mirrors 4.15.1-1 -> 4.15.1-2
pam 1.3.1-1 -> 1.3.1-2
pamac-cli 9.1.1-1 -> 9.2.0-1
pamac-common 9.1.1-1 -> 9.2.0-1
pamac-gtk 9.1.1-1 -> 9.2.0-1
pamac-snap-plugin 9.1.1-1 -> 9.2.0-1
pambase 20190105.1-1 -> 20190105.1-2
papirus-icon-theme 20191101-1 -> 20191201-1
patch 2.7.6-7 -> 2.7.6-8
pciutils 3.6.2-1 -> 3.6.2-2
pcre 8.43-1 -> 8.43-2
pcre2 10.33-1 -> 10.34-2
perl 5.30.0-3 -> 5.30.1-1
pidgin 2.13.0-7 -> 2.13.0-9
pinentry 1.1.0-4 -> 1.1.0-5
pkcs11-helper 1.25.1-1 -> 1.25.1-2
pkgconf 1.6.3-2 -> 1.6.3-3
poppler 0.80.0-2 -> 0.82.0-1
poppler-glib 0.80.0-2 -> 0.82.0-1
poppler-qt5 0.80.0-2 -> 0.82.0-1
popt 1.16-10 -> 1.16-12
ppp 2.4.7-5 -> 2.4.7-6
pptpclient 1.10.0-1 -> 1.10.0-2
procps-ng 3.3.15-1.2 -> 3.3.15-2
protobuf 3.10.0-1 -> 3.10.1-1
psmisc 23.2-1 -> 23.3-2
pygobject-devel 3.34.0-1 -> 3.34.0-3
pyqt5-common 5.13.2-1 -> 5.13.2-3
python 3.7.4-2 -> 3.8.0-1
python-appdirs 1.4.3-2 -> 1.4.3-5
python-cachecontrol 0.12.5-4 -> 0.12.5-6
python-cairo 1.18.2-1 -> 1.18.2-3
python-chardet 3.0.4-2 -> 3.0.4-4
python-colorama 0.4.1-1 -> 0.4.1-3
python-dbus 1.2.10-1 -> 1.2.14-1
python-dbus-common 1.2.10-1 -> 1.2.14-1
python-distlib 0.2.9-1 -> 0.3.0-1
python-distro 1.4.0-1 -> 1.4.0-3
python-distutils-extra 2.39-3 -> 2.39-5
python-docopt 0.6.2-5 -> 0.6.2-7
python-gobject 3.34.0-1 -> 3.34.0-3
python-html5lib 1.0.1-3 -> 1.0.1-7
python-idna 2.8-1 -> 2.8-3
python-importlib-metadata 0.23-1 -> 0.23-2
python-keyutils 0.6-2 -> 0.6-4
python-lockfile 0.12.2-4 -> 0.12.2-6
python-more-itertools 7.2.0-1 -> 7.2.0-3
python-msgpack 0.6.2-1 -> 0.6.2-3
python-npyscreen 4.10.5-2 -> 4.10.5-4
python-packaging 19.2-2 -> 19.2-5
python-pep517 0.6.0-1 -> 0.6.0-3
python-pexpect 4.7.0-1 -> 4.7.0-3
python-pillow 6.2.0-1 -> 6.2.1-1
python-pip 19.2.3-1.5 -> 19.2.3-3
python-progress 1.5-1 -> 1.5-3
python-psutil 5.6.3-1 -> 5.6.7-1
python-ptyprocess 0.6.0-2 -> 0.6.0-4
python-pycups 1.9.74-1 -> 1.9.74-3
python-pycurl 7.43.0.3-1 -> 7.43.0.3-3
python-pyparsing 2.4.4-1 -> 2.4.5-1
python-pyqt5 5.13.2-1 -> 5.13.2-3
python-pytoml 0.1.21-1 -> 0.1.21-3
python-reportlab 3.5.32-1 -> 3.5.32-2
python-requests 2.22.0-1 -> 2.22.0-3
python-retrying 1.3.3-4 -> 1.3.3-6
python-setuptools 1:41.2.0-1 -> 1:41.6.0-1
python-sip-pyqt5 4.19.19-1 -> 4.19.19-3
python-six 1.12.0-1 -> 1.13.0-2
python-urllib3 1.25.6-1 -> 1.25.7-1
python-webencodings 0.5.1-2 -> 0.5.1-4
python-xdg 0.26-2 -> 0.26-4
python-yaml 5.1.2-1 -> 5.1.2-3
python-zipp 0.6.0-1 -> 0.6.0-3
python2-cairo 1.18.2-1 -> 1.18.2-3
python2-gobject2 2.28.7-2 -> 2.28.7-4
qpdf 9.0.2-1 -> 9.1.0-1
qt5-base 5.13.2-1 -> 5.13.2-3
raptor 2.0.15-11 -> 2.0.15-12
readline 8.0.001-1 -> 8.0.001-2
reiserfsprogs 3.6.27-2 -> 3.6.27-3
rpcbind 1.2.5-2 -> 1.2.5-3
run-parts 4.8.6.1-1 -> 4.8.6.1-2
s-nail 14.9.15-1 -> 14.9.15-2
samba 4.10.10-1 -> 4.10.10-2
screenfetch 3.9.0-1 -> 3.9.1-1
sed 4.7-2 -> 4.7-3
shadow 4.7-2 -> 4.7-3
smbclient 4.10.10-1 -> 4.10.10-2
snapd 2.42.1-1 -> 2.42.4-1
sqlite 3.30.1-1 -> 3.30.1-2
srt 1.4.0-1 -> 1.4.1-1
subversion 1.12.2-1 -> 1.13.0-1
sysfsutils 2.1.0-10 -> 2.1.0-11
system-config-printer 1.5.12-1 -> 1.5.12-2
systemd 242.153-1 -> 242.153-2
systemd-libs 242.153-1 -> 242.153-2
systemd-sysvcompat 242.153-1 -> 242.153-2
talloc 2.2.0-1 -> 2.3.0-1
tar 1.32-2 -> 1.32-3
tcl 8.6.9-2 -> 8.6.10-1
tdb 1.3.18-2 -> 1.3.18-4
tevent 1:0.9.39-2 -> 1:0.9.39-4
texinfo 6.7-1 -> 6.7-2
thin-provisioning-tools 0.8.5-2 -> 0.8.5-3
thunar 1.8.10-1 -> 1.8.11-1
thunderbird 68.2.2-1 -> 68.3.0-1
tzdata 2019c-2 -> 2019c-3
udiskie 1.7.7-1 -> 1.7.7-2
ufw 0.36-1 -> 0.36-3
unrar 1:5.8.3-1 -> 1:5.8.4-1
usb_modeswitch 2.5.2-1 -> 2.6.0-1
usbutils 012-1 -> 012-2
util-linux 2.34-3 -> 2.34-8
vi 1:070224-3 -> 1:070224-4
virtualbox-guest-utils 6.0.14-1 -> 6.0.14-4
volume_key 0.3.11-2 -> 0.3.12-2
vte-common 0.58.2-1 -> 0.58.3-1
vte3 0.58.2-1 -> 0.58.3-1
vulkan-icd-loader 1.1.127-1 -> 1.1.129-1
webkit2gtk 2.26.1-1.1 -> 2.26.2-2.1
which 2.21-4 -> 2.21-5
wireless-regdb 2019.06.03-1 -> 2019.06.03-2
wpa_supplicant 2:2.9-1 -> 2:2.9-2
wpebackend-fdo 1.4.0-1 -> 1.4.0-2
x264 3:0.157.r2980.34c06d1-1 -> 3:0.157.r2980.34c06d1-2
xcb-proto 1.13-2 -> 1.13-4
xdg-desktop-portal 1.5.2-1 -> 1.5.3-1
xdg-desktop-portal-gtk 1.5.0-1 -> 1.5.1-1
xdg-utils 1.1.3+18+g0547886-2 -> 1.1.3+18+g0547886-4
xfsprogs 5.2.1-1 -> 5.2.1-3
xorg-server 1.20.5-4.1 -> 1.20.6-1
xorg-server-common 1.20.5-4.1 -> 1.20.6-1
xz 5.2.4-1 -> 5.2.4-2
yelp-xsl 3.34.0-1 -> 3.34.2-1
zlib 1:1.2.11-3 -> 1:1.2.11-4
zstd 1.4.3-1 -> 1.4.4-1
[froggy@pixel-stable Desktop]$ 

EDIT 3: On this mirror, the "Last modified" date for menulibre is 2019-11-14, and the mirror has menulibre 2.2.1-1.0. It is suspicious. menulibre should have a pkgrel of 1.1, or even 2 (why a decimal pkgrel in this case?) to be sure that Pamac 9.1.1 handles the upgrade properly.

@Ste74 It turns out plane-icon-theme has been out of date for 9 months. The prebuilt zips are at 1.9, we have 1.8.

soapyrtlsdr 0.3.0-1 (which comes from community repo) maybe need to be rebuilt:
the other “soapy” packages (also them from community repo) are already available to new release:

soapy_power, soapysdr and simplesoapy
(checked by using “checkupdates” command from the terminal):

soapy_power 1.6.1-2 -> 1.6.1-4
soapysdr 0.7.1-1 -> 0.7.1-4
simplesoapy 1.5.1-2 -> 1.5.1-4

Sorry for the noise.

I didn't updated yet to [Stable Update] 2019-12-10]: I'm checking the packages which needs Python, due the switch to Python 3.8:
In pamac I see that ps_mem (3.12-1) depends on Python: currently report to need Python 3.7, so would be the case to rebuild also ps_mem?

New nvidia driver 440.44. @philm

  • Added support for the following GPU:

Quadro T2000 with Max-Q Design

  • Added support for the __GL_SYNC_DISPLAY_DEVICE environment variable for Vulkan applications.
  • Fixed a bug that caused applications running directly on a display (such as VR HMDs) to tear when a G-SYNC or G-SYNC Compatible monitor is plugged in the system.
  • Fixed a bug in an error handling path that could cause a kernel crash while loading nvidia.ko.
  • Fixed driver installation failure on Oracle Linux 7.7 systems, where the NVIDIA kernel module failed to build with error "unknown type name 'vm_fault_t'".
2 Likes

Update for nvidia 440.44 is done in unstable

1 Like

linux419 (and earlier?) needs to be tweaked to conform to the recent mkinitcpio changes, mainly removing this line https://gitlab.manjaro.org/packages/core/linux419/blob/master/PKGBUILD#L196
Also can somebody take another look at this Manjaro-specific packages which need an update

We already fixed that. Due to some Merge an older state got reintroduced. I've cleaned up the git History and reverted to a clean state.

@oberon While I was cleaning house and attempting to get rid of Python 2 packages, I just discovered tlpui does not require pygtk.

Why are you not using the setup.py? I just built it and it sure makes the package size smaller:

:: tlpui-git and tlpui are in conflict. Remove tlpui? [y/N] y

Packages (2) tlpui-r109.703bade-1 [removal]  tlpui-git-r110.372463b-1

Total Installed Size:   0.44 MiB
Net Upgrade Size:      -1.43 MiB

See my PKGBUILD

1 Like

delete it

Thank you. I'm adopting your PKGBUILD. :+1:

1 Like

Last packager is @philm .

1 Like

virtualbox is out of date, it's current version 6.1

switch to unstable branch

First, virtualbox is an Arch community package, not a Manjaro specific package. Second, it's not out of date as v6.1.0 has been out for over a week. You can check which versions of software are in which branch with Manjaro's repo compare tool.

Forum kindly sponsored by