Manjaro-specific packages which need an update

3 posts were merged into an existing topic: Why are Manjaro-specific packages not updated?

I will look into it

1 Like

Holy Moly you are fast :partying_face::racing_car:

Thanks @Ste74!

A post was merged into an existing topic: Why are Manjaro-specific packages not updated?

Just saw this in unstable
installing icu (64.1-1) breaks dependency 'icu<63.2' required by manjaro-settings-manager

2 Likes

steam-manjaro
@philm

Fix for black screens in steam client when using steam native runtimes.

Working for me. Maybe someone knows a better way to implement this change?

diff --git a/0003-manjaro-steam-native.patch b/0003-manjaro-steam-native.patch
index 2dd38d2..4476458 100644
--- a/0003-manjaro-steam-native.patch
+++ b/0003-manjaro-steam-native.patch
@@ -11,7 +11,7 @@
 +        # if steam-native package is installed, enable native runtime
 +        if [ -f "/usr/lib/steam/native_runtime.txt" ]
 +            then
-+                export STEAM_RUNTIME=0
++                export STEAM_RUNTIME=0 LD_PRELOAD="/usr/lib/libgio-2.0.so.0 /usr/lib/libglib-2.0.so.0"
 +                echo "Manjaro steam native configuration found!"
 +        fi
 +fi
diff --git a/PKGBUILD b/PKGBUILD
index 76a6be6..8cc953f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
 pkgname=steam-manjaro
 _package=steam
 pkgver=1.0.0.56
-pkgrel=1
+pkgrel=2
 pkgdesc="Valve's digital software delivery system"
 url='http://steampowered.com/'
 arch=('i686' 'x86_64')
@@ -31,7 +31,7 @@ sha512sums=('17fdd26b829a5860520d955326af88ebacda18183fbf9a70cbb38a9c593cc6c3e85
             '6bbfdb29a46662a6aec49387819485c91b3c71f23bce421e85132a4391a10c0c97700d601e52a442611e2b517951b7841b8f1944b15798a69b1959d219571c62'
             'ec57f189fbc25633799c553b0eb30bd074f02befd9c7e7ca1c052be0a66ca3745b511b0fccb21ddb57885d60a23c8d40eaa8d63f8da2fc2fff3b8e7f5d23b091'
             '12d8b5786e2a375ec03131ff5c246c64793acc24cf42e74b40cd77a031c17543da05f7dd33b1f17f63524710f5d96636f35908e1953292f44e949f84fb753c27'
-            'fec7a63231c502debaa8ccdac73270e47ad42dd85e420eee44100ed0e4e4678e9ad70e36a3df02cc9ebe9936b710737d0867532a9b319bc1bee141c420db5900'
+            '224491b753562772fb2c4cc165feb66f886332b2844ed3ddacc78360482a9f0bb4afd43ecc3930c6bf351aa3641bda4f5d61da9a82cf98d1640466ef12e778f8'
             '62a9d7f216a71588562618129e75cbd5247477ad28b9c4a81c6dd5ed5bb2c35a379c18b82fe10b18ffbd94d4c1bba1ea11f40f2152c75694c5f68a544caaad17')
 
 prepare()
1 Like

that is something that @anon35400795 should take a look on first.

I'm no part of it anymore (and would also recommend the Steam from flathub instead of everything thats in the repo, because of sandboxing the runtime).

Sad to hear that.
Personally, I won't use snaps or flatpaks because they break with every repository - idea on Linux and add yet another thing to update.

Linux Steam Integration work fine? If yes we can adopt since now is maintained by Clear Linux project...

Last time I tried (January) it made things worse, like in some games where unable to launch, while others work just fine and I was more playing around with the switches inside the LSI config windows, then in steam itself :joy: But could be that this is related to the AUR pkg of LSI somehow. For myself, I couldnt find any benefit in it.

It works fine for me on Solus, they use the latest upstream version from clear linux.
If you like to add it, I would be willing to test it on unstable.

The benefit of this project isn't always visible, but in some cases it helps with game bugs, like fixing incorrect shader assets in ARK because of broken water surfaces.

1 Like

Ok let me see :wink:

trizen is 1.48 in repos, trizen is 1.58 in AUR, needs a rebuild.

TLP? 1.2 is out.

A post was merged into an existing topic: Non-Manjaro packages which have been flagged as needing an update

1.58 is now in unstable.

2 Likes

Packages that need to be updated:

brave
brave-beta

See https://community.brave.com/t/brave-shield-ui-bug/33570/78

Any consideration for pushing these back to AUR?

It seems like any browsers we keep in the repos should be regularly updated for security reasons. If we aren't dedicated to it, why not let it fall back to AUR?

6 Likes

I agree. If Brave remains in the Manjaro repos it should receive the same treatment as Firefox and Chromium (IMHO), which are regularly updated for security reasons.