Manjaro-specific packages which need an update

you are right.
i have used it for a while a couple of years ago and it was fine.

maybe, it is worth exchanging juffed for notepadqq in lxqt iso in order to save @Ste74 future work.

@Ste74 gnome-terminal-fedora needs an update to 3.32.0.

For each package mentioned below, I’ll ping the last packager according to Pamac GTK.

Those requests are based from what is available in Testing currently, so sorry in advance if I mention packages that already got updated in Unstable.


Reminder
@philm:

  • libcpuid: Upstream is at 0.4.1 (i-nex may need to be rebuilt) (this + i-nex could be dropped if you need to reduce your workload);
  • gimp-gtk3: Build date for current is Nov 24th, 2018. (Honestly, if there is no refresh planned for it, just remove it from repos.)
  • chromium-chromevox: Last packaged Sept 10th, 2013. Phew, more than 5 years old! Does it still even work with the current version of Chromium?
  • pamac-classic: Out-of-date upstream is at 6.7.0) and the project is dead. Even if there won’t be a new version anytime soon, Team must keep an eye on it in case it ceases to work. (Could be removed to reduce your workload.)
  • pamac-dev and pamac-dev-tray-appindicator: Out-of-date and not adapted to the new way Pamac is packaged nowadays. (Should be removed IMO.)
  • trizen: Reported by helomoon, the version we have is like 1 year old! Upstream is at version 1.58, we currently have version 1.48.
  • appimagelauncher: Reported by helomoon, upstream is at version 1.2.2.

New requests

@philm:

  • gamemode and lib32-gamemode: Has not been updated since Nov 24, 2018. Version 1.3.1 is available upstream.
  • amarok: Has not been refreshed for four months (Build date: Nov 24th, 2018). Looking at the history of their git, there has been a significant amount of changes between back then and now.

@jonathon:

@Ste74:

3 Likes

steam-native continues to have problems with the more recent steam client builds. Instead of displaying the store, profiles or community pages (basically anything http) only a black screen appears instead of the content (frame loads okay). Only the users library page is unaffected.

The root of the problem appears to be that the client is built against a Debian package (glib2?) that links to libraries not present on Manjaro (libpcre.so.3 and libselinux.so.1). At this point it seems that Steam are unlikely to change this on their end.

The client does correctly display pages after
export LD_PRELOAD="/usr/lib/libgio-2.0.so.0 /usr/lib/libglib-2.0.so.0"

Can steam-native be rebuilt so that it loads the system version of these libraries by default?

@philm

1 Like

More than likely this was done because of Steam-OS. It is debian based.

I grouped Manjaro packages that has a very old Build Date attribute, just to check if there is any need for a spring cleanup.

2012
lsb-release
manjaro-alsa
manjaro-pulse
2013
syslinux4
libtimezonemap
manjaro-artwork-extra
manjaro-artwork-icons
manjaro-artwork-openbox
pam_encfs
chromium-chromevox
fetter
le3cell-artwork-wallpapers
manjaro-users-artwork-wallpapers
2014
plymouth-theme-manjaro-very-elegant
ttf-aboriginal-sans
ttf-lohit-fonts
ttf-myanmar3
ttf-thaana-fonts
xdg-su
bar-aint-recursive
enlightenment-manjaro-themes
faenzaflattr-black-icon-theme
faenzaflattr-darkdecoration-icon-theme
faenzaflattr-darkplasma-icon-theme
faenzaflattr-green-icon-theme
faenzaflattr-grey-icon-theme
faenzaflattr-icon-theme
kdeicons-kfaenza
lightdm-another-gtk-greeter
lightdm-another-gtk-greeter-themes
lxdm-manjaro-theme-openbox
manjaro-circle-icons
manjarobox-evolution-themes
manjarobox-legacy-postinstall-scripts
manjarobox-legacy-themes
menda-lxqt-panel
nitrux-icon-theme
open-dyslexic-fonts
pekwm-menu
raktpdf
sysvinit
timeset
tmpwatch
volumeicon-gtk2
xboomx
xfce4-weather-plugin-menda-circle-icons
2015
mkinitcpio-nfs-utils
gcc49
lha
advcp
bdf-zevv-peep
deepin-trash
econnman
emacs-speechd-el
faenza-icon-theme
fbmenu-manjaro
fbmenugen
fluxbox-wallpapers
gnome-themes-maia
go-packages
i3-theme-dark
i3-theme-dust
i3-wallpapers
keyboardctl
locale-info
maia-xfce-icon-theme
menda-circle-icon-theme
mygtkmenu
nouvegnomegray-icon-theme
numix-manjaro-themes
numix-reborn-icon-themes
numix-reborn-wallpapers
open-fuse-iso
open-fuse-iso-term
pdf2img-c
plasma5-themes-menda
preload
pyplanemode
sakis3g
sddm-menda-theme
srandrd
sxiv-rifle
timeset-gui
tintin
ttf-dejavu-sans-mono-powerline
ttf-font-icons
ttf-montserrat
unified-manjaro-themes-openbox
xfce-theme-numix-reborn
xwinfo
lib32-libindicator-gtk2
lib32-libindicator-gtk3
2016
mhwd-ati
catalyst-input
catalyst-video
gfxboot
manjaro-backgrounds
manjaro-firmware
manjaro-syslinux-theme
plasma-gpg-agent
plasma-ssh-agent
ruby-ethon
ruby-hashie
ruby-json
ruby-osdn-cli
ruby-osdn-client
ruby-typhoeus
sonar-backgrounds
sonar-calamares-branding
sonar-common
sonar-isolinux
sonar-mate-settings
sonar-sound-theme
sonar-syslinux-theme
xfce4-volumed-pulse
adwaita-maia-gtk3
adwaita-manjaro-themes
andromeda-icon-theme
andromeda-wallpaper
artwork-fluxbox
awoken-icon-theme
awoken-icon-theme-light
brandr
bspwm-ruler
cbatticon-gtk2
conky-cli
conky-lua-nv
console-solarized
engrampa-thunar-plugin
fisherman
fluxbox-theme-manjaro
fluxbox-theme-vertex-maia
gtk-theme-e17gtk
gtk-theme-numix-solarized
gtk-theme-stylishdark
hal-flash
jwm-artwork
jwm-documentation
jwm-wallpapers
jwmconf
kde-servicemenus-pkg-tools
kde1-kdebase
kde1-kdelibs
lua-clock-i3
lua-clock-manjaro
lxdm-manjaro-theme
manj-grub
manjaro-lumina-settings
manjaro-pantheon-settings
manjaro-xdg-menu
mdsplib
mediterraneannight-theme
menda-themes
menda-themes-dark
mhwd-tui
mygtkmenui
numix-themes-archblue
oblogout-manjaro
oysttyer
pantheon-wallpapers
plasma5-themes-andromeda
pmenu
prpltwtr
qt1
sddm-andromeda-qt-theme
sddm-andromeda-theme
sunflower
tintwizard
ultraflatorange-icon-theme
wpa_tui
xcursor-chameleon-pearl
xcursor-chameleon-pearl-deepin
xcursor-maia
xcursor-menda
xcursor-rezowhite
xplayer-plparser
2017
sonar-release
calamares-tools
catalyst-server
libxpresent
manjaro-artwork
manjaro-base-skel
manjaro-efi-utils
manjaro-live-portable-efi
manjaro-live-systemd
manjaro-printer
mkinitcpio-openswap
ndiswrapper-utils
opencl-catalyst
plymouth-theme-manjaro
plymouth-theme-manjaro-elegant
plymouth-theme-manjaro-elegant-hidpi
plymouth-theme-sonar-elegant
rt3562sta-common
ruby-kwalify
sddm-start-delayed
sonar-gnome-settings
sonar-iso-profiles
sx-sf-hdparm-sdb-idle
thunar-archive-plugin-gtk3
thunar-volman-gtk3
xfce4-appfinder-gtk3
xfce4-power-manager-gtk3
arc-icon-theme
arc-maia-icon-theme
brisk-menu
checkhash
clevo-indicator
cmst
compare-mirrors
daala
deepin-iconthemes-manjaro
deepin-session-ui-manjaro
delayed-hibernation
evopop-gtk-theme
evopop-icon-theme
fancontrol-common
fancontrol-gui
fancontrol-kcm
flatix-theme
flatix-theme-dark
gnome-shell-extension-openweather
grub-btrfs
gtk-theme-breath
gtk-theme-maia
gtk2-compatibility
i-nex
ido
imagewriter
indicator-application
indicator-application-gtk2
indicator-powersave
indicator-sensors
indicator-sysmonitor
iso-flag-png
juffed-qt5
jwm
kde-servicemenus-rootactions
libcpuid
libpthread-stubs
libxpresent
lightdm-webkit2-greeter-manjaro
lightdm-webkit2-greeter-manjaro-dark
liquidshell
lumina-desktop
lxde-wallpapers
maia-icon-theme
maia-wallpaper
makedepend
manjaro-browser-settings-native
manjaro-lxde-logout-banner
manjaro-lxde-xfce4-notifyd
manjaro-lxde-xfce4-volumed-pulse
manjaro-mate-panel-layout
manjaro-sx-icons
manjaro-sx-wallpapers
mate-notification-theme-slate
muser-wallpapers
nautilus-empty-file
nemo-bulk-rename
networkmanager-dmenu
nextcloud-testing
obmenu-generator
paper-icon-theme-git
parole-gtk3
plasma5-themes-maia
plymouth-theme-manjaro-cinnamon
plymouth-theme-manjaro-circle
plymouth-theme-manjaro-deepin
plymouth-theme-manjaro-deepin-circle
plymouth-theme-manjaro-extra-elegant
plymouth-theme-manjaro-fancy-budgie
plymouth-theme-manjaro-gnome
plymouth-theme-manjaro-gnome-17.0
plymouth-theme-manjaro-redefined-bsplash
pm-utils
pocketsphinx
pulseaudio-ctl
python-efl
qt5gtk2
sddm-maia-theme
sddm-qt-manjaro-theme
sensor-icons
sidplay2-libs
sphinxbase
stationx-driver
thunar-shares-plugin-manjaro
ttf-comfortaa
vibrancy-colors
vicky
xfce4-dockbarx-plugin
xfce4-indicator-plugin-git
xfce4-indicator-plugin-gtk3-git
xtitle
zensu
lib32-catalyst-utils
lib32-libdbusmenu-qt
lib32-libmng
lib32-opencl-catalyst
lib32-qjson
lib32-qt4
lib32-qtcurve-gtk2
lib32-qtcurve-qt4
lib32-qtcurve-utils
lib32-sni-qt

For example is fetter something Manjaro really needs?
manjarobox-legacy-postinstall-scripts looks like a leftover from an ancient Manjaro spin?
There are many icon, font, wallpaper and theme packages, they don’t cause maintenance issues but they still need to be saved in every mirror and maybe some of them don’t deserve it.

5 Likes

Same problem on my Arch machine. But steam-runtime works perfectly.

Additional new request because I have not noticed it for my previous post.

LLVM 8 now being in Unstable and Testing, it would be a good time to push the new version of libc++, libc++abi and libc++experimental in Unstable and Testing. :slight_smile:

Upstream is at version 8.0.0. We currently have 7.0.1 in Testing.

Last packager is @jonathon. Thanks in advance.

@philm :

1 Like

@Chrysostomus dunst 1.4.0 is out.

1 Like

Updating. thanks!

EDIT: updated dunst and dunstify now

1 Like

A post was merged into an existing topic: Non-Manjaro packages which have been flagged as needing an update

A post was split to a new topic: Anki 2.1.11-1 fails to start

A post was split to a new topic: Why are Manjaro-specific packages not updated?

Both in unstable now.

What is gamemode?

It's a tool from Feral Interactive to optimise Linux system performance on demand for games.

Means, you don't have to switch the cpu governor manually to get the best performance.

They do even more with it to optimize specific games and also the gpu performance.

3 posts were merged into an existing topic: Why are Manjaro-specific packages not updated?

I will look into it

1 Like

Holy Moly you are fast :partying_face::racing_car:

Thanks @Ste74!