Manjaro-specific packages which need an update

Possible… no report in launchpad for now as i can see

2 posts were merged into an existing topic: Non-Manjaro packages which have been flagged as needing an update

clipit - lightweight GTK+ clipboard manager (fork of Parcellite)

Thanks :slight_smile:

I know. As explained in the AUR comments the latest release of clipit is broken. For that reason I downgraded it in the AUR and did not update it for manjaro … :stuck_out_tongue_winking_eye:

1 Like

Next time I have to read all the comments in AUR.

I tried to compile actual clipit source code … default configuration didn’t work on my Manjaro (missing GdkSeat symbol), compilation “–with-gtk3” worked but application is crashing after start.

So we must wait till upstream developer make some changes … thanks indeed.

The steam-native package has some problems as noted here: Steam can't work correctly without STEAM_RUNTIME=1 anymore?

Latest steam needs ‘libselinux.so.1’ (package not available in Manjaro currently) and also requires ‘libprce.so.3’ - this as far as I can tell is Debian messing with the soname - and creating a symlink
sudo ln -s /usr/lib/libpcre.so /usr/lib/libpcre.so.3
is a working solution that a number of users have tried previously.
@philm


Seems maybe this will be patched on steam side. Let’s wait and see.

2 Likes

nitrogen - needs some attention too

nitrogen: symbol lookup error: /usr/lib/libgiomm-2.4.so.1: undefined symbol: g_app_info_launch_uris_finish

It’s an Archlinux package:
https://www.archlinux.org/packages/extra/x86_64/nitrogen/

EDIT. And it works OK on my system :thinking:

1 Like

Works perfectly fine on Open Box but not on my i3 install. Two separate installs, both on unstable branch. That means the issue is on my end. My apologize and thanks for pointing that out.

Edit:
Apparently i had to downgrade to glibmm-2.58.1-1 from glibmm-2.60.0-1 on my i3 install to get nitrogen behave correctly, while on OpenBox it works with the latest version. Bad mirror ?
Sorry for the initial confusion!

1 Like

glibmm is @ 2.60.0-1 on my system (unstable). Nitrogen seems to be working for my i3 install.

1 Like

For some reason (unknown for me at this point) the symlinks libgiomm-2.4.so and libgiomm-2.4.so.1 got corrupted. I copied them elsewhere from glibmm-2.58.1-1 version, updated the package again to glibmm-2.60.0-1 and restored only the symlinks. Now all is ok, but i’ll keep an eye on that HDD if somehow is failing, or i had simply a bad mirror and that corrupted the install. Thanks a lot for confirming that all should be fine, and all was on my end.
Cheers!

1 Like

No problem on my install either - probably really was a ‘specialiity’ of your system … :wink:

2 Likes

For each package mentioned below, I’ll ping the last packager according to Pamac.


Rebuild that are kind of urgent to do

@philm : compiz-manjaro is currently broken in Stable (and Testing). It needs to be rebuild so it can work again with the new version of protobuf. See those posts. (There is also a new version from upstream, but the most urgent thing to do for now is rebuilding Compiz against the new version of protobuf.)


Reminder
@philm:

  • libcpuid: Upstream is at 0.4.1 (i-nex may need to be rebuilt, if you still want to maintain this package);
  • gimp-gtk3: If you guys really want to continue to maintain a development version of Gimp, a refresh could be nice to have. Build date for current is Nov 24th, 2018.
  • chromium-chromevox: Last packaged Sept 10th, 2013. Phew, more than 5 years old! I accidentally discovered this old relic when searching for Chromium. Does it still even work with the current version of Chromium?
  • pamac-classic: According to someone, it still works. Huh, oh well. It is still out of date though (upstream is at 6.7.0) and the project looks pretty much dead nowadays. It may stop to work properly one day, so it is something to keep an eye on.
  • pamac-dev and pamac-dev-tray-appindicator: I suggest to remove it for now since it isn’t used anymore. Add it again if needed in the future (for example, to test out major changes in Pamac).

New requests

@philm:

@oberon:

@jonathon (I apologize in advance, I know you love this package lol):

Quite a lot of maintenance to do. :slight_smile:

6 Likes

Sorry for double-posting, I noticed this one later and I wanted to be sure that the ping works correctly.

New request

@Ste74: budgie-desktop: I suppose it won’t be overlayed anymore? Arch packaged version 10.5 recently. Hopefully it will behave well (or at least not too bad?) alongside Gnome 3.32. :slight_smile:

Already pushed Both Budgie desktop and Budgie extra in unstable a few days ago :wink:

Do you still have the issue, @kouros17 ?
I just tried installing menulibre in Cinnamon, and it seems to work. At least it launches for me:

What system language are you using?

Feral’s GameMode has had recent updates lately, but the version is the repo’s is severely behind.

Both gamemoded and lib32-gamemoded need updates.

Yes I do, I’m using greek as default language:

(menulibre:29343): Gtk-WARNING **: 21:07:10.658: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton

(menulibre:29343): Gtk-WARNING **: 21:07:10.706: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton
Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/menulibre/MenulibreApplication.py", line 2217, in do_activate
    self.win = MenulibreWindow(self, headerbar)
  File "/usr/lib/python3.7/site-packages/menulibre/MenulibreApplication.py", line 250, in __init__
    self.configure_application_treeview(builder)
  File "/usr/lib/python3.7/site-packages/menulibre/MenulibreApplication.py", line 589, in configure_application_treeview
    self.treeview = MenulibreTreeview.Treeview(self, builder)
  File "/usr/lib/python3.7/site-packages/menulibre/MenulibreTreeview.py", line 48, in __init__
    self._configure_treeview(builder)
  File "/usr/lib/python3.7/site-packages/menulibre/MenulibreTreeview.py", line 59, in _configure_treeview
    treestore = MenuEditor.get_treestore()
  File "/usr/lib/python3.7/site-packages/menulibre/MenuEditor.py", line 123, in get_treestore
    return menu_to_treestore(treestore, None, menu)
  File "/usr/lib/python3.7/site-packages/menulibre/MenuEditor.py", line 111, in menu_to_treestore
    treestore = menu_to_treestore(treestore, treeiter, item[3])
  File "/usr/lib/python3.7/site-packages/menulibre/MenuEditor.py", line 100, in menu_to_treestore
    tooltip = escapeText(item[2]['comment'])
  File "/usr/lib/python3.7/site-packages/menulibre/util.py", line 99, in escapeText
    return GLib.markup_escape_text(text, len(text))
  File "/usr/lib/python3.7/site-packages/gi/overrides/GLib.py", line 415, in markup_escape_text
    return GLib.markup_escape_text(text, length)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xce in position 80: unexpected end of data

@oberon @ste74 For menulibre, it looks like an issue that happens depending on the language.

There is hope. According to this post, we need to apply a patch in the source code of menulibre. The patch is in the ticket linked in this post.

At that point, we have nothing to lose.

Could it be possible to rebuild the package, with the patch included, and push it in Testing and Unstable?

1 Like

2.38 is now in unstable.

Forum kindly sponsored by Bytemark