Manjaro-specific packages which need an update

etcher we have fixed. Others we may drop or find a solution ...

It is In AUR if needed

Having to rely on AUR to be able to install packages that are in repos would be a bit stupid though.

So either Manjaro Team packages gconf themselves, make the software somehow works without gconf if it is even possible, or drop everything that needs gconf completely.

1 Like

I've found a solution for Pix.
Fixed with version 2.4.3-2 in unstable.

1 Like

We also found a solution for OnlyOffice.
Until further notice, we will take over pconf from AUR.
OnlyOffice has also been updated to version 5.4.2.

If there are any other problems with gconf, please report.


2 posts were split to a new topic: Repo cleaning

Please update kvantum-theme-matcha 20190810-1 to fix this problem:

Fixed commits 28 Aug, 2019:

Last packager for kvantum-theme-matcha is @philm.

Also, I guess the description for kvantum-theme-matchama should be "Matchama theme for Kvantum", right? @Ste74

EDIT: Hum... wait a minute, the repo that used to be called "matcha-kde" got renamed to "matchama-kde"; therefore, isn't kvantum-theme-matchama supposed to simply replace kvantum-theme-matcha?

On Gitlab: "Project 'cscs/matcha-kde' was moved to 'cscs/matchama-kde'. Please update any links and bookmarks that may still have the old path."

EDIT2: Now that I think of it, we can't make an automatic replacement just like that, considering that the theme has been renamed. People that used the theme with the old name will suddenly have problems because the theme with the old name won't exist anymore.

For the old package, perhaps we could add "(obsolete, replaced by matchama)" or something like that.

By default, kvantum-theme-matcha is installed after installation. I also noticed this second kvantum-theme-matchama package. So you can safely swap them?

As stated here, pyrex is a dependency of compiz-manjaro in the extra repo but is no longer in the Testing or Unstable branches.

It looks like compiz in the AUR removed its pyrex dependency in February of last year when it was updated to 0.9.14. It is likely that either the dependency will need to be reintroduced to keep the 0.9.13 version, or manjaro-compiz needs to be updated.

Latest version is according to upstream.

The latter option would be the best choice to me (update Compiz), unless there is technical reason not to do it.

Last packager is @philm

1 Like

Well, at first glance, I do not see why it would be a problem.

Try to install kvantum-theme-matchama first. Is there is no conflict between the two packages, you should be able to change your Kvantum theme like you would do with any theme.

EDIT: I have just noticed that you are using KDE. I am not very knowledgeable about KDE theming, so I do not know if you would need to do more steps to theme your system properly.

firefox needs an update to version 72 to fix security vulnerabilities.

firefox is not Manjaro specific, it is an Arch Linux package. It was updated to version 72 yesterday:
Yet maybe for the sake of security it can be quickly put to Testing and Stable Manjaro repositories.

Ah, right you are (now). At one time it was packaged by a manjaro team member and I still thought it was without re-checking.
Arch's package works for me, btw.

Package file on Manjaro repos is vulnerable to

Should be updated to 5.38-1

file is a core Arch package and is already updated to 5.38.1 in the Manjaro unstable branch.

1 Like

The package snapper-gui needs a rebuild for Python 3.8 – or at least I think that's what this error suggests:

Error message
Traceback (most recent call last):
  File "/usr/bin/snapper-gui", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 3252, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 583, in _build_master
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'snappergui==0.1' distribution was not found and is required by the application

Is trizen one of ours? currently at 1.62-1 we have 1.58-1.

Yes it is.

testing is still at 1.58.

1 Like

Forum kindly sponsored by