Manjaro sometimes recognises a held key after not typing (dell latitude 7275)

Not too long ago i discovered manjaro and thought it would be a good Linux distro to run on my device, and so far its pretty flawless using gnome as its more touch friendly, apart from this issue. Sometimes when i stop typing Manjaro seems to recognise a keypress and it holds that last key until i press a key to stop it. This doesn’t seem to be a hardware issue as the keyboard doesn’t exhibit this issue with win 10 and 11. Ive also tried the KDE Plasma and Xfce versions but they also do it. Using a usb keyboard doesnt cause that issue. Any ideas?

Hi @DDM, and welcome!

Those 2 facts point to hardware, which is what I think.

LESS issues in Windows? Never thought I’d see the day. Anyway, I think it’s the key-repeat in Windows that might be slightly longer than Manjaro.


This might help:


Yeah ive found it funny that there would be such an issue that isnt present on windows lol. Anyway ive followed the link and tried the example command which didnt do it, and i also applied a 1000ms delay and 1hz rate, however no change.

Except hardware, I have no idea then…

:man_shrugging: :sob:

Damn, ill try and see if i can thoroughly clean the keyboard, tho thanks for earlier idea

1 Like