Manjaro slow rendering of videos and full-screen apps

I’ve recently upgraded to a larger SSD and installed Manjaro (gnome) on it.
Everything works fine, apps launch fast and loads in seconds but when I try to watch a video at a resolution higher than 480p it just slows down dramatically and it’s unwatchable. I have a 4k monitor but I’ve never had any problem watching videos on my previous archlinux-based distro, EndevaourOS.
This happens when using full-screen apps as well, for instance when I scroll a web page on Firefox text and images overlap and the overall experience is quite bad.
I was using open-source drivers and I tried to switch to proprietary (nvidia in this case) ones, but with no success. Could it be that the SSD is faulty? What else should I be checking?

$inxi -G                                       
Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] driver: nvidia v: 455.45.01 
Display: x11 server: 1.20.9 driver: nvidia 
resolution: <xdpyinfo missing> 
OpenGL: renderer: GeForce GTX 980 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01

UPDATE: I discovered the problem is occurs only on Firefox (v83.0)… WHY DID YOU DO THIS TO ME MOZILLA :sob: I’ve disabled hardware acceleration as suggested here but with no success.

Are you running Gnone on Wayland or X, and what was you using on EndevaurOS as desktop environment?

I’m on gnome on x11 now.
I was using gnome for EndeavourOS as well.

Try wayland, :slight_smile: also maybe there was different Nvidia driver.

is there a particular reason why I should try switching to wayland? isn’t it considered less stable then xorg?

I would say not. Maybe you’ll miss some features like screen recording on apps that never bothered to implement some of the wayland protocols.

I found out that the problem exists only while using Firefox. I tried disabling hardware acceleration, rebooted but it didn’t solve the problem.

Any extensions or addons you are using.

Else I have no clue. :confused: Most likely Nvidia’s inferior driver stack.

I am not sure if already fixed or not.

You could try older kernel as Arch Linux - News: nvidia 455.28 is incompatible with linux >= 5.9 tells there was a problem with nvidia, as usual. (forgive me the smugness, I really hate that company)