Manjaro Shutdown Time Sometimes Slow

As you have done before:

Oh, okay. I didn’t notice that there’s an sda in the path to understand that the result is for /dev/sda.
Yes, it gives: mq-deadline kyber [bfq] none

After reading the manual of your laptop, it could be also your TPM that is too slow for generating random numbers and therefore slow down the whole boot and shutdown process.

Could you post the output of:

cat /proc/sys/kernel/random/entropy_avail
1 Like

Yeah, sure! It gave a number: 3043.

I did all these and everything went just like we expected. Just for the last part, it just shut itself down instead of restarting. It shut itself down and the power light went off. I expected it to light back on signalling a reboot, but it didn’t light back up for 15-20 seconds. So, I manually pressed the power button and the system booted up without any problems.

It’s not like it shut itself down abruptly. It did say stuff like “Firmware update is complete” and then shut itself down. Nothing to really worry about, right?

Nothing to worry here then. If it would be <1000 then it could be an issue.

If it completed then it is alright.

1 Like

So? What’s the net result? Shutting down faster now?


I’ll try working on my laptop for > 2 hrs now and let y’all know for sure

1 Like

Okay guys, I just worked on it multiple times for multiple hours, and now it takes 5-10 seconds to shut down. Looks like the problem has been solved. It’s unlikely that it’ll again take 1 minute 30 seconds again except after a mass update or something. :grinning:

Thanks a bunch! :grin: @Fabby @megavolt

I feel it’s the firmware update that fixed it. What do you guys think?


@megavolt Which one of the whole bunch should be marked as an answer according to you? Post #33 mentions updating firmware first.


1 Like

Hi, didn’t mean to annoy y’all but it seems like the 1m 30s shutdown delay is back. It took 1m 30s yesterday once, so I thought it might just be a one-time thing. But nah, today it again took 1m 30s to shutdown.

But anyway, thanks for your time. @Fabby @megavolt

It seems like this doesn’t have a solution. Y’all wanna check some logs or some terminal output for one last time?

Hey…if nowatchdog is set to the kernel parameter, you might need to blacklist the hardware module also:

blacklist iTCO_wdt

Here how to do it: Kernel module - ArchWiki

Watchdog is a hardware service to ensure that the hardware shutdown or reboot properly. Therefore it sets a timer until it should force shutdown. If not there it will not wait for the hardware/firmware and shutdown immediately. While it is useful on servers for remote reboot/shutdown, on Desktop PCs it is not really needed because you have access to the power button and even the power plug.

1 Like

Go to the directory
open the file lvm.conf with kate.
Replace the line
use_lvmetad = 2 with use_lvmetad = 0

It works for me

THis work for me

When someone complains because they haven’t received an answer within the first 18 minutes, it must be a great community! I’ve seen Microsoft boards with questions that receive no response in 18 months!

More power to the Manjaro community!

Ruziel :slight_smile:


People if you have wine 5 or more ,no matter wine apps installed downgrade to 4 and it realy fixses the problem with shutdown and restart speed

Hello :slight_smile:
i install manjaro kde plasma yesterday and i have same problem too slow when i start, restart or shutdown
i don’t even know how to write a post in this forum, i was planning to install it again
im fully noob sorry and im not good enough in english but i will learn how to use linux operating system

    ~  inxi --full --verbosity=7 --filter --no-host              ✔ 
  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1
  dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: Z370 Gaming K6
  serial: <superuser required> UEFI: American Megatrends v: P1.20
  date: 10/26/2017
  Message: No system battery data found. Is one present?
  RAM: total: 15.55 GiB used: 2.92 GiB (18.8%)
  RAM Report:
  permissions: Unable to run dmidecode. Root privileges required.
  Info: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP
  arch: Kaby Lake note: check rev: A cache: L1: 384 KiB L2: 1.5 MiB
  L3: 12 MiB bogomips: 88824
  Speed: 1923 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800
  2: 800 3: 865 4: 1936 5: 1677 6: 815 7: 1091 8: 1537 9: 2187
  10: 1652 11: 1403 12: 800
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
  epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
  fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp hwp_notify ibpb
  ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
  md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36
  pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1
  xsave xsavec xsaveopt xsaves xtopology xtpr
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Micro-Star MSI
  driver: nvidia v: 495.44 bus-ID: 01:00.0 chip-ID: 10de:1b80
  class-ID: 0300
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: nvidia resolution: 1920x1080 s-dpi: 81
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
  v: 4.6.0 NVIDIA 495.44 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f0
  class-ID: 0403
  Device-3: Creative Sound BlasterX H7 type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2
  chip-ID: 041e:3242 class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e
  v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8
  class-ID: 0200
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb
  v: kernel port: c000 bus-ID: 05:00.0 chip-ID: 8086:1539
  class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.38 TiB used: 25.5 GiB (1.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H1
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
  serial: <filter> rev: EXA72H1Q temp: 38.9 C scheme: GPT
  ID-2: /dev/sda vendor: Western Digital model: WD10EZRZ-00HTKB0
  size: 931.51 GiB speed: 6.0 Gb/s type: HDD rpm: 5400
  serial: <filter> rev: 1A01 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / size: 468.09 GiB used: 25.5 GiB (5.4%) fs: ext4
  dev: /dev/nvme0n1p2 label: N/A
  uuid: 1c8d7b9c-7d11-41f3-b9f3-8b660cf28d00
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
  dev: /dev/nvme0n1p1 label: NO_LABEL uuid: 340B-00F4
  Alert: No swap data was found.
  ID-1: /dev/sda1 size: 931.51 GiB fs: ntfs label: Karim
  uuid: 9C700C9E700C816E
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Creative Sound BlasterX H7 type: Audio,HID
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
  speed: 12 Mb/s power: 100mA chip-ID: 041e:3242 class-ID: 0300
  serial: <filter>
  Hub-2: 1-3:3 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
  speed: 480 Mb/s power: 100mA chip-ID: 174c:2074 class-ID: 0900
  Device-1: 1-9:4 info: Corsair K95 RGB Platinum Keyboard [RGP0056]
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2
  rev: 2.0 speed: 12 Mb/s power: 500mA chip-ID: 1b1c:1b2d
  class-ID: 0300 serial: <filter>
  Device-2: 1-11:5 info: Cooler Master ARGB LED Controller
  type: HID,Keyboard driver: hid-generic,usbhid interfaces: 2
  rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 2516:1011
  class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 10 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-7:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
  speed: 5 Gb/s power: 8mA chip-ID: 174c:3074 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: ASUSTek ROG Gladius II Origin type: Mouse,HID
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 0b05:1877 class-ID: 0300
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 29.0 C mobo: N/A gpu: nvidia temp: 59 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 289 Uptime: 2h 10m wakeups: 0 Init: systemd v: 249
  Compilers: gcc: 11.1.0 Packages: pacman: 1214 Shell: Zsh v: 5.8
  default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.09
    ~                                                            ✔

:+1: Welcome to Manjaro! :+1:

  1. Please create a new post, because this one is very old and never got solved.
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


1 Like