Manjaro Settings Manager's Chinese text can't display normally

I have set Chinese as my manjaro default language, and xfce as my desktop.
Recently, I updated my packages to the newest. (manjaro-settings-manager 0.5.6-3 manjaro-settings-manager-notifier 0.5.6-3). I found that the softwares can't display Chinese normally.


How can I fix it? If you need more information, please let me know.

yes, the last update had several font package changes. i fixed it for myself by installing noto-fonts-cjk, though there are probably others that will work as well.

3 Likes



Yes I can confirm this issue. Took a long time to find my reply in stable tread. Could you please add something like "asian text looks likes blocks" to wiki?

You too have the power to edit the wiki!

But this problem only affects systems that only have ttf-droid installed (which renders CJK characters normally but is broken at the moment), but also no other CJK fonts to fall back on as well.

Yea, I am just not confident with my wording that is why I rarely do this myself
With great power comes great responsibility you know

How do you like my wording?

1 Like

After I try the command "sudo pacman -S noto-fonts-cjk", the problem is solved. Thanks!:grin:

My English isn't very good, can you add this yourself ?

korealinux already did this

Forum kindly sponsored by Bytemark