Manjaro Running MacOS in VirtualBox Trying to get 1920x1080

I have searched and searched, and can't find the solution to this question. I have Manjaro Running MacOS Sierra in VirtualBox Trying to get a screen resolution of 1920x1080. I've found several resources showing how to make this work if Windows is the Host operating system, but I can't find anything on Linux being the Host system. Does anybody know where to find the code to resolve this issue?

No idea about MacOS in Vbox.
But, you can try this I suppose?

Please be warned. This was tested on Ubuntu and might not work for Manjaro.

Make a backup first.

I am sorry to have to sound like a party pooper, but macOS is a proprietary operating system, and its use on any other machine than an Apple computer ─ whether virtual or bare metal ─ is illegal in most countries.

Asking us to support you in doing something illegal ─ thereby making us legally complicit ─ is unethical. If you really need advice with that, then please seek it at an appropriate venue. The Manjaro forum isn't one of them.

(Thread moved from #newbies to #other-os.)


The single most important setting for a virtual machine using Manjaro is the graphics setting.

Create a new VM and set the graphics to VBoxSVGA - but I may have misunderstood your issue.

At first I thought you were running Manjaro in VM on macOS - but the comment made me rethink.

I have original macOS DVD so I have no licensing issues as I have the origiinal install media.

However I have a lot of issues getting macOS to run - it requires several settings using VBoxManage - adding those settings.

You can probably set the resolution using the same setting used when you want a Windows VM to run at full resolution.

VBoxManage setextradata "name-of-your-machine" "VBoxInternal2/EfiGopMode" 5
should give you 1920x1200.

If that doesn't work, try
VBoxManage setextradata "name-of-your-machine" "VBoxInternal2/EfiGraphicsResolution" "1920x1080"

Funnily enough, my guide on how to install MacOS in VBox is still available (but outdated) here on the forum :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by