Manjaro reopens session even if not told to


I am using Manjaro with KDE and what I have noticed that after restarting or just shutting down the nest time I log in Manjaro automatically opens previous apps. After digging in system settings I found Desktop Session in Workspace > Startup and shutdown > Desktop Session. I think it is what I was searching for so form defaults I set When logging in to Start with an empty session, but the problem is still present. Am I missing something here or is it completely different setting?

Thanks in advice!

It is best, when changing those settings, to close all windows, log out and then log back in, in order to make sure that the setting sticks.

Also check whether you have anything undesirable listed under… (System Settings)

Workspace → Startup and Shutdown → Autostart

Haha, it worked!
It’s not intuitive at all, but it works.
Again, thanks for helping out!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.