Manjaro randomly freezes becoming totally unresponsive (whith audio loop)

Goodmorning to everyone,
I have been using Manjaro KDE for about two years without any big inconvinient, but since one month I’m experiencing this problem: the system randomly freezes while using it and it’s unresponsive to any input, so that I have to hard reset by long pressing the power button (even the REISUB “shortcut” doesn’t work in this case). It mainly (but not exclusively) happens while playing videos and in this cases the last ~2 seconds of audio are repeated in loop.

I think it isn’t a kernel-version problem, since I experienced it with versions 4.19, 5.4 and 5.10. And I also suppose it isn’t an hardware problem because it never happened on ElementaryOS and Windows 10 (which I have in dual-boot).

I know there are a lot of similar topics on the forum, but some are left open and the others don’t provide solutions that worked for me.

Here the output of inxi -Fazy

  Kernel: 5.10.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=07d5fbe2-2b7d-4f9c-8381-00604c0059b1 rw quiet 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: X540LJ v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X540LJ v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X540LJ.205 date: 03/14/2016 
  ID-1: BAT0 charge: 15.3 Wh condition: 29.9/33.2 Wh (90%) volts: 10.8/10.8 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging 
  cycles: 861 
  Info: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F 
  L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 15971 
  Speed: 798 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 class ID: 0300 
  Device-2: NVIDIA GK208BM [GeForce 920M] vendor: ASUSTeK driver: nvidia 
  v: 390.141 alternate: nouveau,nvidia_drm bus ID: 04:00.0 chip ID: 10de:1299 
  class ID: 0302 
  Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-5:3 chip ID: 04f2:b52b class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c class ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  class ID: 0403 
  Device-3: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus ID: 04:00.1 chip ID: 10de:0e0f class ID: 0403 
  Sound Server: ALSA v: k5.10.19-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK 
  driver: r8169 v: kernel port: 4000 bus ID: 02:00.2 chip ID: 10ec:8136 
  class ID: 0200 
  IF: enp2s0f2 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: AzureWave driver: ath9k v: kernel port: 4000 bus ID: 03:00.0 
  chip ID: 168c:0036 class ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus ID: 1-4:4 
  chip ID: 13d3:3423 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 465.76 GiB used: 118.11 GiB (25.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
  ID-1: / raw size: 35 GiB size: 34.2 GiB (97.72%) used: 27.33 GiB (79.9%) 
  fs: ext4 dev: /dev/sda8 maj-min: 8:8 
  ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) 
  used: 33.7 MiB (13.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 105 GiB size: 102.85 GiB (97.95%) 
  used: 90.78 GiB (88.3%) fs: ext4 dev: /dev/sda10 maj-min: 8:10 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 5 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda11 maj-min: 8:11 
  System Temperatures: cpu: 37.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2100 
  Processes: 186 Uptime: 19m wakeups: 25075 Memory: 3.74 GiB 
  used: 2.29 GiB (61.3%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1565 lib: 426 flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole 
  inxi: 3.3.01 

How can I avoid these annoying freezes?
Thank you in advance for any help! :slight_smile:

:+1: Welcome to Manjaro! :+1:

  1. You have a 4GB machine with KDE Plasma and a slow HDD with standard swapping parameters.

    • use LXDE
    • set your swappiness to 90 and your cache pressure to 75
  2. REISUB needs to be enabled.

  3. Every time you hard reset:

    your file system gets damaged if you don’t boot from an ISO and repair your file system (only /home can be fscked from /) and after the 100th time you might run into serious trouble.


Thank you for your reply and for the suggestion!

I know hard reset is a very very bad way to “solve” a freeze, that’s why I was looking for a solution as soon as possible. Unfortunately REISUB is enabled (I discovered it while looking for alternatives to hard reset): I tested it in a normal situation and it worked, but in these freezes it doesn’t… I don’t know why.

At the moment I “solved” the problem doing a fresh install in another partition, but if someone can help me to find a real solution, it would be nice.

Thank you again!

Can you still boot into the old partition?
If yes, can you create a new user (E.G. greenpit2 and logging in there and see if it happens there too?)

If it happens there too, no one will be able to find a solution for you so please read this to lighten your mood:

because you’re in for a fresh install…



Thank you again! I’ll try as soon as possible

P.S. the fresh install is working flawlessly

1 Like

As far as I’ve been able to test, your solution works!

Thank you again!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.