manjaro plymouth not working.

I installed plymouth following the tutorial on Arch Wiki, but it doesn't seem to work.

https://wiki.archlinux.org/index.php/Plymouth

Can be displayed when shutdown.

But the manufacturer logo will be displayed when booting.

I use efi boot system.

I want to know how to disable the vendor logo and enable plymouth.

Thank you all for your help.

I think that's the purpose of the grub-vanilla package.
So try using that, instead of the regular grub.

you need to enable early kms for Plymouth/bootsplash to work

you can do so by editing
/etc/mkinitcpio.conf

MODULES=(i915 amdgpu nouveau radeon)

then

sudo mkinitcpio -P linux
sudo update-grub

if using
nonfree nvidia
then add

nvidia

in modules

also install
plymouth-git
package from aur

dont use Plymouth from repo its way outdated.

Hi, I did as you said, but it still didn't improve. I added "quiet splash" to /etc/default/grub and then sudo update-grub

Thanks,I don't understand.I did not use nvidia graphics

just edit the mkinitcpio.conf
and add the module.

if you want Plymouth enabled iso.
you can check out
wayfire linux

or
manjarowish gnome-gaming edition

Sorry, I said wrong, my English is poor, I did as you said, the situation has improved, plymouth can be previewed, but I can't enter the interface, it is stuck

press esc
or
ctrl + alt +f4

btw what graphics card do you have

i5 8250u + 940mx

Do it as described without steps 2 and 5:

I found my manufacturer's icon at /sys/firmware/acpi/bgrt/ . Do I need to delete it? I feel like it is blocking plymouth

Please forgive me that my English is not very good, I ca n’t read a lot of English composition articles

Use an online translator or ask in threads for your language then:

Not necessarily. It cannot block Plymouth. You don't see theme for some other reason, most likely - misconfiguration.

ok,thanks

This issue has been resolved, and I have come to the following conclusions after repeated testing.

install plymouth

yay -S plymouth-quit

add to /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="video=efifb:nobgrt quiet splash ..."

add to /etc/mkinitcpio.conf

MODULES="i915"
HOOKS="base udev plymouth ..."

sudo update-grub
sudo mkinitcpio -P

#Smooth transition
sudo systemctl disable lightdm.service
sudo systemctl enable lightdm-plymouth.service

You can see the effect after restarting.

Thank you for your kind help!

1 Like

The transition is not smooth, or not. I abandoned plymouth and enabled bootsplash, which looks much better.

Until you enable Secure Boot and/or connect another monitor - yes.

Forum kindly sponsored by