Manjaro partition keeps freezing up

Before installing the kernel try

$ mkinitcpio -P 

{creates all img kernel}

Ok so this did clear up the previous issue, but now when I try the sudo mhwd-kernel line, I get an error that says target not specified. Thanks alot for all your help so far, by the way.

Check kernel status by

$ mhwd-kernel -li

It could be required to update the system first by

$ sudo pacman-mirrors -f 5
$ sudo pacman -Syyu

I did update the system with the pacman -Syyu line before, but I will try the other two things now too.

Still getting error no targets specified after doing this too

Please provide output of

$ mhwd-kernel -l

and

$ mhwd-kernel -li

The error message could also occur if you boot with a non-Manjaro kernel. I guess your LIVE session based on a Manjaro edition?

[manjaro /]# mhwd-kernel -l
available kernels:
   * linux316
   * linux414
   * linux419
   * linux44
   * linux49
   * linux51
   * linux52
   * linux53
   * linux419-rt
   * linux50-rt
[manjaro /]# 

[manjaro /]# mhwd-kernel -li
Currently running: 4.19.28-1-MANJARO (linux419)
The following kernels are installed in your system:
   * linux316
[manjaro /]# 

I am hoping somebody could please help me out with this. My system is further messed up after following the advice of danielsuarez above.

Then install the latest 4.19.xx kernel and kernel version 5.2.xx.

And test again.

I'm wondering that only linux316 is installed. Anyway, in this case I would first try to install linux419 similar to my explanation (chrooted) and by using

$ sudo mhwd-kernel -i linux419

I am unable to. When in chroot in the live usb, I get "error: no target specified" when I try to install those kernels.

I tried that and it says that I cannot reinstall my kernel. It's as if I'm working within the live usb in chroot instead of my actual system....

How do you want to chroot into the system?

Normally: manjaro-chroot -a

and then select to the system, where you want to chroot into.

That is what I have been doing.

You could replace

$ sudo mhwd-kernel -i linux419

by

$ sudo pacman -Syyu linux419

If it fails again have a look into last lines of the log file /var/log/pacman.log. If it's a success don't forget $ exit to leave chroot properly.

Alright that worked!!! but now we're back to square one with my original freezing issue..... lol

OK, let's see. What Win 10 version are you using?

Here are the recommended OSI strings:

  • version 1607 -> 'Windows 2016'
  • version 1703 -> 'Windows 2017'
  • version 1709 -> 'Windows 2017.2'
  • version 1803 -> 'Windows 2018'
  • version 1809 -> 'Windows 2018.2'

Put the the right string into your grub file:

$ sudo nano /etc/default/grub

just as an example:

acpi_osi='Windows 2012'

In the grub file it should be added just behind

GRUB_CMDLINE_LINUX_DEFAULT="

Then Ctrl+o und Ctrl+x to safe and exit.

Then:

$ sudo update-grub

Finally, reboot.

It is still freezing after doing this unfortunately :frowning:
I really appreciate all your help so far!

As an easy fix you could try adding acpi_osi=! to your grub file - very similar as described before. As an example the changed line could start like this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' ...

Then:

$ sudo update-grub

reboot.


If this does not help then I would try to install linux52 by

$ sudo pacman -Syyu linux52
$ sudo mkinitcpio -P

Install the headers for the currently running kernel by

$ sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

Try to rebbot with this newer kernel. It could be useful to install the header for linux52 when running with the above command, again.

Update the system then and tell us if it improves the situation.

Just bumping my post in hope that somebody can help me with this. I still have not been able to fix this freezing issue unfortunately. Thanks

Forum kindly sponsored by Bytemark