Manjaro paket yöneticisi güncelleme hatası

aur deplarında 9 tane uygulamayı paket yöneticinden güncellerken hata alıyorum
veritabanı kilitlenemiyor eşitlenmiyor hatası
ve peşine geçersiz veya bozuk veri tabanı uyarısı alıyorum nasıl düzeltebilirim

bilgisayarda db.lck dosyasını aratıp silin. ardından pamac update komutunu deneyin.

sudo pacman -Qq db.lck diye arattım ve bu çıktıyı aldım
hata: veritabanı (archlinuxfr) kaydedilemedi (veritabanı zaten kayıtlı)
hata: ‘db.lck’ paketi bulunamadı

ek olarak sudo pacman -Qq diye yazarak kendim aradım gene bulamadım
cd db.lck yaptığımda ise cd: böyle bir dosya ya da dizin yok: db.lck bunu aldım

pamac update yaptığımda ise,
Hazırlanıyor…
Paket veritabanları yenileniyor…
veritabanı kilitlenemiyor
Veritabanları eşitlenemedi
Yenileniyor AUR Depoları…
skypeforlinux-stable-bin derleme dosyaları klonlanıyor…
skypeforlinux-stable-bin bilgisi oluşturuluyor…
skypeforlinux-stable-bin bağımlılıkları kontrol ediliyor…
Hata: İşlem hazırlığı başarısız oldu: geçersiz veya bozuk veritabanı

Derleme dosyalarını düzenle : [e]
İşlemi uygula ? [e/y/N] e

İşlemden vazgeçildi.

db.lck bir paket değil.

terminalde şunları bir deneyin:

sudo rm /var/lib/pacman/db.lck
sudo rm /var/tmp/pamac/dbs/db.lck

program ekle/kaldır’dan özelliklere girerek aur veritabanını temizleyin. skype paketini kaldırın.
ardından tekrar güncellemeyi deneyin.
bundan sonra skype paketini tekrar yükleyin.

aur veri tabanını temizleyin derken gelen güncellemeleri mi sileyim
sudo rm /var/tmp/pamac/dbs/db.lck bu işe yaradı direk silindi şimdi skype kaldıracağım

sudo pacman -Su
hata: GPGME hatası: Veri yok
hata: GPGME hatası: Veri yok
hata: GPGME hatası: Veri yok
hata: GPGME hatası: Veri yok
hata: veritabanı (archlinuxfr) kaydedilemedi (veritabanı zaten kayıtlı)
hata: ‘core’ veritabanı geçerli değil (geçersiz veya bozuk veritabanı (PGP imzası))
hata: ‘extra’ veritabanı geçerli değil (geçersiz veya bozuk veritabanı (PGP imzası))
hata: ‘community’ veritabanı geçerli değil (geçersiz veya bozuk veritabanı (PGP imzası))
hata: ‘multilib’ veritabanı geçerli değil (geçersiz veya bozuk veritabanı (PGP imzası))

böyle hata almaya başladım

‘pacman -Su’ güncelleme için yeterli değil. pacman kullanacaksanız pacman -Syu veya pacman -Syyu komutunu kullanın.
güncellemeyi terminalden pamac update komutuyla yapın, böylece aur paketleri de güncellenir.
mirror’ları güncellemek için de pacman-mirrors kullanabilirsiniz. bu ikisini birlikte yapmak için:
sudo pacman-mirrors -f && pamac update

çok teşekür edderim peki aur veri tabanını nasıl temizleyebilirim

pamac update

yaptıktan sonra
monado-git bağımlılıkları kontrol ediliyor…
openxr-git bağımlılıkları kontrol ediliyor…
openxr-utils-git bağımlılıkları kontrol ediliyor…
monado bağımlılıkları kontrol ediliyor…
openxr-layers-git bağımlılıkları kontrol ediliyor…
qjson bağımlılıkları kontrol ediliyor…
xr-hardware bağımlılıkları kontrol ediliyor…
libsurvive bağımlılıkları kontrol ediliyor…
openhmd bağımlılıkları kontrol ediliyor…
sbt-extras-git bağımlılıkları kontrol ediliyor…
sbtools-git bağımlılıkları kontrol ediliyor…
sbtools-hook-git bağımlılıkları kontrol ediliyor…
sciplot bağımlılıkları kontrol ediliyor…
sbsigntools-git bağımlılıkları kontrol ediliyor…
efitools-git bağımlılıkları kontrol ediliyor…
Hata: İşlem hazırlığı başarısız oldu: geçersiz veya bozuk veritabanı

Derleme dosyalarını düzenle : [e]
İşlemi uygula ? [e/y/N] e

İşlemden vazgeçildi.

Hata: İşlem hazırlığı başarısız oldu: geçersiz veya bozuk veritabanı

yazılım ekle kaldırdan da aynı hatayı alıyordum bunu nasıl düzeltebilirim

aur paketlerinizle ilgili bir sorun var herhalde. ben devamını bilemiyorum. güncellemeyi terminalde sudo pacman -Syyu komutuyla yapmayı deneyin, sorun çıkmazsa aur paketlerindedir problem.

program ekle kaldır’da (veya işte onun yerine geçen programda) özelliklere girin, üçüncü parti (türkçe isimlerini bilemiyorum) sekmesinde aur bölümünde temizle diye bir buton olmalı. Kastettiğim oydu.

ayrıca, işlemi uygula? satırındaki seçeneklerden e, edit anlamına geliyor. y evet, N hayır. o aşamada enter’a basarsanız işlemden vazgeçer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.