is down

Update: This is resolved.
Also mod moved around posts to this thread out of order so posts may seem out of place when separating from Stable Updates thread.

I changed to a different url and rebooted machine. Still same issue, so I do not think so.
Notably the “You need to log in to this network” has appeared too… but this is not the real case.

That’s my best guess — I got an “Unable to connect” message when I opened the link. I followed instructions to disable that part of NetworkManager per this post and my desktop stopped complaining of “limited connectivity.”

By the way, I’m getting this on my Manjaro system with my package branch set to testing and I last updated it yesterday, so I don’t think it’s an issue exclusive to the stable branch.

Edit: Apparently the main Manjaro site is down too, so it could be related to this issue.


Is there a special criteria for the check to pass? I tried setting the uri to a webpage I know is up and rebooted with no success.

Is it not just a simple ping to the uri provided?

I tried it, too, and I confirm that it doesn’t help. I tried the address from the Arch wiki instead—to no avail, mind you—but I haven’t disabled the check yet. Hoping for a fix instead.

I don’t know exactly, but at least we know that NetworkManager uses only one URL, which I think is a flawed way of checking connectivity. Windows and possibly macOS does this check a lot better in my opinion.


:construction: @philm is currently breaking upgrading the server. Please bear with us. :construction:


Response needs to be with the header X-NetworkManager-Status set to online or the body NetworkManager is online to work, header preferred mode.
But you should just wait, it’s a non-issue unless you have something relying on that status.

An intermediate solution is described here:

As intermediate solution run:

sudo nano /etc/NetworkManager/conf.d/20-connectivity.conf

and create the following content, then save and exit:


After this upgrade (kernel 5.10.53-1) KDE WiFi drawer shows a yellow ‘!’ and says limited connectivity. However Internet etc works fine. Doesn’t break anything except incorrectly sets the WiFi icon and hover text to say limited connectivity.

From lspci:
00:14.3 Network controller: Intel Corporation Cannon Lake PCH CNVi WiFi (rev 10)

Here is image

Edit/Update: From further down in thread, also “You need to log in to this network” has appeared for me.
From other user findings affects other kernel version and DE (GNOME and KDE confirmed so far).


Присоединяюсь. Сообщение “ограниченное подключение” появляется при Wi-Fi и проводном подключении. Интерне работает нормально.

English translation via Google Translate:

I join. The “limited connection” message appears for Wi-Fi and wired connections. The internet works fine.

1 Like

same here, r8169 on 8168 chip


Seems like it messes up spotify client. Somebody needs to verify that. Spotify opens normally, but all songs are greyed out and you can’t play them. Besides that you can control other playing devices as expected.
When running from terminal error appears:
/usr/lib/ no version information available
But it’s some old bug.

EDIT: seems like killing NetworkManager solves the problem.
FIX for now - disable NetworkManager connectivity check:
echo -en "[connectivity]\n.set.enabled=false" | sudo tee /etc/NetworkManager/conf.d/20-connectivity.conf
sudo systemctl restart NetworkManager

Same here. Maybe due to that “connectivity” issue with networkmanager.

Happens to me too. I disabled the connectivity check for now: NetworkManager - ArchWiki


Today has been my initiation with the connectivity check. I’ve never seen it before and had no idea what was wrong. In addition to limited connectivity notices, wifi connects fine but with another notice saying “unable to reach the internet” which sent me to the router’s reset button, among other things.

Before this thread was started I found the same post @acarasimon96 mentions and it helped get Manjaro online without the exclamation mark. I’m relieved and glad to have my sanity back regardless of when it’s ok to remove 20-connectivity.conf.

1 Like

I have no 20-connectivity.conf at /etc/NetworkManager/conf.d/ but I still have the login issue due to crash

The https version of is down

You have it at /usr/lib/NetworkManager/conf.d/20-connectivity.conf. See Archwiki.

In the interest of transparency, was this a planned outage? Was there a better way to let the community know about this outage?

Check on Manjaro twitter.

Of course not, it was not planned /wanted.

Edit: even better, just check the forum.

I am still facing issues , but not gonna lie some time ago it did get restored but same issue still going from last 20 minutes