Manjaro OpenRC installer: failed update

I tried to install again, 3 days ago the update during the liveusb install was working. Now it gives conflicts.

The ISO: manjaro-xfce-openrc-17.0-rc-x86_64.iso

I will try this version.

Manjaro Testbuilds - Browse /lxqt/17.0-rc2 at

not working.

I reinstalled the manjaro-xfce-openrc-17.0-rc-x86_64.iso and then during update:

if I remove that file update succeed

The first is a normal update question. If you update in the terminal with pacman, you should be able to reply yes to replace. In Manjaro OpenRC, consolekit is being replaced by elogind.

The second is a common update issue recently (that you handled correctly). Lots of discussion about that one in the forum.

1 Like

I hope we will not be forced to move to elogind (until it is well tested).

I would love having a “Don’t break my computer” mode like the other distro :wink:

there is a programming principle, saying “If it ain’t broken don’t fix it”

1 Like

The elogind packages have been tested for almost a month now (you’ve seen the discussion), with no major issues. I’ve been using it with no problems.

I think the consolekit packages probably won’t be supported/updated any more. You can keep using consolekit as long as it keeps working, I suppose.

consolekit is gonna be removed from the repos soon.
elogind works well, its tested, and solves lot of issues with DE packages, which would otherwise need ck specific version.

Okay guys I won’t resist :wink:

Because this is my distro of choice, even if I can’t solve the 2 last issues I have with that Dell Inspiron.

  • not possible to create a LUKS root during install. But without LUKS install works (this is NVMe SSD)
  • Not possible to activate any external display through the HDMI plug (it is that nvidia/intell hell).

For both, no other distro can

I tried manjaro architect, OBrevenge, Ubuntu Maté, Linux Mint, Antergos, Arch Anywhere.

1 Like

I also had this problem and solved it the same way. That file was simply a symlink linking to itself…; but xorg-server provides the real thing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark