Manjaro OpenRC 17.0 Xfce ISO [RC]

community-edition
openrc
release-candidate

#1

Release Candidate of the Manjaro OpenRC 17.0 Xfce ISO.

Packages include:

  • Linux 4.9.9
  • OpenRC 0.23.2
  • Eudev 3.2.0
  • ConsoleKit2 1.1.0

Main changes since last release:

  • Kernel updated to 4.9.x series (next LTS).
  • Reverted to using ALSA by default (decided by voting, see here for reference).
  • Old CLI installer patched to work with manjaro-tools 0.13.8 (changes
    available here).

Download:


Want to help Manjaro Team with OpenRC
Manjaro OpenRC 17.0.1 Xfce ISO
#2

Nice. Thanks for bringing back the CLI installer!

Couldn’t get to the desktop with i686 in Virtualbox (or qemu) but it booted fine on my real machine.


#3

A quick install report. No major problems.

Wrote USB from an existing openRC install, rebooted and used the CLI installer. There was a brief error on boot (β€œundefined video mode number: 37e”), probably because the laptop is plugged into a monitor.

On the hard disk section I did no partitioning but jumped straight to Filesystem Mountpoints, and wrote it to an existing partition over the top of another existing openRC install to an SSD. Proceeding, I skipped anything marked optional.

I also skipped the bootloader install, which seemed to be the source of the only real issue. Doing so appeared to bork the resident GRUB file. I solved this by running through the install from live USB again and letting it take control of the boot menu. Second time through it found all of the seven or eight partitions and ID’d them correctly.

Standard update led to 9 packages, which installed without incident. Number of packages per the pkgs.txt is 769 for the 923.8 MB iso. Gparted reported that the installed size was right at 4 GB.

Memory use for the updated system was 433.6 MB according to inxi.

A few bugs appear to remain unaddressed, such as needing to push lightdm along a little, but nothing even close to showstopping. Thank you sincerely again for all you do.

kK


#4

Awesome, downloading it right now.

Glad I can easely change the Kernel, as all kernels after the 4.8 series give me error messages at boot.
Something like:
ACPI Error: [GTF0] Namespace lookup failure.
ACPI Error: Method parse/execution failed
and so on.
(even though the OS seems to run fine…)

With the latest 4.8 kernel all is good, so I will stay with it.
The CPU is SandyBridge.

BTW: This error is not Manjaro specific as every distro with 4.9 kernel I tried exhibited the same issue.


#5

I can’t install it.

I need the β€œnonfree video drivers” option of other Manjaro distributioons.


#6

Hi,

Could you provide some details, like your graphics card and whether you are booting in UEFI mode or BIOS mode.


#7

Aaditya,

Just installed X64 with graphic installer. Went very smooth. Only had to set time manually.

Thanks again for these great iso’s.

db


#8

BIOS mode. NVIDIA GT760Ti

In other Manjaro distributions the β€œnonfree video drivers” option does the trick, the if it is not selected it can’t boot to graphic mode and can’t be installed.


[Manjaro OpenRC XFCE] Unable to boot into Manjaro using eGPU
#9

Hi,

While booting you can add extra boot parameters nomodeset xdriver=vesa, install, on first boot again set the above parameters, and install the non-free drivers for your card using mhwd.

Links


Getting back to Manjaro
Manjaro OpenRC 17.0.2 Xfce ISO [beta]
#10

Thank you aaditya.

First boot from USB and installation solved with your help, but I can’t find where to set the parameters in the first real boot from installation in HDD.


#11

Even easier:
Boot with a live USB, entering xdriver=vesa in the boot screen,
manjaro-chroot -a mhwd-tui
You might need to install mhwd-tui first. It looks like this:

                              ::Hardware::  
 β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
 β”‚    1   Install a kernel                      2   Remove a kernel           β”‚
 β”‚    3   Use free graphics                     4   Use nonfree graphics      β”‚
 β”‚    5   List installed drivers                6   Configure touchpad        β”‚
 β”‚    7   Configure printers                    8   Configure monitors        β”‚
 β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
                            ::Information::  
 β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
 β”‚    I   Basic system information              T   System temperatures       β”‚
 β”‚    D   Disk usage                            U   Home folder usage         β”‚
 β”‚    H   Detailed hardware information         B   Bios information          β”‚
 β”‚    P   Prosessor information                 M   Mountpoints and partitionsβ”‚
 β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
          Select a number                       0 Exit mhwd-tui


Getting back to Manjaro
#12

For that press β€˜e’ while at the grub prompt, and append the parameters at the end of the line starting with linux.

Described here:

If eugen-b’s suggestion seems simpler you can try that.


#13

I had this excat problem as EdoNork with previous openRC but couldn’t get the thing to work so gave up… why not just include β€œnonfree video drivers” option, isnt’ this the easiest solution…
out of curiosity, why it’s not included in this ISO ?

Cheers


#14

Because I used to have a pretty slow connection and every Mb of data transfer mattered (the non-free drivers take up around 100mb AFAIK).

I dont understand why the Nvidia card(s) hang with the free drivers though?


#15

Thank you for this version. It’s working flawless. Your Manjaro OpenRC is my main distro right now.

I’m still missing pulseaudio but is easy to install, I know it was a community choise based on our feedback but I’m used to change audio outputs constantly so it is a lot easier with pulseaudio.

I just installed manjaro-pulse paprefs pavumeter paman pasystray.

I use pasystray as my volume tray icon and manage pulseaudio. Just wanted to share this with anyone else interested in to keep using pulseaudio.


#16

Thanks for your hard work! Is there a possibility of a heavily trimmed down version of Manjaro OpenRC being released? Just the barebone ISO so I can install only packages that I want.


#17

#18

If you install this ISO and run into problems updating, please see here:

forum.manjaro.org/t/unstable-xorg-server-libglx-so-file-conflict-during-mesa-17-0-update/17809/63

The fix is pretty straightforward.


#19

I created an account just for thanking you. I love Manjaro but it (and any other OS with systemd) hangs on boot for a minute and it’s getting worse every boot, for unknown reason. This solved my problem, keep up the good work!


#20

It’s been a long time since a net install iso, will there be one soon?