Manjaro OpenRC 17.0.2 Xfce ISO [beta]

Hi!

New release of the Manjaro OpenRC Xfce ISO.

Packages include:

  • Linux 4.9.34
  • OpenRC 0.26.3
  • Eudev 3.2.2
  • Elogind 229.6

Main changes:

  • Includes newer version of the Calamares which fixes a bug that generated weak password hashes (link).

  • This build experiments with a hybrid ALSA Pulseaudio setup in which PulseAudio uses the ALSA dmix backend (link) and is configured to start only when an application uses/needs it. For people who do not want it it should be easy to remove with pacman -Rs pulseaudio pavucontrol, while for people who have trouble with plain ALSA but pulse works for them out of the box can enable it by default adding PulseAudio to startup (Settings -> Session and Startup -> Start Pulseaudio sound server), and reverting the changes done to /etc/pulse/default.conf (link).

  • Firefox has replaced Palemoon. Since version 54 Firefox seems smoother and more responsive than before (on real hardware, in virtualbox it seems slower) due to multi process rendering; for older, less powerful systems or if you just prefer it, Palemoon can be installed with pacman -S palemoon-bin like it was in the previous version of the ISO.

Download:

Possible issues:

  • The mute key on the keyboard (generating a XF86AudioMute event) or mute shortcut on the volumeicon may not work correctly in this hybrid ALSA pulse system; as a workaround it have included a script mute-unmute-audio (in /usr/local/bin) which may work.
    If the script works a keybind can be added for it (also let me know so that if a large number of people experience this issue it can be used by default). Relevant link here.

P.S.
Let me know if the hybrid ALSA PulseAudio system works or we should switch to something else.

  • Hybrid Pulse + ALSA works
  • PulseAudio only
  • ALSA only (means no firefox too)

0 voters

3 Likes

System would not start if non-free drivers selected.

At end of installation calarmares would not restart the system.

Needed to install manjaro-pulse before I could turn off my unused built in audio

Changed from stable to unstable and got thiis bug

This bug has now migrated to testting!

Elogind has just been updated and now fixes this problem

1 Like

english phrasing problem? the way your first sentence is structured, it says “older-thing has been replaced with newer-thing” and which would mean the new iso has palemoon instead of firefox, but the rest of the paragraph suggests that the new iso has firefox. if that’s so, it should say “firefox has replaced palemoon”.

1 Like

Hello,

Install was almost fine, tried with VB and metal.

2 small issues with networkmanager:

This one is not blocking but present in both tests.

The other one on real machine only:
Networkmanager failed to start on live session and giving therefore netmount service errors.
Which resulted that I couldn’t mount my EFI drive with calamares, vfat was not recognized ( I don’t see the link).
I could mount the drive through CLI without any issue.
As soon as I connected to WIFI and restarted networkmanager, calamares recognised my EFI partition.

I never encountered this with systemd live session, but haven’t retested calamares since 2-3 months.

I can do some more tests if you need.
I will see for the sound tomorrow.

Below the details:

System:    Host: onf-openrc Kernel: 4.9.35-1-MANJARO x86_64 (64 bit gcc: 7.1.1) Console: tty 0 dm: lightdm
           Distro: Manjaro Linux
Machine:   Device: laptop System: Apple product: MacBookPro11 5 v: 1.0 Chassis: type: 9 v: Mac-06F11F11946D27C5
           Mobo: Apple model: Mac-06F11F11946D27C5 v: MacBookPro11 5
           UEFI: Apple v: MBP114.88Z.0172.B16.1702161608 date: 02/16/2017
Battery    BAT0: charge: 74.4 Wh 98.0% condition: 76.0/87.5 Wh (87%) volts: 12.9/11.4
           model: DP bq20z451 serial: N/A status: Full
CPU:       Quad core Intel Core i7-4870HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19961
           clock speeds: min/max: 800/3700 MHz 1: 1309 MHz 2: 1199 MHz 3: 1224 MHz 4: 1199 MHz 5: 2501 MHz
           6: 1199 MHz 7: 1199 MHz 8: 1306 MHz
Memory:    Array-1 capacity: 16 GB (est) devices: 2 EC: None
           Device-1: DIMM0 size: 8 GB speed: 1600 MT/s type: DDR3
           manufacturer: 0x802C part: 0x31364B544631473634485A2D314736453120 serial: N/A
           Device-2: DIMM0 size: 8 GB speed: 1600 MT/s type: DDR3
           manufacturer: 0x802C part: 0x31364B544631473634485A2D314736453120 serial: N/A
Graphics:  Card-1: Intel Crystal Well Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0d26
           Card-2: Advanced Micro Devices [AMD/ATI] Venus XT [Radeon HD 8870M / R9 M270X/M370X]
           bus-ID: 01:00.0 chip-ID: 1002:6821
           Display Server: X.Org 1.19.3 drivers: ati (unloaded: radeon) FAILED: modesetting
           Resolution: 2880x1800@59.99hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 17.1.4 (compat-v: 3.0) Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
           Card-2 Intel Crystal Well HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0d0c
           Card-3 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 1002:aab0
           Sound: Advanced Linux Sound Architecture v: k4.9.35-1-MANJARO
Network:   Card: Broadcom Limited BCM43602 802.11ac Wireless LAN SoC
           driver: brcmfmac bus-ID: 04:00.0 chip-ID: 14e4:43ba
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.3GB (60.6% used)
           ID-1: /dev/sda model: APPLE_SSD_SM0512 size: 500.3GB serial: S29ANYAG884146
Partition: ID-1: / size: 12G used: 3.4G (32%) fs: ext4 dev: /dev/sda6
           ID-2: /boot size: 197M used: 137M (70%) fs: vfat dev: /dev/sda1
           ID-3: /run/media/onf/Data size: 326G used: 280G (86%) fs: hfsplus dev: /dev/sda4
Unmounted: ID-1: /dev/sda2 size: 99.48G
           fs: HFS Extended version 4 label: Macintosh HD uuid: 1d7003e5-bcb9-3c4f-8570-c826bc717210
           ID-2: /dev/sda3 size: 0.65G
           fs: HFS Extended version 4 label: Recovery HD uuid: 008b25fd-4e96-35bd-95c4-f6d2409d2360
           ID-3: /dev/sda5 size: 37.58G fs: ext4 label: N/A uuid: bbc3529f-eac1-4ccc-a990-2ff45b6cb207
Sensors:   System Temperatures: cpu: 66.0C mobo: N/A gpu: 63.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 196 Uptime: 1 min Memory: 440.7/15928.3MB
           Init: SysVinit v: 2.88 rc: OpenRC v: 0.26.3 runlevel: default default: 3 Gcc sys: 7.1.1
           Client: Shell (sudo running in bash) inxi: 2.3.23
1 Like

I really wish you stuck with your last change, abandon Firefox. Imposing pulseaudio on users is just beginning. What will be next? Firefox will not run without systemd? Probably that is next, and not only for Firefox.
If you want to fight this plague you have to stick to your guns, don’t give in on anything, otherwise it’s a losing battle.
Thank you for your work, I do appreciate it.

2 Likes

I feel you, 57, but …

“Beta”. “Experiment”. Solicitously worded poll and everything.

Personally I didn’t vote because I haven’t had time to test the beta, and because of semi-rational skepticism about it too I suppose.

But I think it’ll be alright in the end. I have a lot of faith in the OP and the guns he sticks to.

1 Like

@kernelKurtz thanks for the vote of confidence :slight_smile:

@polaca57 its not personal mate, its what the majority of people want, and if i can accomplish that while still giving an option to opt out for. If alsa and palemoon work for the majority of people, i see no reason to change it.

1 Like

I think you misunderstood what I was saying. I wanted you to stick with your decision to abandon Firefox in favour of Palemoon. I am against Firefox, not for it. :slight_smile:

1 Like

are you against firefox because of the pulseaudio requirement specifically? because it may still be possible to get sound in it using jack or apulse.

(not answering for polaca57!)

… but your question, steanne, reminded me immediately of another 3-day-old Reddit thread …

Tim Berners-Lee approves Web DRM, but W3C member organizations have two weeks to appeal

And specifically:

Might be time to ditch HTML folks!

I thought it was a real interesting concept. Though the potential alternatives offered (Display PostScript, Display Ghostscript) seem somewhat less than up to such a huge task …

(I’ll stop derailing now!)

I am against anything that forces something down our throats. And Firefox is doing just that. This time it’s pulseaudio, what is next?

1 Like

Not sure how to respond to the poll. Pale Moon is fine overall, but can be fairly annoying as well. I’ve been adjusting to using it but find myself missing modern Firefox. It’s nice to hear it’s running more smoothly with recent versions. Then again, maybe it’s not Pale Moon, but all the bloat and useless “evolving” technology on popular websites that’s the problem. Still quite a shame FF decided PulseAudio only :slightly_frowning_face: Installing & running apulse would feel like I’m just putting a band aid on it.

IMO, it seems the amount of software at the moment that’s actually dependent on systemd or pulseaudio is small. I imagine if it increased you’d get more dissent and more people inspired to do something about it. Maybe not :man_shrugging:t5:

1 Like

Just installed this and it is great! A question though, it won’t let me upgrade the kernel - is this normal?

(In the Kernel app in the Manjaro Settings Manager)

After you install kernel in your MSM, you can switch kernel by reboot and the select your preferred kernel in GRUB…

It would not let me install in MSM although I dd install with the regular add/remove program. In MSM it just did nothing…

Another small but serious (to me) problem. If I connect my Samsung tablet by cable, it shows up in the places list on Thunar but I can’t access it. I move stuff (mainly books) all the time so this is something I need to work. I see the usual MTP support is already installed so II’m at a loss. This works in MX-Linux and PCLinuxOS (my two main distros until today) and I didn’t have to install anything special.

Any help?

Maybe this might help with your tablet?

And try starting manjaro-settings-manager in a terminal and see if you get any errors.

2 Likes

Cimmaronline beat me to it. There are a number of threads from the last few months about mounting issues. The one he pointed to is a good start.

The probable reason that MX and PCL are working is that most of the Debian-based nosystemd distros haven’t chosen to move ahead with a real alternative (like OpenRC), but are still basically running sysvinit, and shimming their way around systemd dependencies.

I think that’s even true of Devuan, so far, though they’ve begun conversations on their forums about s6 and runit and OpenRC as longer-term alternatives.

1 Like

Thanks, adding the package and myself to the group did the trick.

I ran settings manager from a terminal and no messages. When I select install in MSM Kernel, it just says 100% and done - without doing anything…

For now i only test it (continue testing) on VBox. No issues so far and all went smooth, from install to updates … Sound is working fine. For some reason i find it more responsive than the stable release … way more responsive …
One thing i noticed, and maybe you know that already, the Restart invokes the password window just for a moment then the restart takes place normally. Love it so far!

Forum kindly sponsored by Bytemark