Manjaro OpenRC 17.0.1 Xfce ISO

New release of the Manjaro OpenRC Xfce ISO.

This one has major changes since the last release (Xfce OpenRC 17.0 RC), to bring it in line with upstream changes (detailed below).

Packages include:

  • Linux 4.9.22
  • OpenRC 0.24.2
  • Eudev 3.2.1
  • Elogind 226.5

Main changes:

  • Consolekit replaced with Elogind (see this topic for more info), and several nosystemd packages added.

  • Built using manjaro-tools 0.15 and iso-profiles, this brings changes like using grub as the install media bootloader instead of syslinux.

  • Old CLI Installer brought back in the RC release has been removed (does not work with manjaro-tools 0.15). Moving forward, manjaro architect is an alternative that can be used.

  • Firefox has been replaced with Palemoon due to requiring Pulseaudio as a dependency for playing audio (bug report).


Known issues:

  • X fails to load after installation in Virtualbox (at least for me, unable to load module vboxvideo). [PEBKAC]

  • Oblogout Poweroff, Reboot, Suspend and Hibernate options no longer work (unable to find requisite commands for logind dbus interface) [solved].

  • MTP with Android phones does not work (see here for solution).

What would you prefer:

  • Firefox with Pulseaudio
  • Palemoon

0 voters


Thanks @aaditya. Will your old CLI installer still work on the older isos (since I assume they have the older version of manjaro-tools)?

And I use oblogout in XFCE OpenRC with the new elogind (and nosystemd) packages. These commands in oblogout.conf work for me:

logout      = xfce4-session-logout -lf
shutdown    = xfce4-session-logout -hf
restart     = xfce4-session-logout -rf
suspend     = xfce4-session-logout -sf
hibernate   = xfce4-session-logout --hibernate

Yup, should work :slight_smile:[quote=“cimarronline, post:2, topic:21804”]
And I use oblogout in XFCE OpenRC with the new elogind (and nosystemd) packages. These commands in oblogout.conf work for me:

shutdown = xfce4-session-logout -hf
restart = xfce4-session-logout -rf
suspend = xfce4-session-logout -sf
hibernate = xfce4-session-logout --hibernate

These may work with Xfce, but dont seem to work under Openbox.

Yes, those commands would just be for XFCE. They use the XFCE session manager logout functions (and the f makes sure it doesn’t save the session, which would bring oblogout up again at the next session):

  xfce4-session-logout [OPTION...] 

Help Options:
  -?, --help               Show help options
  --help-all               Show all help options
  --help-gtk               Show GTK+ Options

Application Options:
  -l, --logout             Log out without displaying the logout dialog
  -h, --halt               Halt without displaying the logout dialog
  -r, --reboot             Reboot without displaying the logout dialog
  -s, --suspend            Suspend without displaying the logout dialog
  --hibernate              Hibernate without displaying the logout dialog
  -f, --fast               Log out quickly; don't save the session
  -V, --version            Print version information and exit
  --display=DISPLAY        X display to use
1 Like

I am using FF 52.0.2 and ALSA works, although it seems official support has ended (for now).
A linked discussion I discovered in the bug report opened my eyes to the full situation: Rationalising Linux audio backend support

I support bundling with Palemoon. Thank you for your excellent work :smile_cat:

1 Like

I have been using Palemoon for a couple of years, and did replace Firefox with Palemoon in my recent Manjaro XFCE i686 openrc (RC iso) netbook install, simply because Firefox no longer supports java which is needed to configure some devices still on the field.

My install was performed using the cli installer because the gui installer incorrectly stated that it needed nearly 8gb of storage (it only needs about 3gb). While i was at it i used btrfs lzo compression, and it worked wonders with that old 4gb ssd xD.

Now if somebody could patch Pamac so the window could be shrunk to fit 800px wide (a bit less would be better); then i would be golden (and the few package that still need openrc scripts such as Miredo xD).

Yes, the Asus 701 Eeepc still lives :slight_smile:

PS: Due to several people having problems, i have put upgrades on hold. We need a guide to upgrade Manjaro from the openrc 17.0 [RC] to openrc 17.0.1 [beta] asap.

I guess I’ll just test it in a VM to see what the problems are:

Warning: removing 'dbus-x11' from target list because it conflicts with 'dbus-elogind'
Error: unresolvable package conflicts detected

Failed to prepare transaction:
conflicting dependencies:
elogind-openrc and consolekit-openrc are in conflict

Ok so what i did here was to go pamac-manager and install dbus-elogind, it prompts to remove dbus-x11, easy peasy. The fun comes afterwards.

Basically ended uninstalling consolekit packages (and networkmanager) to let the upgrade perform, at the end reinstalled networkmanager-openrc. I think light-locker gets removed in the process, not a big deal to me xD

Oh yes during this process you lose the ability for pamac to elevate privileges, so you need to sudo from a terminal or it complains of not having permissions to do things.

After a reboot it works, but without shutdown/reboot etc, things consolekit used to let users do. That long thread about migrating from consolekit to elogind has the answer buried somewhere:

sudo rc-update add elogind default

And that fixes the users can’t reboot / shutdown thing :slight_smile:

1 Like

Nice, I was about to refer you to this thread for update issues with previous ISO (it would be better in my opinion to further discuss there):

There seems to be something _really off_ with Calamares (the graphical installer), manjaro-tools, or my [iso profiles repo](; in the installed system **2 different versions of the same package** are present: for example if I do `sudo pacman -Syu` I get errors like: error: duplicated database entry 'networkmanager-openrc' error: duplicated database entry 'linux49' Some of these packages (like `networkmanager-openrc`) were not even present in the profile itself :thinking: If I reinstall some package, like `linux49-virtualbox-guest-modules`, it starts to work again, same for a lot of other packages. Theme of the installed system is different as well, will need to investigate whats up.

See post below.

Disregard my post above, what had happened was that Calamares the installer did not ask me to format the partition on which I was installing (the default was to not format), and I ended up overwriting and merging my previous install and causing these package conflict issues; when I formatted the partition before installing it worked as expected.

See here for what elogind uses for reboot etc…

Try loginctl -h for details

1 Like

Vote for Pale Moon. At any time Firefox will also depend on the systemd virus.-

1 Like

I voted with you, though it doesn’t matter a lot to me. I run a lot of browsers for different purposes.

These work well for me in Manjaro OpenRC:

FirefoxESR, PaleMoon, Seamonkey, LightFirefox, Abrowser, Cyberfox, Icecat, and Tor. (It will be interesting to see how many of these break if your dire prediction comes true).

Chromium, Qupzilla, Vivaldi. Otter … is okay. Iridium, when I finally got it working, caused some pretty terrible freezes.

Final ISO released containing bugfixes described in the OP.


Thank you.

Downloading from here.

1 Like

@aaditya Dear friend, thank you very much for your wonderful OpenRC edition but please could you tell us in brief - how to install it? Usually there is a graphical installation interface available after LiveUSB boot, but with your edition after booting - instead of desktop environment with some GUI installer shortcut on it - there is a pure command line. Of course I am fine with command line installation. But sadly I have no idea how to launch a command line installation utility? Could you help?

running “setup” command, even under root@manjaro user, gives “setup: command not found”. Where is any installer, and how to launch it?

There is a live graphical environment. You’re probably having problems with an incorrect video driver and so you don’t get to the desktop but it fails to the command line.

An alternative is using the Manjaro-Architect installer, which offers an OpenRC option:


Sad truth is that soon everything will depend on systemd virus. Just watch it.

a back-door found to exist for 2 (!) years in systemd

Question: Do we have any fresh open-rc iso with non-free drivers implemented? I tried lxqt-open-rc iso to no avail either.


Forum kindly sponsored by Bytemark