Manjaro OpenRC 17.0.1 Xfce ISO


There seems to be something _really off_ with Calamares (the graphical installer), manjaro-tools, or my [iso profiles repo](; in the installed system **2 different versions of the same package** are present: for example if I do `sudo pacman -Syu` I get errors like: error: duplicated database entry 'networkmanager-openrc' error: duplicated database entry 'linux49' Some of these packages (like `networkmanager-openrc`) were not even present in the profile itself :thinking: If I reinstall some package, like `linux49-virtualbox-guest-modules`, it starts to work again, same for a lot of other packages. Theme of the installed system is different as well, will need to investigate whats up.

See post below.


Disregard my post above, what had happened was that Calamares the installer did not ask me to format the partition on which I was installing (the default was to not format), and I ended up overwriting and merging my previous install and causing these package conflict issues; when I formatted the partition before installing it worked as expected.


See here for what elogind uses for reboot etc…

Try loginctl -h for details

Switch from consolekit to elogind

Vote for Pale Moon. At any time Firefox will also depend on the systemd virus.-


I voted with you, though it doesn’t matter a lot to me. I run a lot of browsers for different purposes.

These work well for me in Manjaro OpenRC:

FirefoxESR, PaleMoon, Seamonkey, LightFirefox, Abrowser, Cyberfox, Icecat, and Tor. (It will be interesting to see how many of these break if your dire prediction comes true).

Chromium, Qupzilla, Vivaldi. Otter … is okay. Iridium, when I finally got it working, caused some pretty terrible freezes.


Final ISO released containing bugfixes described in the OP.


Thank you.

Downloading from here.


@aaditya Dear friend, thank you very much for your wonderful OpenRC edition but please could you tell us in brief - how to install it? Usually there is a graphical installation interface available after LiveUSB boot, but with your edition after booting - instead of desktop environment with some GUI installer shortcut on it - there is a pure command line. Of course I am fine with command line installation. But sadly I have no idea how to launch a command line installation utility? Could you help?


running “setup” command, even under root@manjaro user, gives “setup: command not found”. Where is any installer, and how to launch it?


There is a live graphical environment. You’re probably having problems with an incorrect video driver and so you don’t get to the desktop but it fails to the command line.

An alternative is using the Manjaro-Architect installer, which offers an OpenRC option:


Sad truth is that soon everything will depend on systemd virus. Just watch it.


a back-door found to exist for 2 (!) years in systemd

Question: Do we have any fresh open-rc iso with non-free drivers implemented? I tried lxqt-open-rc iso to no avail either.


Hi @dr-kart

Would manjaro architect suit your needs? It allows installing non-free drivers on the target system afaik.


Hi aaditya,
point is to have live session along with non-free (Nvidia video in my case) drivers pre-loaded. As long as we generally have such an option with systemd spins.


Ah, ok, got it.


Welcome to Lindows :-/


i tried to install with manjaro architect installer and openrc does not appear to be working with non-free amd drivers… in fact that whole section of the installer appears borked to me. I tried installing openrc iso, 17 & 17.01 but neither works. This sucks.


non-free drivers section of the manjaro architect installer appears to not be workin g


Looks like there’s been a problem with M-A recently:


Yeap, I agree, the procedure described at the page is misleading and old news
From the first command of pacman -S openrc-core … it is finding conflicts and refuses to install. Just downloading openrc alone gives you a nice cell with no networking to download anything else to make it work.

I think the maintaining community needs to write new instructions based on
the current system and a functional procedure.