Manjaro OpenRC 16.06 (Xfce, Net)

Hi all,

Another update of the OpenRC ISOs, featuring the following packages:

  • Linux kernel 4.4.12
  • OpenRC 0.21
  • Eudev 3.2.0
  • Consolekit 1.1.0

Changes include

  1. Gtk-3.20 compatible Vertex-Maia theme by default to fix the theme issue with the 16.03 release.

  2. Updated kernel and Virtualbox packages to fix issue with X not starting under VirtualBox.

Download

Unresolved issues

Note

  • If NetworkManager does not connect to the wireless connection on autostart, try editing the connection and checking the ‘All users may connect to this network’ property.

http://imgur.com/nw4hudYl.png

  • Laptop users: If tapping on the touchpad does not count as a click anymore, have a look here.
8 Likes

Hello aaditya.

Version: Xfce 16.06 x64

I have found a fail on having the hour of the system: it always shows the UTC and not local.

The configuration is correct but it seems pass of the configuration. I configure correctly the hour, reboot and it is again in UTC. I have used the program “timeset-gui” and manually and nothing.

And the clock in the panel also show in UTC.

From terminal:

cat /etc/conf.d/hwclock
Set CLOCK to “UTC” if your Hardware Clock is set to UTC (also known as
Greenwich Mean Time). If that clock is set to the local time, then
set CLOCK to “local”. Note that if you dual boot with Windows, then
you should set it to “local”.
clock=local

date
jue jun 9 21:29:44 CEST 2016

ls -l /etc/localtime
lrwxrwxrwx 1 root root 39 jun 9 21:14 /etc/localtime -> /usr/share/zoneinfo/posix/Europe/Madrid

ntpdate hora.roa.es
9 Jun 19:31:02 ntpdate[2533]: step time server 150.214.94.5 offset -7197.913707 sec

date
jue jun 9 19:31:12 CEST 2016

hwclock --debug
hwclock de util-linux 2.28
The interface is used / dev to the clock.
last adjustment of realized phase lag 1465499705 seconds after 1969
last realized calibration 1465499705 seconds after 1969
The hardware clock has the local time
It is presupposed that the hardware clock has the local time.
Waiting for sign of clock…
… received sign of clock
Well-read hour of the clock of hardware: 2016/06/09 19:31:24
Hour of the clock of hardware: 2016/06/09 19:31:24 = 1465493484 seconds from 1969
The time passed from the last adjustment is-6221 seconds
The phase lag of the clock of studied hardware is 0,000000 seconds
2016-06-09 19:31:23.569958+1:00

Reboot

date
jue jun 9 21:33:57 CEST 2016

hwclock --debug
hwclock de util-linux 2.28
The interface is used / dev to the clock.
last adjustment of realized phase lag 1465499705 seconds after 1969
last realized calibration 1465499705 seconds after 1969
The hardware clock has the local time
It is presupposed that the hardware clock has the local time.
Waiting for sign of clock…
… received sign of clock
Well-read hour of the clock of hardware: 2016/06/09 19:34:45
Hour of the clock of hardware: 2016/06/09 19:34:45 = 1465493685 seconds from 1969
The time passed from the last adjustment is-6020 seconds
The phase lag of the clock of studied hardware is 0,000000 seconds
2016-06-09 19:34:44.736053+1:00

Greetins

very nice of you that you uploaded a NET version, thanks!

2 Likes

Hi @v17564,

It seems that the settings at the system level are correct, but the hardware clock time is set to the old (UTC) time.

To update hardware clock time, after getting the correct time in the system, you could write it to the hardware clock (Option 8 in timeset-gui: Synchronize hardware clock to system time).

1 Like

Hi @aaditya

I try in a VM of Virtualbox. Today i try in a physical machine.

I always use this option but don’t work.

I have try it just again with timeset-gui:

  • update the hour with the network (ntp) and the clock change to local time
  • applied the option 8 and even try option 9
  • reboot
  • not work

In the version 16.03 when boot, OpenRC show the next messages:

  • Populating /dev with …
  • Setting system clock with hardware clock [Local Time]
  • Autoloaded 0 module(s)

And when shutdown, it show the next messages:

  • Stopping udev …
  • Setting hardware clock with system clock [Local Time]
  • Terminating remaining processes …

The 16.06 don’t show the messages about the clock.

Try to remove hwclock from boot runlevel.

rc-update del hwclock boot

Thank you, good people.

Writing this from inside the live 16.06 Xfce.

Used SUSE Studio Imagewriter 1.10 to write the ISO to USB. Smooth as silk.

Wireless connected with minimum fuss.

Will install onto SSD soonish and report back if there’s anything significant to say.

1 Like

Hi @artoo, @aaditya

Sorry for delay, after the previous post i go to dinner and bed. Now I am in my job but have a free time to respond.

I made a new clean install.

There isn’t daemon hwclock:

rc-update

   NetworkManager |      default                           
            acpid |      default                           
        alsasound |      default                           
           binfmt | boot                                   
        bluetooth |      default                           
         bootmisc | boot                                   
        cgmanager |      default                           
       consolekit |      default                           
           cronie |      default                           
            cupsd |      default                           
             dbus |      default                           
            devfs |                                 sysinit
            dmesg |                                 sysinit
             fsck | boot                                   
         hostname | boot                                   
          keymaps | boot                                   
        killprocs |                        shutdown        
kmod-static-nodes |                                 sysinit
            local |      default nonetwork                 
       localmount | boot                                   
         loopback | boot                                   
          modules | boot                                   
         mount-ro |                        shutdown        
             mtab | boot                                   
           net.lo | boot                                   
         netmount |      default                           
           procfs | boot                                   
             root | boot                                   
        savecache |                        shutdown        
             swap | boot                                   
        swapfiles | boot                                   
           sysctl | boot                                   
            sysfs |                                 sysinit
        syslog-ng |      default                           
     termencoding | boot                                   
     tmpfiles.dev |                                 sysinit
   tmpfiles.setup | boot                                   
             udev |                                 sysinit
     udev-trigger |                                 sysinit
          urandom | boot                                   
              xdm |      default

Adjust time with “timeset-gui” and reboot.

When shutdown show this message, from /var/log/errors.log:
Jun 10 13:51:46 manjaro openrc[2972]: Clock skew detected with `/etc/conf.d’

I run:

rc-service -r hwclock
/etc/init.d/hwclock

rc-update add hwclock boot

Reboot and now work, i have local time.

          hwclock | boot

@aaditya, I noticed your OpenRC 16.06 XFCE iso is half as big as the systemd version. Why’s the systemd version so much bigger?

This is because I use a slimmed down profile; the official Xfce ISO has non-free drivers, multilib, steam, etc.

Good choice, in my opinion. Thanks.

Hi @aaditya

The ISO don’t start daemon for hwclock, see my previous post, i need to run “rc-update add hwclock boot” after install for configure local time.

Update: Install successful and I am well on the way to having everything perfect again. I haven’t noticed any bugs, and in fact it’s much cleaner than the old install, which was suffering sadly from the GTK hell.

(Granted, i haven’t tried moving off of Vertex-Maia yet–too scared. However, changing icons to Faenza-Green didn’t break anything and looks great.)

I really want to give it a try again (I am currenlty using Antergos+Mate).

with a new eudev, I hope inserting an iphone will be recognized without have to type any command this time (antergos: you need to issue an ifuse command)

Thanks guys.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.