Manjaro on teclast f5 - sound not working and touchpad after resume

I am here to show what works and what don’t work on this laptop Teclast F5 - TECLAST

Installation went without problem.

I needed to upgrade the kernel to have wifi working fine, now I am using kernel 5.13.11-1 and I have only this warning in dmesg

rtw_8821ce 0000:01:00.0: timed out to flush queue 1

Bluetooth works fine but using it to connect to my cell phone via tethering/bluetooth was not affordable.

Sound is not working as I cannot see the sound board. In dmesg I see these lines

[    4.012906] snd_hda_intel 0000:00:0e.0: DSP detected with PCI class/subclass/prog-if info 0x040100
[    4.418863] snd_hda_intel 0000:00:0e.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

The command

inxi -A

gives this result

  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio 
  driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Sound Server-3: PipeWire v: 0.3.33 running: yes 

lspci -v

00:0e.0 Multimedia audio controller [0401]: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio [8086:3198] (rev 03)
    DeviceName: Onboard - Sound
    Subsystem: Intel Corporation Device [8086:7270]
    Flags: bus master, fast devsel, latency 0, IRQ 128
    Memory at a1210000 (64-bit, non-prefetchable) [size=16K]
    Memory at a1000000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: [50] Power Management version 3
    Capabilities: [80] Vendor Specific Information: Len=14 <?>
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_apl

But alsamixer shows only hdmi output and this does not work: I found something in 213065 – Gemini Lake snd-hda-intel no HDMI audio but I cannot check more.

Touchpad works fine but sometimes after the suspend it did not work.

I found some help in in this page about ubuntu on this laptop GitHub - ijonglin/teclast-f5-ubuntu-finalizer: Current HW/SW Kernel/System/ACPI Modifications To Get a $400 Dream Ubuntu Linux Laptop but trying to remove (along with i2c_hid_acpi) and reinsert i2c_hid module did not work

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.


Oops, you are right.
My intention was to save this post as draft but I save it without actually asking nothing.

I’m sorry for being dumb, but I don’t understand:

  • lnoferin’s issue is solved
  • lnoferin’s issue is not solved

0 voters

Which of the 2 is it???