Manjaro on an Acer Spin 1 SP111-32N (Convertible 2 in 1 Laptop)

Hi, I am currently trying to use Manjaro GNOME Edition (17.1.5) on an Acer Spin 1 SP111-32N.
The Acer Spin 1 is a convertible 2-1 laptop running Windows 10. It is powered by an Intel Pentium N4200 Apollo-Lake.

I would like to keep Windows 10 on the internal eMMC and therefore installed Manjaro on an 128GB USB Stick (2 partitions, 1 encrypted with LUKS). The install works without any issue and Manjaro boots. Most of the hardware, WiFi, Bluetooth, … is also working.

Unfortunately I have some issues I can’t resolve:

  1. Autorotate does not work. I tried iio-sensor-proxy from the AUR repo. After installing and rebooting the display is flipped 90° in the wrong direction. Flipping back does not work - the sensors do not react. I tried the newest Fedora Rawhide. With Fedora the flipping is functional, but also inverted (landscape and portrait mode).

  2. Tablet Mode: If the Laptop is folded into a tablet the keyboard and touchpad is correctly disabled. After folding back to laptop mode the keyboard and touchpad stay disabled. The touchscreen is the whole time only working as an normal pointing device (no multitouch)

I tried the suggested steps mentioned in the Arch Wiki without success: https://wiki.archlinux.org/index.php/Tablet_PC#Tablet_mode

The script fails with the message: no sensors detected

  1. The normal touchpad has also an issue. If I move slowly from the outer border of the touchpad to the center, the cursor does not move. This happens from every border side. Moving reverse from the center to the border works correctly. I am using the default libinput. If I install xf86-input-synaptics the touchpad has no issues - but Arch Wiki does suggest not to use the old package.

  2. Suspend is not working. Choosing suspend from the menu or closing the lid do not bring the laptop into suspend mode. Maybe this is related to the USB install.

Overall I am pretty satisfied with Manjaro. I came from Fedora, but have to admit the start with Manjaro is more comfortable.

I would be glad if someone could give me an advice to resolve these issues.

Regards
Tom

1 Like

Fedora rawhide is working because their very own Hans de Goede is exactly working on that in these days.
If you want to stick with arch, you’ll have to wait for him to have got everything upstream.

As for multitouch… I don’t know, maybe they are using the new standard around?

Last but not last, _LID problems are usually related to acpi.
Shims might be needed… But I’m not really sure how else I could guide you from here.

Thanks for the reply.
Fedora Rawhide does only recognize the rotation sensor, but the rotation is not working correctly. Landscape and Portrait mode are inverted. This is the only difference to Manjaro - the other problems also exist using Fedora.

Overall a working rotation is not the most important thing, because I am using it mostly in landscape mode. I can wait if there is a fix coming in the near future. Therefore I would like to stay with Arch / Manjaro.

A more important issue is the convertible mode. If the notebook is folded into a tablet the keyboard and touchpad get disabled, but not reenabled if folded back to a laptop. The deactivation works, so it has to be recognized somehow by the system. Would it be possible to write a script which activates the keyboard/touchpad if the “fold” signal is received?

Regarding the touchpad issue: The mouse does not move if the finger is in the right/left border of the touchpad (libinput). But moving the finger from the center of the touchpad to the borders does work correctly. The whole touchpad is then usable. Maybe this is related to some functions like edge scrolling? Can the borders/border functions be disabled using libinput?

Is there a log file to see if suspend mode is working? Is it a normal behavior that after returning from suspend mode the screen is not locked? If the screen is turned off through energy settings, the screen gets locked.

You might want to check 4.16.
Some of the improvements I mentioned should have landed there.

I’d also recommend you to get directly in touch with hans (he seems pretty sociable)… though I’m not sure on whether he might not be kinda busy or something these days.

As for libinput, I know latest 1.10 is quite an improvement.
Also check its git.

I tried kernel 4.16 experimental, but there is no difference to the stable 4.15.

But I could resolve the autorotation between landscape / portrait mode.
I installed again from AUR iio-sensor-proxy (https://github.com/hadess/iio-sensor-proxy) and created a custom configuration file for the correct rotation order (Tutorial: https://www.aixin.fr/jipeblog/?p=119):

/etc/udev/hwdb.d/61-sensor-local.hwdb

sensor:modalias:acpi:BOSC0200*:dmi::svnAcer:pnSpinSP111-32N:*
ACCEL_MOUNT_MATRIX=0, 1, 0; 1, 0, 0; 0, 0, 1

The sensor is recognized and the rotation works now correctly.
A small issue remains:
I scaled the interface to factor 2: gsettings set org.gnome.desktop.interface scaling-factor 2
After that i used xrandr to scale the interface down factor 1,5x1,5
Since there is no fractional scaling, this is the best way for me to get a decent interface size.
iio-sensor-proxy is using xrandr to rotate the display. Whenever the screen is rotated, my xrandr scaling settings are overwritten. I would need to attach my scaling settings to the rotation settings from iio-sensor-proxy, but I don’t see a way how to do it.

Regarding fractional scaling, I read Gnome 3.26 does support it in experimental mode:
gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]”

This does not work for me - maybe it does only work under Wayland?

The other issue with the touchscreen / multitouch is resolved. It was only a problem with firefox.
I did find the solution in Arch Wiki: https://wiki.archlinux.org/index.php/Firefox/Tweaks#Enable_touchscreen_gestures

Some issues with the touchscreen remain. If I touch-click an item from the favorites list (dash-to-panel / dash-to-dock) 2 instances are opened.
As far as I understand this is a known issue: https://github.com/micheleg/dash-to-dock/issues/652

Also the on-screen keyboard caribou is opened whenever the touchscreen is touched. This happens regardless of an input field and makes the touchscreen almost unusable. A workaround is to install the Gnome extension Block Caribou: https://extensions.gnome.org/extension/1326/block-caribou/
But this blocks the touchscreen the whole time and makes it impossible to display the on-screen keyboard if needed.

The touchpad behaviour is the same with the newest libinput 1.10. I first thought it could be related to libinput hysteresis problem, which filters small movements. But this was fixed in libinput 1.10.
Small movements do work for me, but only in the center of the touchpad. The problem does only exist in border areas. So this has to be a different issue.

I also still haven’t found a way to reenable the touchscreen / keyboard after the laptop is folded back from tablet mode into laptop mode.

“xinput --list” does list my touchscreen, keyboard and touchpad.
“xinput set-prop “my_device” 'Device Enabled” 0" and “1” do correctly enable or disable the device.
But after folding the convertible from tablet to laptop, the above commands do not reenable the devices.
The only way to reactivate both is to reboot the system. Maybe the keyboard/touchpad are disabled in a different way if the convertible is folded into a tablet. What different ways do exist to disable a touchpad or keyboard instead of xinput?

I tried to catch the key/button which is responsible for the tablet/laptop switch.
acpi_listen returns “676AA15E-6A47-4D 000000bc 00000000” if the tablet is folded from laptop to tablet mode. Folding back from tablet to laptop mode does not return any signal. Also the signal is shown only the first time. Further folding the laptop to both modes does not return any more signals.

Trying to use “xev” doesn’t create any output while folding the convertible to tablet mode or vice versa.

That’s really not telling a thing.
So, again I’m not a particular expert, but at least on my laptop (and iirc) (plan b?)

After following the bread trail I found out tablet mode gets triggered by a SW_TABLET_MODE signal.

This in turn got exactly supported in 4.16
So, you may want to try latest linux rc/git

Thank you for the hints. The mentioned forum post sounds interesting.

From the Windows 10 device manager I could find out the sensor, which is responsible for the laptop / tablet mode switch:

GPIO-Laptop/Slate-Indicator
Hardware-ID: ACPI\ID9001

The ACPI device with ID9001 is also listed under Manjaro: /sys/bus/acpi/devices/ID9001:00

As far as I understand the idea from the forum post (HP Spectre X360 user), is to create a custom udev rule for the device and then trigger it through keyboard shortcuts.
At this point I don’t know, how to do it for my ACPI\ID9001 device. acpi_listen also never shows this particular device, if the convertible is folded into tablet mode / laptop mode.

I also tried the newest experimental kernel 4.16 (unstable repo) from today, unfortunately without success.

I just wanted to give a small update / summarize. I recently changed from Manjaro GNOME Edition to Manjaro KDE Edition. HighDPI scaling (fractional scaling) in X11 under KDE is working almost perfect. In GNOME I had to scale the interface with factor 2 and then scale it down factor 1,5x1,5 using xrandr --scale, which gave me some problems using auto screen rotation. I also tried the experimental scaling under GNOME wayland, but using this gives me unfortunately blurry fonts. Auto screen rotation does also work pretty well under KDE using kded_rotation as mentioned in the ArchWiki (https://wiki.archlinux.org/index.php/Tablet_PC#With_a_KDE_module).

To get the rotation order correct, the same configuration file as for GNOME has to be created:

/etc/udev/hwdb.d/61-sensor-local.hwdb

# Acer Spin 1 SP111-32N
sensor:modalias:acpi:BOSC0200*:dmi:*:svnAcer*:pnSpinSP111-32N:*
 ACCEL_MOUNT_MATRIX=0, 1, 0; 1, 0, 0; 0, 0, 1

From the issues mentioned in my first post, only one remains:
The tablet mode is not working. Once the convertible is folded into a tablet and back, there is no way to get the keyboard / touchpad working again, than doing a reboot. To be more precise, it needs two reboots. After the first reboot the keyboard / touchpad is still not working and the convertible has to be turned off and on again.

I also attempted the newly released final kernel 4.16. I did even try some daily builds / alpha / beta releases from different distributions (Ubuntu, Fedora), but they all show the same behaviour. I searched a lot of github projects regarding “tablet mode” and “tablet mode switch” etc., but I couldn’t find any specific for my Acer Spin 1.

There is a device which is very similar to the Acer Spin 1 SP111-32N. It is the Acer TravelMate Spin B1 Convertible - this device is as far as I know even shipped with a linux distribution Endless OS. Because the specs of both devices are almost the same, I hoped I could try it on my convertible, but I cannot get Endless OS to boot. Looking in the their support forum, the newer Intel platforms will be supported by Endless OS in the next beta / release.

Overall Manjaro does work pretty well with the Acer Spin 1, almost everything is working out of the box and I hope I can solve the last remaining part with the “tablet mode”.

Can you try linux-git?
Some hours ago they merged some other improvement.

AUR lists linux-git only in version linux-git 4.16rc6.
I never build directly from source. This would be the correct git? https://github.com/manjaro/packages-core

In the announcement section I found this post to the latest testing updates: [Testing Update] 2018-04-11 - ZFS, Firefox, Gnome v3.28.1, Haskell, Python

I tried the Manjaro XFCE Alpha with the new linux kernel 4.17. There the issue with switching back from tablet mode still exists.

You mentioned some improvements in the last hours, which I suppose are not included in the Alpha Release, although it is using the most current linux417 4.17-rc0. Could you specify which improvements could lead to a solution for the “tablet mode” issue? I cannot figure out, what exactly to look for.

Regards


Version is just a number. Aur package is just fine, and you don’t have to do a thing to configure it.

Changes were these, indeed not present in manjaro old release.

I tried linux-git from AUR, which after installation showed up as 4.17rc1. The changes did really sound promising, but the problem with going back from tablet mode still exists.

Is this definitely an issue which has to be solved directly in the kernel or is there maybe an approach in userspace?

Idk, and exactly for this, at this point I’d just recommend you to install Fedora, then report back to their bug tracker (since developers of *both* are there)

Kernel, if there is no prohibitive license, otherwise DKMS extra module or similar.

I haven’t heard of packages just for one switch, that wouldn’t make sense.

@tom86
I’m in the exact same boat as you are. Installed Manjaro which I really love due to it being arch basically. Saw mirh’s suggestion about going to fedora, which I GUESS I can do if things seem really grim.

But is it fully confirmed that everything on the SP111-32N works OOTB in Fedora?
Cause that DOES sound tempting.

In any case, I’ll post here if I find a workaround or fix for the tablet mode. I kinda like it.
Thanks for your info!

I tried the most recent Fedora Rawhide and could not notice any difference regarding supported hardware to Manjaro.
The only difference, auto-rotation is directly supported. In Manjaro you have to install iio-sensor-proxy from AUR.
But also in Fedora the direction of the rotation is not correct, so you have to create the file /etc/udev/hwdb.d/61-sensor-local.hwdb same as in Manjaro.
Therefore I would like to stick to Manjaro, because it really does not make any difference regarding supported hardware and I dont want to miss AUR anymore.

Maybe there is a solution with the help of the Acer TravelMate Spin B1 Convertible. This device seems to have identical hardware to the Acer Spin 1 and has a preinstalled Linux Endless OS. Because this device is also a convertible, tablet mode switching has to work, otherwise I think it would not be shipped with a preinstalled Linux.

But as mentioned before, I am unable to boot the current image from Endless OS. Maybe the preinstalled version has some changes, because the hardware basis should be the same on both convertibles.

I think it’s how the hardware works when there isn’t a software to change its behaviour. I have the same laptop model, and this happens in BIOS settings - if a laptop is folded into a tablet, BIOS settings won’t see any keyboard events anymore even if the laptop is folder back into laptop mode.

I folded my Acer Spin 1 into a tablet in the BIOS settings, but the keyboard / touchpad stayed enabled. This would show a different behaviour than your device. I am using the newest BIOS firmware version 1.06.

BTW: Fedora 28 was released yesterday, but the tablet mode problem still exists.

1.06 here as well, and checking back, it seems like keyboard works as it should in BIOS settings (although I’m pretty sure it used to not work like this in some older version).

Forum kindly sponsored by