manjaro-nx-19.0-unstable-minimal-191220-linux54.iso -- ERROR; Failed to mount '/dev/loop'

I'm testing manjaro-nx-19.0-unstable-minimal-191220-linux54.iso on a live USB on my small laptop

~ >>> inxi -Fxxxz                                                              
System:
  Host: mjaro Kernel: 5.4.15-1-ck-silvermont x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: LXDE 0.10.0 info: lxpanel wm: Openbox 3.6.1 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80WG v: Lenovo ideapad 110S-11IBR 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 110S-11IBR 
  serial: <filter> 
  Mobo: LENOVO model: Kant v: SDK0J91216 WIN serial: <filter> UEFI: LENOVO 
  v: 4HCN07WW date: 08/11/2016 
Battery:
  ID-1: BAT1 charge: 30.5 Wh condition: 30.5/32.7 Wh (93%) volts: 8.6/7.6 
  model: Intel SR 1 Harris Beach type: Li-ion serial: <filter> status: Full 
  cycles: 75 
CPU:
  Topology: Dual Core model: Intel Celeron N3060 bits: 64 type: MCP 
  arch: Airmont rev: 4 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6400 
  Speed: 1835 MHz min/max: 480/2480 MHz Core speeds (MHz): 1: 1638 2: 2415 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) 
  v: 4.6 Mesa 19.3.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k5.4.15-1-ck-silvermont 
Network:
  Device-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: 1000 bus ID: 03:00.0 
  chip ID: 10ec:8821 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 58.94 GiB used: 16.38 GiB (27.8%) 
  ID-1: /dev/mmcblk0 model: DF4032 size: 29.12 GiB serial: <filter> rev: 0x8 
  scheme: GPT 
  ID-2: /dev/sda vendor: LITE-ON IT model: LSS-32L6G-HP size: 29.82 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 702 scheme: GPT 
Partition:
  ID-1: / size: 26.64 GiB used: 16.30 GiB (61.2%) fs: btrfs 
  dev: /dev/mmcblk0p2 
  ID-2: /boot size: 239.9 MiB used: 58.6 MiB (24.4%) fs: ext4 
  dev: /dev/mmcblk0p1 
  ID-3: /home size: 26.64 GiB used: 16.30 GiB (61.2%) fs: btrfs 
  dev: /dev/mmcblk0p2 
  ID-4: swap-1 size: 2.23 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/mmcblk0p3 
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 155 Uptime: 5m Memory: 1.79 GiB used: 544.4 MiB (29.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.0 alt: 8 Shell: zsh v: 5.7.1 
  running in: lxterminal inxi: 3.0.37 

It boots to root terminal

mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.
ERROR; Failed to mount '/dev/loop'
     Falling back to interactive prompt
     You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs ] #

The ISO file is OK:

/media/DataHDD/ISO >>> gpg --verify *.sig                                                                                                                                                    
gpg: assuming signed data in 'manjaro-nx-19.0-unstable-minimal-191220-linux54.iso'
gpg: Signature made Sat 21 Dec 2019 03:01:31 PM CET
gpg:                using RSA key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E
gpg:                issuer "philm@manjaro.org"
gpg: Good signature from "Philip Müller (Called Little) <philm@manjaro.org>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: E4CD FE50 A2DA 85D5 8C8A  8C70 CAA6 A596 11C7 F07E

It boots to the same root terminal on my desktop machine.

I nurned the ISO another time on the same stick - same issue. Could be a defective stick, it's new. Will try dd and then anoter ISO.

It was probably indeed a defective USB stick. Another stick works.

The OS makes a somewhat unexpected impression.

...as in ?

Tr Y it but not before bedtime

@philm, my suggestion which you can forward:

  • make the mx-welcome-wizard not fullscreen (like the monopolist OS does) but a proper window with a Close and Minimize button.
  • also, the same old Manjaro KDE "bug" that touchpad tap to click is disabled,
  • desktop shortcuts are covered by the panel.

Forum kindly sponsored by