Manjaro not starting. Can't find any solution and pinpoint exact reason!

out of interest what is your first language? the forum can be posted to in English, German, French, Brazilian, Polish, Russian, Spanish and Turkish. your last post made little sense but i’m guessing you mean consistency rather than incontinence which means manjaro cannot control it’s bladder and leaks urine everywhere :wink:

1 Like

I wanted to say inconvenient, but I guess I didn’t recheck my autocorrection :joy:
Thank you for pointing that out :wink:

Well it’s Polish and I know I could post on Polish thread and to why I didn’t the short answer would be the power of habit.

I use English as my main language on all of my devices.
I also just find it much faster and easier to lookup anything on the internet in English and I’d say Polish sites were hardly ever useful to me.
It’s also that English speaking communities are just so much bigger.

This setting is in WinOS. You have to disable it.
Since you say you have correct boot order, Manjaro first, then post it, please.

efibootmgr -v
efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0002,9999
Boot0000* Windows Boot Manager  HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...t................
Boot0001* manjaro       HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0002* Solid State Disk      PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-B3-71-B3-65-85)/HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)..BO
Boot9999* USB Drive (UEFI)      PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)..BO

Find how to disable fastboot and if it still fails, re-install grub with --recheck

I’ve just disabled fastboot and haven’t seen any ACPI errors this time, so I guess that was causing them.
Should I repeat this command?

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

If you boot to Manjaro without workaround, no.
You are solved. :+1:

1 Like

Just to clarify I had to use gohlip’s work around, so I assume that I should after all.

I don’t know what happened this time but another problem popped up.
When I start my computer GRUB shows’s up as always but now it’s “frozen”.
It just shows OS selection window but I can’t do anything and the timer is also stuck. However when I start GRUB from Boot Manager everything works just fine…

Not saying I have a good idea, … (but maybe a rough guess)

  1. Let’s take a look at your /etc/default/grub.
  2. At Grub from Boot Manager (where it is not frozen)
    go to grub prompt (press ‘c’ at menu)
    type in
    grub> videoinfo
    Show what shows. (I guess you have to take a screen camera shot on this)

[EDIT] - at (2), output of ‘set’ would also do.
grub> set

Here’s grub file:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

And videoinfo

and set

Try this. At /etc/default grub, change 2 lines
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

to
GRUB_GFXMODE=1024x768x32
GRUB_GFXPAYLOAD_LINUX=1024x768x32

That is, if your monitor resolution is equal or better than 1024x768x32

Then
sudo update-grub

Reboot.
Let us know if it still freeze.

Unfortunately it still does :pensive:

Ok. That’s not that then.
But you can keep the changes you’ve made (recommended)
If we think of something else, we’ll let us know.
Good luck.

Then you could take a look to some UEFI/BIOS setting that triggers this.
Other users have reported this kind of settings.

It seems that it might be the laptop model issue.
Guy in this post has the same laptop (maybe different exact model number) and the same problem although with Ubuntu.

[Edit] It’s unsolved so I don’t know yet if there’s anything useful. I have to read through it first.

From the link that petsam provided in post 3

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”


You’ve done this, right?

If you haven’t, do this.
Please recheck your partitions, verify them, especially with
findmnt /boot/efi

And recheck any typo. I’m losing track of the many posts here.

Note: that should make your /boot/bootx64.efi and your Manjaro\grubx64.efi the same.
And the ubuntu link that shows the same issue shouldn’t apply.
That’s why we need the [Additional steps for UEFI] in the link.

Yep

So that’s the findmnt

findmnt /boot/efi
TARGET    SOURCE         FSTYPE OPTIONS
/boot/efi /dev/nvme0n1p2 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,io

From what I understand just to be sure I cloud do something like “clean install” of grub by removing BOOT and Manjaro folders from EFI, deleting UEFI entry with efibootmgr -b and then doing:

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

Because I’ve done this before without cleaning EFI folder, but I guess the commands overwrite the files anyway.

Yes. But some people reported getting 2 ‘manjaro’ bootentries after that.
No big problem, either if so. You can then remove the older one, or leave it.

I did as I said but still nothing

BTW it seems that in some point in future I will have to change kernel anyway, because from what I’ve read it’s required to make my speakers and audio jack function properly. But for now that’s just a digression

Okay. May be best then.
Take care. Good night.

Forum kindly sponsored by Bytemark