Manjaro not booting after updating (basically a complete newbie)

So I’ve been using Manjaro for some time now after switching from windows, without much problems, and I’ve enjoyed it over the previous system

But today I wanted to update the general system so I went to the update manager. It wanted to delete some files like something nvidia related, whoch I suspect to be the cause of the problem.
Unfortunately I don’t know how to verify this.
I know basic terms like root and basic install commands but beyond that I am very inexperienced and can’t really even assess the problem.
So if anyone could help me get this thing to work again, all I can say is that I’d be extremely grateful.

Right now all I see when starting my desktpp is /dev/nvme0n1p2: clean, 482784/62496768 files, 82499891/249972404 blocks

I have a usb with live manjaro on it if that helps.

try entering into TTY with ctrl+alt+f2, if f2 doesnt work try with f1-f6 keys

Okay, thanks for the response.
So I entered the tty thing and entered my username and password. Which seems to have worked. Am I supposed to write something in there now?

first rerun update with: pamac update
if there are any errors post them here

It says I can’t embed media here but essentially it keeps repeating
Temporary failure in name resolution
Failed to synchornize database.

you can take a picture of the logs and upload it to imgur, and the link put into this icon in the editor:</>
do you use kde/gnome/xfce?

https: //imgur .com/a/38NVflv
Added spaces and stuff because it said I can’t use links
Made an imgur account just now and uploaded
This is what shows up
Honestly I never bothered to remember what I was using so I have no idea what I was using. I think it was gnome.

you running 5.14 kernel which is not longer supported … so try installing newer one with this:
sudo pacman -S linux515

https:// imgur. com/a/5SaCbvU
So I tried twice and both times errors occured, and no packages were upgraded. Does this mean I have to do a fresh reinstall?

try with this command:

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

https:// imgur .com/a/KFq1E6m

it can connect to them, maybe your pc is not connected to internet, try with this command:
sudo pacman-mirrors --geoip
if you get the same error messages again, no need to post a picture of them, but run this command:
inxi -Fazy
and under desktop check what youre running, kde/gnome/xfce etc… dont need to post picture, just say what it is

Okay I managed to connect to the internet with nmtui and update to 5.15.
Tried checking the enviorment with Fazy but can’t see desktop and can’t scroll up. Screenfetch doesn’t tell me either.

so first provide output from:
mhwd-kernel -li && mhwd -l && mhwd -li

Currently running: 5.15.38-1-MANJARO (linux515)
The following kernels are installed in your system:

  • linux510
  • linux514
  • linux515
    Below that is some nviida info but nothing about gnome, xfce, or kde.

i wanted the graphic drivers info, what are available and what you have installed
so first uninstall the 5,14 kernel with:
sudo pacman -R linux514
then provide output from:
mhwd -l && mhwd -li
inxi -xxS

14 has been uninstalled

inxi -xxS output is
Host: (My name I don’t think I should upload this here)
Kernel: 5.15.38-1-MANJARO
arch: x86_64
bits: 64
compiler: gcc
v: 11.2.0
Console: tty 6
Distro: Manjaro Linux
base: Arch Linux

Also finally I can upload pics here

good, whats the output from:
inxi -G

Device-1: NVIDIA GA104 [Geforce RTX 3070]
driver: N/A
Display server:
loaded: N/A
failed: nvidia
gpu: N/A
tty: 128x48
Message: GL dara unavailable in console. Try -G --display

all right so first uninstall it with:
sudo mhwd -r pci video-nvidia
then install it again:
sudo mhwd -i pci video-nvidia
then reboot:
systemctl reboot
and hopefully youll be able to boot normally

1 Like