Manjaro Not Booting After Antergos GNOME Install

I recently uninstalled my Ubuntu partition and instead replaced it with Antergos GNOME. I can boot Antergos but the Manjaro partition will not boot. I cannot tell what it says because the words are cut off. I tried sudo fsck /dev/sda3 but it didn’t work. I still have access to all my files from the partition but I can’t boot it. Also, another thing to note is that Antergos doesn’t have the sudo update-grub command, or at least it gave me an error saying command not recognized. I really need to be able to use my Manjaro partition again because that’s my main system. If anyone could help it would be great. Also, I know that this is not entirely about Manjaro but I hope this isn’t blocked or something like that. :wink:

You need to make Manjaro’s grub the controlling grub - search the forum, there is a lot of info.

Thanks. I did some research amd I found this really good tutorial on the YouTubes. It was really poorly made but it at least worked. :wink:

Best tutorial ever.

1 Like

This tutorial created by @gohlip and you can find it here:

1 Like

@kouros17 - cheers, that was the one, was on my way out for a meal.


I used it last week when an update to Xubuntu messed up Grub.
It worked fine.

1 Like


Funny this post showed up…Just last week I installed KXstudio and when I went to boot manjaro, it wouldn’t boot. So I found this post Restore Manjaro boot and followed it. Shows that it pays to do research and follow what instructions you find…I learned how to fix the issue without reinstalling. That would have sucked, seeing how I had months of customizations and applications installed. I learned how to fix my grub and save myself a whole lot of time reinstalling.


Me too. I had my Manjaro customized to the most smallest measurable degree of precision customization! I was afraid that I would never be able to use Manjaro again without doing the unspeakable: REINSTALLING MANJARO AND CUSTOMIZING AGAIN IT FROM THE GROUND UP! Luckily I found the worst tutorial ever made, which I posted above, and I was able to fix my machine! I ended up not having to reinstall and lose all my artwork or having to back up my files which I already had to do with Ubuntu when I installed Antergos GNOME. I would recommend you check out that tutorial, I bet you’d get a good laugh out of it! :wink:

Antergos has the same problem in grub generation that all Ubuntu family distros have - it doesn’t generate proper grub entry for Manjaro.
Fortunately there is a solution/workaround, see

Writing the same fixes into Antergos solve the grub generation problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark