Manjaro Newbie : Latest update break fonts: Fonts are tearing

Hello, I am a long time linux user, I have been using Netrunner for some time, in netrunner with the latest updates I had fonts, seamed like displayed low resolution images in high resolution screens, dotted. I could not solve the problem. I installed manjaro, and after update I see the same problem.

Any help much appreciated...

Welcome :slight_smile:

Please post inxi -Fxxxz

and read

1 Like

Hello, I usually post the log or snapshots relavant to the problem, however in this case I was not sure what to post. The snapshot of the desktop probably will not be very helpfull either..

System:    Host: dell2 Kernel: 4.19.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.3
tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: Vostro 5481 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: Dell model: 0PK27Y v: A00 serial: <filter> UEFI: Dell v: 2.2.0 date: 03/24/2019
Battery:   ID-1: BAT0 charge: 40.5 Wh condition: 40.5/42.0 Wh (96%) volts: 12.9/11.4 model: BYD DELL 1VX1H93 type: Li-poly
serial: <filter> status: Full
CPU:       Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake rev: B L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808
Speed: 500 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 4: 500 5: 500 6: 500 7: 500 8: 500
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11
resolution: 1920x1200~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.2 compat-v: 3.0
direct render: Yes
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:9dc8
Device-2: Realtek type: USB driver: snd-usb-audio bus ID: 1-4.3.4:9 chip ID: 0bda:402e serial: <filter>
Sound Server: ALSA v: k4.19.59-1-MANJARO
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3
chip ID: 8086:9df0
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 v: 8.047.02-NAPI
port: 3000 bus ID: 01:00.0 chip ID: 10ec:8168
IF: enp1s0 state: down mac: <filter>
Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 2-4.4:4 chip ID: 0bda:8153
serial: <filter>
IF: enp0s20f0u4u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 268.20 GiB used: 93.06 GiB (34.7%)
ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC501 NVMe 256GB size: 238.47 GiB speed: 15.8 Gb/s lanes: 2
serial: <filter> rev: 80002C00 scheme: GPT
ID-2: /dev/sda type: USB vendor: Generic model: SD MMC MS PRO size: 29.72 GiB serial: <filter> rev: 1.00
scheme: MBR
Partition: ID-1: / size: 221.72 GiB used: 93.01 GiB (41.9%) fs: btrfs dev: /dev/nvme0n1p3
ID-2: /boot size: 512.0 MiB used: 53.7 MiB (10.5%) fs: vfat dev: /dev/nvme0n1p1
ID-3: /home size: 221.72 GiB used: 93.01 GiB (41.9%) fs: btrfs dev: /dev/nvme0n1p3
ID-4: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p4
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2529
Info:      Processes: 284 Uptime: 29m Memory: 7.48 GiB used: 3.22 GiB (43.1%) Init: systemd v: 242 Compilers: gcc: 9.1.0
Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34type or paste code here

Maybe, you could delete if it is not helpful :wink:
Can you start this app, that I do not use/know , from terminal and post the output?

@sgs think the OP means:

https://www.netrunner.com/

I am not in KDE ATM - check your compositor settings say Opengl 3.1

1 Like

I found nothing in repositories and AUR so ... :wink:

1 Like

Hello thank you for the replies

My OpenGl part was 2. I changed to 3.1 as suggested. Problem persists.

I have found some warnings, I do know if they are relavant or not.

[     5.119] (II) LoadModule: "fbdev"
[     5.120] (WW) Warning, couldn't open module fbdev
[     5.120] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.120] (II) LoadModule: "vesa"
[     5.120] (WW) Warning, couldn't open module vesa
[     5.120] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.120] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     5.120] (II) intel: Driver for Intel(R) HD Graphics
[     5.120] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     5.120] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     5.120] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.120] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180719
[     5.120] (II) intel(0): SNA compiled from 2.99.917-863-g6afed33b
[     5.135] (WW) Falling back to old probe method for modesetting
[     5.135] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[     5.135] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[     5.135] (II) intel(0): Creating default Display subsection in Screen section

I have two labtops, they have the same font tearing problem. One is Dell Vostro 5481 running Manjaro which has the configuration provided above. The other ise Dell Latitude E5420. Old but reliable labtop, running Netrunner rolling (which is manjaro based). They both intel embedded graphic card, albeit different versions. They both suffer the same problem.

fbev is a red herring - I get the same errors, it is the frame buffer driver.

cat /var/log/Xorg.0.log | grep fb
[    13.127] (==) Matched fbdev as autoconfigured driver 2
[    13.135] (II) LoadModule: "fbdev"
[    13.136] (WW) Warning, couldn't open module fbdev
[    13.136] (EE) Failed to load module "fbdev" (module does not exist, 0)
        "Default Screen Section" for depth/fbbpp 24/32

And you are not using the intel driver at all:
driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 resolution: 1920x1200~60Hz

1 Like

Maybe something here can help:

I installed fbdev. Rebooted some parts of X.log is below...Problem still persist.

[     5.678] (II) LoadModule: "intel"
[     5.678] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     5.682] (II) Module intel: vendor="X.Org Foundation"
[     5.682] 	compiled for 1.20.4, module version = 2.99.917
[     5.682] 	Module class: X.Org Video Driver
[     5.682] 	ABI class: X.Org Video Driver, version 24.0
[     5.682] (II) LoadModule: "modesetting"
[     5.683] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     5.687] (II) Module modesetting: vendor="X.Org Foundation"
[     5.687] 	compiled for 1.20.5, module version = 1.20.5
[     5.687] 	Module class: X.Org Video Driver
[     5.687] 	ABI class: X.Org Video Driver, version 24.0
[     5.687] (II) LoadModule: "fbdev"
[     5.687] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[     5.688] (II) Module fbdev: vendor="X.Org Foundation"
[     5.688] 	compiled for 1.20.0, module version = 0.5.0
[     5.688] 	Module class: X.Org Video Driver
[     5.688] 	ABI class: X.Org Video Driver, version 24.0
[     5.688] (II) LoadModule: "vesa"
[     5.689] (WW) Warning, couldn't open module vesa
[     5.689] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.689] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     5.690] (II) intel: Driver for Intel(R) HD Graphics
[     5.690] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     5.690] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     5.690] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.690] (II) FBDEV: driver for framebuffer: fbdev
[     5.690] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180719
[     5.690] (II) intel(0): SNA compiled from 2.99.917-863-g6afed33b
[     5.706] (WW) Falling back to old probe method for modesetting
[     5.706] (WW) Falling back to old probe method for fbdev
[     5.706] (II) Loading sub module "fbdevhw"
[     5.706] (II) LoadModule: "fbdevhw"
[     5.707] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[     5.708] (II) Module fbdevhw: vendor="X.Org Foundation"

Create an /etc/X11/xorg.conf.d/20-intel.conf
Contents:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "DRI" "3"             # DRI2 and DRI1 are alternatives if DRI3 performs performs poorly
    Option      "TearFree" "true"
    #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
 EndSection

Reboot. Use inxi to see if it worked:

inxi -G
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 v: kernel
           Display: wayland server: X.Org 1.20.5 driver: intel resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.2
1 Like

Thank you all for the effort... I have created the exact conf file...The inxi output is below. However problem still persists...

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1920x1200~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.2

open KDE Settings and then fonts. Uncheck the box next to exclude range from anti-aliasing. Click Apply, then click okay in the message about affecting only newly opened applications. Close settings. Restart the PC. DO NOT open font settings again or you will need to do the same again. There's currently a reproduceable bug in KDE font settings causing this exclusion behaviour issue.

3 Likes

Hello,

I would like to thank you all, great Manjaro community. The problem is fixed. I have removed the configuration file suggested by "xircon" to make sure that fix is not dependent to that. Yes with below setting tearing problem is gone. I had to enable anti aliasing to uncheck it.

Again thank you all who provided feedback.

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: fbdev,modesetting resolution: 1920x1200~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.2type or paste code here

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by