Manjaro Net/LXQt 17.0.2



i am proud to announce the immediate availability of manjaro net/lxqt 17.0.2.

a recent security vulnerability of calamares (the GUI installer) made a rebuild of the manjaro net/lxqt 17.0 ISO image necessary.

changes of the live system ISO since manjaro net/lxqt 17.0:

  • use gparted instead of partitionmanager
  • all changes made in manjaro 17.0.1 and 17.0.2.
    for example, GRUB is used as boot menu and calamares 3.1.1 as GUI installer. furthermore, pacman-mirrors 4.2 should eliminate problems where download of packages was extremely slow.

the netinstall still works the same as before and did not change at all. if you are interested in the differences between the live system (which gets booted from the ISO image) and the netinstall (which downloads the latest packages - selected during installation by the user - and installs them on the local hard drive), please read the release announcement of manjaro net/lxqt 17.0.

please note that this release will probably be the last with a 32bit ISO image as arch linux deprecates 32bit packages soon.

download folder on sourceforge:
Download Manjaro Linux Community




  • the root account for all manjaro live systems is:

    • username: manjaro
    • password: manjaro
  • the default audio server is “alsa”. this means that the volume widget in the panel will NOT work, if you install pulseaudio (which gets installed, when you mark all packages!). in order to make the volume widget/applet work, right click it and select “configure volume control” --> tick “PulseAudio” and enter pavucontrol-qt as external mixer.

  • when you mark all lxqt packages during installation, both openbox and kwin get installed as your window manager. by default, lxqt uses openbox as window manager. when you want to continue using it, there is no need for kwin and you can safely remove it:
    sudo pacman -Rns kwin systemsettings

Manjaro Mate 17.0.2
Manjaro LXQt 17.0 (net edition)
LXQt - new install missing lxqt-sudo
Manjaro lxqt release date?

Excalibur and other maintainers, can’t comment on the new netinstall, but I did put this back on my testing machine using Manjaro Architect to look at the desktop. Everything seemed to work, except Octopi complained about missing a frontend for getting permissions. I reinstalled kdesu but still no joy. Not sure what the problem was, or if it was a problem with the M-A install. I don’t usually use a gui for updates or installs anyway. Probably something simple.


an optional dependency of octopi is:

  • kdesu (for kde)
  • lxqt-sudo (for lxqt)
  • gksu (for gtk)

by default, manjaro-architect should install the lxqt group, which contains lxqt-sudo (but i am sure about that). try to install lxqt-sudo and gksu. if these do not work, i do not have any idea what is the cause of your problem.

i am kind of in the same situation as you. i have not used octopi for years. i use pacui or pacman for package management.


Ah, didn’t realize lxqt had its own sudo frontend. Probably what it was looking for.


After fighting some hours with the brightness controls, I finally managed to adjust my backlight on Lxqt:
I installed light-git


light -U 20 decrease backlight 20%
light -A 20 increase 20%
light -S 50 set backlight to 50%

My original problem: trying to reduce backlight using fn keys only messes up with lxqt-brightness which does not affect the backlight at all, I only get a darker hard to see screen or it gets too much brighter.
Searching through Lxqt github, it appears to be a design problem?

Anyway my fn keys works fine on any DE that I tried, only Lxqt gave me this problem.
Btw, I have a Acer laptop with Intel sandy bridge gpu, nothing fancy really.

Can you laptop users chime in? I’m curious if it’s just me the lucky one :roll_eyes:


Light-git also works on wayland. It is a nice little app.


Nope, same here.

Keep in mind, lxqt isn’t actually complete yet.


i never have problems with setting the backlight of my laptop screen. the fn keys work as they are supposed to.

but setting the screen brightness on my new desktop computer does not work (well, it works. but only in the way you have described above: the brightness is set and NOT the backlight!). probably, because i have a screen connected via HDMI and i use the free radeon driver. other bug reports also mention they use the free radeon driver.

not even light-git works:

~ > light -v 3 -G                                                                                                                        
Automatic mode -- finding best controller.
error: "could not find an accessible controller", in "src/light.c" on line 762.
error: "could not find suitable controller", in "src/light.c" on line 272.
error: "Initialization failed", in "src/main.c" on line 13.
~ > light -v 3 -L
warning: "no controllers found, either check your system or your permissions", in "src/light.c" on line 844.

it seems to me that backlight control is a tricky thing and works differently on different systems.


Thanks for the answer guys, yeah my last experience with LXqt a year ago was the same.
I had to install light and map the fn keys with it using Lxqt “shortcut keys”.


for all non-english users of lxqt:

if you are using pcmanfm-qt with non-english translations and you want to use keyboard shortcuts like CTRL+C, CTRL+V, DEL, etc. you should install the package “qt5-translations”!

together with the lxqt team, i solved that long-standing bug, which turned out to be a missing dependency:


Does this mean the Manjaro LXQt is end of life? Even the Systemd / NetInstall version?


The lxqt edition installed by manjaro-architect should keep working happily. Openrc version has support until autumn, so I would not recommend installing it. Or if if installing, convert it to artix.


this means that @artoo does not continue to develop the openRC version of manjaro net/lxqt. he contributed the new netinstall feature to calamares and adjusted manjaro-tools to support that feature.
because he now stops doing that (for manjaro), there will probably be fewer new features coming to the manjaro netinstall than i had hoped for in the past.
so, losing @artoo is definitely a blow for the future development of manjaro netinstall.

nevertheless, i will continue to develop/maintain manjaro lxqt (systemd version) as long as i use lxqt as my DE. in case calamares ever discontinues the netinstall feature (or manjaro-tools cannot support it anymore), i will probably continue using manjaro-architect.


Thank you very much. I find for my little netbook, the systemd LXQt edition I installed via netinstall runs beautifully, far better than the old Manjaro Netbook Edition.

It is also a great solution for Virtual Machines, as it runs happily in 1GB.


version 17.0.5 just got released. not because it was necessary, but because a user asked for it and it is probably the last 32bit ISO: