Manjaro mirrors not updating

Update is not visible to my pc but is visible for my laptop!

If they use different mirrors/sources, then I would say this is normal. It takes a while until all mirrors have the same exact copy.

I also have the same problem @proteas has , the update was visible for my desktop PC however for my laptop no update is visible.

How long does it typically take for the update to propagate to the mirrors?

We can’t tell you when your specific mirror is going to be updated because it out of the Manjaro team’s control and under control of the mirror maintainer and why the announcements always say:


That’s why you should:

  1. Check the mirrors

  2. Execute:

    sudo pacman-mirrors --country YourCountry,NeighbouringCountry --interactive
  3. only take the green and fast ones and leave the other ones unselected.




sudo pacman -Syu

I didn’t find an update, but

sudo pacman-mirrors -c Germany && sudo pacman -Syyu

worked for me.

Likewise and even doing

sudo pacman-mirrors -c Germany && sudo pacman -Syyu

Hasn’t worked for me which his really odd

However when I set the servers to be worldwide (i.e. not just Germany) it actually worked. I thnk that one of the German servers may have issues.


I already checked the server list with pacman-mirrors and the mirror list before posting (they were already set to Germany). But I tried this command line and still no update.
Is this something I should worry? Or is it simply that their servers didn’t got the full update yet, which is unusual guess. I will probably switch to worldwide too. Thanks for the tipp.


This time I used the Pamac GUI and set the servers to worldwide. And it immediately found the new Stable Update. Do I need to run pacman -Syyu too, if I use the Pamac GUI to change servers? BTW thanks for the tip to use worldwide.

Yeah I did it by setting the pamac GUI to worldwide, not by using the pacman-mirrors command.

I don’t think you need to run pacman -Syyu as well

I still not get this stable update, despite the fact that I executed pacman-mirrors --fasttrack
EDIT: nor using pacman-mirrors -c all

EDIT 2: pacman-mirrors -c Global did the trick: now I can see the update.

While the actual update happened without any issues…

Many hours after this update was released and it was still not being seen by the package manager. None of the mirrors being used were in or near my country, so I ran a sudo pacman-mirrors -c X,Y && sudo pacman -Syyu where X and Y are my and close countries. The updates were immediately seen and over 100 package updates were available. I had to do this same thing a few updates back as well.

@Fabby, the bigger issue is that very few of the mirrors on are actually updating and this has been an issue for several days. I use sudo pacman-mirrors -f5 for USA, Canada and Global mirrors and only four mirrors appear in my mirror list as that’s all that are current (not just for Stable which I run, but for Testing and Unstable branches too).

The solution clearly says to use:

Have you tried that already?


1 Like

I’m not in front of my PC right now, but I have run that command in the past. I get no bad mirrors on my mirror list, but I do get precisely four mirrors - one Global, one Canada and two US - four in total. These are the only four mirrors for Global, Canada and US that show green rows and check marks on for Stable, etc.

I will run the command you supplied later to see if my mirror list pulls in any of the “bad” repos that are showing all x’s on red rows, which are the vast majority of those listed on the website.

Thank you for your time and assistance.

1 Like

Yes, it still pulls them in, but you don’t select them is what the --interactive switch is doing: the human overrides which of the ones pulled in are to be used and why the solution says:


1 Like

Actually, I’m going to rephrase the solution to say what you should be doing instead of what you should NOT be doing…


1 Like

run pacman-mirrors (without parameter) for check if your config is good - this command use same datas that
pacman use only the first mirror in list

That’s his problem: that’s a bad one…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.