Manjaro minimal bash-like line editing is supported

Make sure when you create the USB installer using RUFUS that you use the DD mode.

yes, I used DD mode

2 Likes

@dklvch
Take a look at this and start up install media install it up in uefi mode.

Follow up with step 6 and its UEFI additional commands.

If you still have problems (hopefully not), tell us if you can boot up to installed Manjaro OS.
and let us know the output of terminal at installed OS

LANG=C
sudo parted -l
sudo blkid
efibootmgr -v
findmnt -s
findmnt /boot/efi

If you cannot boot up to installed OS, boot up livecd in UEFI mode and give the same commands as above, but also go to installed OS in file manager and provide contents of its /etc/fstab.

Good luck.

ps: Print also your input command as well as all the output (including errors or blank) .

4 Likes

Here:

no screen shots please.
Print.
I need to copy down and paste commands for you.
I can’t do that with screen shots.
Oh, tell us what you booted up to.

1 Like

@gohlip
I used livecd, I can’t boot up installed os.

[manjaro@manjaro-gnome ~]$ LANG=C
[manjaro@manjaro-gnome ~]$ sudo parted -l
Model: ATA HFS256G32TND-N21 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 473MB 472MB ntfs Ba hidden, diag
2 473MB 578MB 105MB fat32 EF boot, esp
3 578MB 595MB 16.8MB Mi msftres
4 595MB 105GB 104GB ntfs Ba msftdata
5 105GB 209GB 104GB ntfs msftdata
6 209GB 217GB 8389MB linux-swap(v1) diag
7 217GB 256GB 38.8GB ext4

Model: JetFlash Transcend 8GB (scsi)
Disk /dev/sdb: 8032MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 1839MB 1839MB primary boot
2 1839MB 1844MB 4194kB primary esp

[manjaro@manjaro-gnome ~]$ sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/loop1: TYPE=“squashfs”
/dev/loop2: TYPE=“squashfs”
/dev/loop3: TYPE=“squashfs”
/dev/sda1: LABEL=“M-PM-^RM-PM->M-QM-^AM-QM-^AM-QM-^BM-PM-0M-PM-=M-PM->M-PM-2M-PM-8M-QM-^BM-QM-^L” UUID=“541A64641A6444D8” TYPE=“ntfs” PARTLABEL=“Ba” PARTUUID=“60a8c273-2519-4fc3-88e6-bcc440dd39a1”
/dev/sda2: UUID=“3264-9AC9” TYPE=“vfat” PARTLABEL=“EF” PARTUUID=“192c3134-7dc7-4c71-b7b3-e428ec5c292d”
/dev/sda3: PARTLABEL=“Mi” PARTUUID=“2b90663b-7050-4ac3-b8e3-ee8a40d4b132”
/dev/sda4: UUID=“E418723918720AB6” TYPE=“ntfs” PARTLABEL=“Ba” PARTUUID=“1cda76ec-8f2c-4b54-bf81-6663f004c361”
/dev/sda5: UUID=“A2586CD5586CAA2D” TYPE=“ntfs” PARTUUID=“38f44d9b-9075-eafd-3412-75cbfcbcb1a5”
/dev/sda6: UUID=“fed1cb64-fee7-4dd4-8875-fbdd63487c91” TYPE=“swap” PARTUUID=“7c57dd76-652e-4d79-83d9-2dde7f1430ed”
/dev/sda7: UUID=“296ba75b-03b1-47f6-9cc0-15732ddf3068” TYPE=“ext4” PARTUUID=“521e18c7-2067-403e-be91-857841f152a1”
/dev/sdb1: UUID=“2018-04-28-08-00-50-00” LABEL=“MJRO1719” TYPE=“iso9660” PARTUUID=“9d87aad4-01”
/dev/sdb2: SEC_TYPE=“msdos” LABEL=“MISO_EFI” UUID=“8955-B080” TYPE=“vfat” PARTUUID=“9d87aad4-02”
[manjaro@manjaro-gnome ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0001,0000,0003,0002
Boot0000* Windows Boot Manager HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…7…
Boot0001* ubuntu HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* HFS256G32TND-N210A BBS(HD,0x0)…GO…NO…o.H.F.S.2.5.6.G.3.2.T.N.D.-.N.2.1.0.A…A…>…Gd-.;.A…MQ…L.S.E.2.7.1.N.5.4.1.5.9.0.2.A.5.I. .E. . …BO…NO…S.J.e.t.F.l.a.s.h.T.r.a.n.s.c.e.n.d. .8.G.B. .8…0.7…A…&…Gd-.;.A…MQ…L.T.0.8.Z.E.0.1.S…BO
Boot0003* UEFI: JetFlashTranscend 8GB 8.07 PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/CDROM(1,0x36d16c,0x8000)…BO
[manjaro@manjaro-gnome ~]$ findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/ /dev/mapper/root-image auto defaults
[manjaro@manjaro-gnome ~]$ findmnt /boot/efi

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=3264-9AC9 /boot/efi vfat defaults,noatime 0 2
UUID=fed1cb64-fee7-4dd4-8875-fbdd63487c91 swap swap defaults,noatime,discard 0 2
UUID=296ba75b-03b1-47f6-9cc0-15732ddf3068 / ext4 defaults,noatime,discard 0 1
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

First, tell us computer make and model.

Now boot up to livecd again in uefi mode.

Check if Manjaro installed OS is sda7 and $esp is sda2
with “lsblk -f”. I will use sda7 and sda2 below. If it is sdb7 and sdb2, change accordingly below. If unsure how to change, do not proceed and tell us. (but most likely it will be sda7 and sda2, but you must be sure with ‘lsblk -f’)

So at livecd terminal,

sudo mount /dev/sda7 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
sudo grub-install  --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug
sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo cp /mnt/boot/efi/EFI/Manjaro/grubx64.efi /mnt/boot/efi/EFI/boot/bootx64.efi
sudo cp /mnt/boot/grub/x86_64-efi/core.efi /mnt/boot/efi/EFI/boot/bootx64.efi

Now, check with command (in livecd terminal)

efibootmgr -v

It should show an entry like this… (may not be 0004, but it’s okay) and will be top of the bootorder.

Boot0004* manjaro HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)

Now reboot.
If you reboot to a grub prompt (grub>) and not a grub menu. It’s okay, let us know and well fix it after you tell us. It’s simple to fix but not at this livecd.
.
.
.

##############################################################
Now another possible problem (hopefully not)

If you have a Lenovo, a HP or an Asus, it may still not reboot (not even to a grub prompt), tell us what the computer make and model and we’ll try to fix it as well.
Not so easy with Lenovo.
##############################################################

Also, it looks like you installed or tried to install Ubuntu (or derivatives) earlier.
Was it successful? It is important that you tell us. It may have a bearing on how we can proceed (especially if you have a Lenovo).
And why did you remove it? It’s okay, we don’t care what you installed or removed. We just want to make you install Manjaro correctly. (And we don’t really care if you install other OS’s later or remove Manjaro.) We just want to do a good job here. (Of course we wish you’ll be happy with Manjaro).
Phew… human sensitivities… :grinning:

Cheers.

2 Likes

I use Asus x541u. I used ubuntu 16 and it become laggy with time, so I want to switch to manjaro.
Manjaro is on sda7, do not sure about esp, here the output:
[manjaro@manjaro-gnome ~]$ lsblk -f
NAME FSTYPE LABEL UUID MOUNTPOINT
loop0 squashfs /run/miso/sfs/livefs
loop1 squashfs /run/miso/sfs/mhwdfs
loop2 squashfs /run/miso/sfs/desktopfs
loop3 squashfs /run/miso/sfs/rootfs
sda
|-sda1 ntfs \xd0\x92\xd0\xbe\xd1\x81\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xb8\xd1\x82\xd1\x8c 541A64641A6444D8
|-sda2 vfat 3264-9AC9
|-sda3
|-sda4 ntfs E418723918720AB6
|-sda5 ntfs A2586CD5586CAA2D
|-sda6 swap fed1cb64-fee7-4dd4-8875-fbdd63487c91
-sda7 ext4 296ba75b-03b1-47f6-9cc0-15732ddf3068 /run/media/manjaro/296ba75b-03b1-47f6-9cc0-15732ddf3068 sdb iso9660 MJRO1719 2018-04-28-08-00-50-00 |-sdb1 iso9660 MJRO1719 2018-04-28-08-00-50-00 /run/miso/bootmnt-sdb2 vfat MISO_EFI 8955-B080

Yes, it is sda7 and sda2 respectively. Proceed.

With Asus, it may still not reboot. But it is easier to fix than with Lenovo or HP.
But Proceed.

ps: I’ll send you a link in next post if your Asus does not reboot to manjaro or to grub prompt.
But proceed. It must show efibootmgr with ‘manjaro’ in it.
It does not have ‘manjaro’ now. It must have that .manjaro’ entry.
Proceed.

1 Like

[manjaro@manjaro-gnome ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0004,0001,0000,0003,0002
Boot0000* Windows Boot Manager HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…7…
Boot0001* ubuntu HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* HFS256G32TND-N210A BBS(HD,0x0)…GO…NO…o.H.F.S.2.5.6.G.3.2.T.N.D.-.N.2.1.0.A…A…>…Gd-.;.A…MQ…L.S.E.2.7.1.N.5.4.1.5.9.0.2.A.5.I. .E. . …BO…NO…S.J.e.t.F.l.a.s.h.T.r.a.n.s.c.e.n.d. .8.G.B. .8…0.7…A…&…Gd-.;.A…MQ…L.T.0.8.Z.E.0.1.S…BO
Boot0003* UEFI: JetFlashTranscend 8GB 8.07 PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/CDROM(1,0x36d16c,0x8000)…BO
Boot0004* manjaro HD(2,GPT,192c3134-7dc7-4c71-b7b3-e428ec5c292d,0xe1800,0x32000)/File(\EFI\Manjaro\grubx64.efi)

Good. Reboot. Good luck.

If your Asus does not reboot, use this link.. The author was very clear on how to fix it.
Hope you do not get into the problem, but if you do, the link should be able to help.

Thank god you’re not using Lenovo.

ps: I’m atheist, but at times like this… :grinning:

2 Likes

Yeah, there is grub, but linux doesn’t work it constantly shows some error. I had similar with Ubuntu and solved with pci=nomsi

Does it boot to Manjaro?
At this point, I don’t care about pci=nomsi. :grinning::joy::rofl:

1 Like

It shows grub with manjaro, but manjaro doesn’t boot

Okay, does it boot with pci=nomsi ?

If not, add ‘3’ (no appos) at the linux line in grub menu and see if that boots to a prompt.
If at prompt, login with user name and password and do

sudo pacman-mirrors -f 5
sudo pacman -Syyuu

then reboot.

But tell us if it boots to prompt
Or at least tell us if manjaro grub menu appears.
Or is that grub prompt?

2 Likes

when I hit manjaro I got an error

Press ‘e’ at that Majaro line.
You will get to the grub entry
Arrow down to linux line.
Arrow right past splash and quiet
Backspace to remove them
Careful you do not remove ‘rw’ or other things.
Add a ‘3’ (no apostrophes) just a 3 - at the end of that linux line
Press ‘F10’ to boot

You will boot to a prompt
Enter with username and password.
Do the commands in my previous post.

2 Likes

Oops - commands should be
sudo pacman-mirrors -f 5
sudo pacman -Syyuu

Sorry.
Corrected in the previous post.
It was ‘sudo pacman -f 5’ should be ‘sudo pacman-mirrors -f 5’

1 Like

same error
There was only quite parameter, so I deleted it and added 3 at the end, but


Ps we almost there, I believe in you :smile:

Forum kindly sponsored by Bytemark