Manjaro LXQt 17.0 (net edition)

systemd
community-edition
lxqt
openrc
netinstall

#81

I saw a post about not enough testers on real HW, so I am sacrificing my netbook (since the 32-bit support is probably going away anyway this fall).

I can confirm that the package selection is dynamically loaded. I see:

  • manjaro
  • desktop
  • programs

I also think I saw something about mirror ranking before the live ISO GUI came up, but it could not rank mirrors because it did not have my WEP password, so I ranked them manually, after giving up without ranking.

I left the default on manjaro, selected all of desktop, and selected only qupzilla from desktop.

Everything seems to work, I was able to add my wireless network. There is no LXQt way of adding the touchpad tap actions the way I can in Plasma System Settings, right?


#82

not that i know of.
if you have selected all packages in “desktop”, you also have installed kwin + systemsettings. you can select kwin as in session management --> basic settings --> window manager. then, use “systemsettings” instead of “obconf” to adjust your window manager and compositor. this gives you a “plasma light” desktop, but without touchpad settings…


#83

Its time to at least modify your first post with an EXACT link to what should be downloaded and installed.
If you follow your own links you arrive at a page full of choices, NONE of which mention LXQt, None of which mention net edition.

So I’m left to guess which of these to install.

Further, the Flagship releases are all based on 17.0.1 these days. Is there actually such a thing as a net edition of 17.0.1?


#84

Is it too much to expect that the user knows if he or she wants an OpenRC system orthe default SystemD? Assuming he or she knows which CPU architecture to choose.

The shared folder and the name of the ISO file is actually a statement: Both init systems are equally supported, the Net install doesn’t limit you to a particular DE, the version doesn’t need point release numbers, because net install always downloads the newest version of packages.


#85

there are 4 different editions:

  • net/lxqt systemd 32bit
  • net/lxqt systemd 64bit
  • net/lxqt openRC 32bit
  • net/lxqt openRC 64bit

of every edition, there are 3 files:

  • … .iso : this is the image file
  • … .iso.torrent : this is a torrent file, which downloads the … .iso file via torrent protocol.
  • … .pkgs.txt : this file contains a list with all installed packages on the … .iso file (i.e. in the live system)

maybe, 32bit images will not be released with 17.1 or 17.2. the team is currently deciding what to do about it. this would cut the “choices” in half.
i agree that the … .pkgs.txt file does not really make sense anymore for net editions. this file could be left out as well.

if i link directly to the … .iso images, other people start to complain. these people want an easy way to check the sha1 / md5 checksum of the … .iso file before downloading. this means i would need to add the link to all files as well.
also, i would need to link to the torrent files, for people who prefer to download via torrent. this means i would need 9 links in the OP.
do you feel that 9 links are less confusing than 8 files on sourceforge (if we leave the … .pkgs.txt files away the next time)?

all other questions were already answered by eugen-b.


#86

Quantity isn’t the issue here.

Go look at cinnamon, I3, Mate, gnome. Its clear you are looking at Mate package when in the mate directory because every package has mate in the name.

But when in the lxqt direcory, as a new user, you aren’t sure you are even in the right page !! When you arrive in this directory, and every file just looks like its just manjaro.
Packages should include the word -lxqt- in the name

(And it doesn’t help when that “Looking for the latest version” shows Cinnamon or Mate or something else. But I realize that isn’t your doing).


#87

But it was not that painful.

sudo nano /etc/X11/xorg.conf.d/30-touchpad.conf

Then enter

Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
EndSection

Exit, saving the buffer, and re-boot.

Background:
https://bbs.archlinux.org/viewtopic.php?id=214382


Manjaro LXQt: Octopi crash[patched], sound icon [solved] and tap touchpad[solved too]
Can't get touchpad click to work again
#88

this is not my choice, but @artoo decided this. the ISO name is made up by manjaro-tools.
the reason for “-lxqt-” missing in the name is that manjaro-tools classifies it as net edition and not as lxqt edition:

at the moment, the live system is booted with a lxqt DE and the packages you can install are also lxqt, but it can get easily extended to offer other DE packages…


also, please keep in mind that the sourceforge directory of all ISO files is
HOME/lxqt/17.0/
and the internet address of the link is
https://sourceforge.net/projects/manjarolinux-community/files/lxqt/17.0/

this should be sufficient to indicate that all ISO files are indeed related to lxqt.


#89

Its why its not that bad to avoid a DE in name.
We may think about adding something *net.
But yeah, since the iso is basically just an environment to start installer, and you can install cli only as well as whatever DE, I found dropping DE in name more logical.


#90

However, it would be more intuitive for the users if the ISO name was s.th. like manjaro-17.0-lxqt-net-*.iso
The statement of the name would become weaker on the other hand.


#91

“Intuitive” is usually an euphemism for “to be used to something”, or “Me wants what I am used to”.


#92

Yeah, like Hume’s we are used to the sun rising every day in the east. :wink:


#93

Or, teenagers find the military equipment very “intuitive” because they have been unknowingly trained by military when the played some simulation to fly drones.


#94

On LXQt I see only qt5-translations in Manjaro Settings Manager.

On KDE Stable, using Manjaro Settings Manager I have many additional language packages.

  • Under Global language packages, I have poppler-data (from Okular?).
    Then under en_US, I have
  • firefox-kde and thunderbird (understandable, since I do not have them installed in LXQt).
  • aspell-en
  • hunspell-en
  • hunspell-en_US
  • hyphen-en
    I seem to recall that some of them might have popped up in a notification saying there were additional language packages to install, but that might not be correct,

#95

i also remember that manjaro-settings-manager created a notification (about 5min after the first boot) and tells the user to install language packages…

i have just checked a minimal lxqt installation: the packages “aspell”, “hunspell”, “hyphen” are not on it. this might be the reason you do not get notified to install their language version…
please search for these packages on your lxqt system. you probably do not have them installed…


#96

When I installed them using Octopi and re-booted. they showed in the Manjaro Settings Manager > Language Packages > Installed Language Packages.

I recall in the KDE Stable edition, they showed in the Manjaro Settings Manager > Language Packages > Available Language Packages (with checkboxes pre-filled) and I needed to click the install button before they moved over to the Installed Language Packages tab.


#97

There is no IRC Client in the selection list, right?

I assume quassel would bring in fewer dependencies than konversation?


#98

I don’t know if it is a bug but sddm won’t start for me after installation… I work around this problem by modprobing ethernet card and instaling Intel drivers by mhwd. God bless me how much time I spend looking for this resolution :smile:


#99

i tried to keep the list of applications minimal.
this is the reason, why i have only included qupzilla as a web browser and not firefox or chromium.

look here for a list of qt-based IRC clients and choose your favorite:
https://wiki.manjaro.org/index.php?title=List_of_Qt_Applications#IM.2FIRC.2FVoIP.2Fetc_clients


#100

thank for telling me. i have never looked at drivers which could not get installed using mhwd. maybe artoo can help.
can you be more specific what you have done?

  • have you installed any packages in the “firmware” category during installation?
  • which kernel module did you need to add/remove (exact name or modprobe command)?
  • which intel driver (exact name) did you need to install via mhwd?
  • have you tried to switch to another tty (CTRL+ALT+F2), login, and execute “startlxqt” or “startx” manually? what kind or error do you get this way?
  • do you have to add a kernel modul and intel drivers with mhwd when installing other manjaro editions?