Manjaro LXQt 17.0 (net edition)

systemd
community-edition
lxqt
openrc
netinstall

#61

I believe if you read upstream in this thread #32 you will find I am a fan of Net Installs. I’m guessing 95% of us would be just fine with ONLY Net installs.

There are still the 5% corner cases of course of people who can’t use a net install.

And, again referencing the Mesa/gl fiasco, the overall download size of my last update was well over a gig. I might have been better off downloading the next ISO.

So I doubt there will be all that much download bandwidth saved using a net install. Neither initially, or over the long haul. Neither for the users or the mirrors.

But the Net Install does make getting a new spin out the door easier.
Combined with Architect it could really be light weight.

Some reorganization is probably needed so that there is Only One True Net Install ™, that includes the minimum needed to pull in a base version of Manjaro.

Then launch w3m or Lynx for the user to select their Spin or Flagship of choice from a single web page.

Upstream in this thread it was suggested to me that it was as simple as installing everything found in pacman -Sg lxqt but I suspect a great deal was glossed over.


#62

When I try to install both OpenRC and Systemd builds(x64) on Virtualbox, I get an error when the install is finishing. Regardless of which packages are installed, grub wont popup.

I just tried the Mate 64 build and it installed and booted fine using only what was selected by default. Then I tried to install LXQT alongside it to see if the error was just on grub, but not even the menu entries got created.

Went as far as doing a system upgrade on the live iso(lol) to see if something was fixed after release, but no go, same error.


#63

Just checking, looks like you’re installing in UEFI.
Did you mount /boot/efi? Looks possible you’ve mounted /boot instead only.


#64

I suppose all my virtualbox installs are MBR, because thats what I use it on my reall hdd. UEFI isnt ticked either on vbox settings.
Im doing the same procedure I used on the Esclapion builds, going straight into the installer, on a unpartitioned vhd.

Tried making a DOS partition from the partition manager shipped with the iso, same error.

Screenshot, this time from the Systemd build. Basically the same.

Guess I’ll just wait and see what happens.


#65

Okay, sorry then.
Perhaps other people with VB experience can help out.
Good luck, cheers.


#66

First time LXQt user here, just curious to test in VirtualBox.

I downloaded the 64-bit ISO from the link at the top (https://sourceforge.net/projects/manjarolinux-community/files/lxqt/17.0/). For some reason, I could not launch the installer icon (I tried single click and double click), but I was able to use the search entry field at the bottom of the menu to search for install, and launched the installer.

Once in the installer, I took all the defaults, Erase Disk, MBR, On Package Selection, I chose network lxqt-basic, and qupzilla. It gave me the Summary, and than started the Install step, but never got to the Finish Step. It hangs at Running chrootcfg operation.


#67

Thats because you didn’t let it finish and interrupted.
People don’t seem to have any time these days to wait for the “finished” message.


#68

Patience is good, but
sudo pacman-mirrors --geoip && sudo pacman -Syy
is better.

However, it seems to boot into a shell. Are there some additional packages I should have selected (beyond network, lxqt-basic, and qupzilla)?


#69

the system cannot boot into GUI, if you do not install a window manager and login manager.
in most cases, xdg-user-dirs, base-devel, yaourt, and gvfs-xxx are really useful as well (but not strictly necessary).


#70

Thank you. Based on this:
https://wiki.manjaro.org/index.php?title=Minimal_LXQt_installation#Graphics_Driver
Openbox and sddm are the favorites?


#71

IMHO, if you could avoid sddm you would be happier. Maybe lightdm would run? IDK.


#72

yes.
other login/display managers work as well. choose one and install it as described here:
https://wiki.manjaro.org/index.php?title=Install_Display_Managers

sddm is the recommended login/display manager by the lxqt team, because it is based on qt5.


openbox is the recommended window manager. i use kwin instead of openbox for a couple of months now and it works as well.
other window managers such as xfwm4 should work, too. but i have not tested it extensively.


#73

Thats what calamares covers.
Don’t select any DE packages, and you get cli base system.

Architect fork is not yet officially adopted, and should only be deployed on cli install media, ie they have no desktop installed.

The confusion here is, that the old “net” cli installer was no net installer, just in name.


#74

Thank you. I successfully installed in a Virtual Box guest after checking the window-manager and displaymanager boxes in addition to lxqt-basic and qupzilla (network was already checked).

If you are looking for test results from a typical newbie (I know, nobody asked), I have two suggestions:

  • First, without sudo pacman-mirrors --geoip && sudo pacman -Syy the installer appeared to stall for me. If this cannot be scripted as part of the installation, then I recommend that this be listed not as a trouble-shooting step, but as step 1 after the live session comes up.
  • One of the things I like about Manjaro is ‘sane defaults’. Almost every LXQt user is going to want a GUI. If this is intended to be a generic installer, then an LXQt installation step should be to select displaymanager and window-manager from the Package Selection Step. If this is an LXQt-specific installer, it would be nice to have them pre-selected, the way network is.

#75

thanks for your suggestion.
i am not sure yet what to do. currently, this ISO is meant as a net install of manjaro with the option of installing lxqt.

when only “network” or “networkmanager” is selected, a minimal net edition of manjaro gets installed.
when the user selects ALL packages, a full-blown manjaro lxqt gets installed (the packages “kwin” and “systemsettings” are not really needed in this configuration).

doing something in between (what you did) and selecting only a couple of packages requires knowledge of what you are doing.
maybe i should make this more clear in the announcement…


#76

One option would be to replace https://wiki.manjaro.org/index.php?title=Minimal_LXQt_installation or to create a brand-new wiki page based on your clarification and the original post.

I would be willing to try to do either if you think it will help.


#77

i have just totally overhauled the package selection. therefore, your tips do not really apply anymore.

now, it should be easier:

  • if you keep the default selection a minimal net edition will be installed.
  • if you mark the “manjaro” and “desktop” packages, a simple lxqt desktop without any fancy programs gets installed.
  • it should be really easy to mark ALL packages (only 3 clicks)

can you test it and give some feedback?

  • should i put “manjaro-hello” and “manjaro-documentation” into the “desktop” category?
  • should i create more subgroups?
  • are you missing any packages?

#78

I would be happy to test. Is the package selection dynamically loaded, because the images at:
https://sourceforge.net/projects/manjarolinux-community/files/lxqt/17.0/

Appear a month old:
manjaro-17.0-stable-x86_64.iso 2017-03-07 718.3 MB


#79

Do you have an exact link for this latest overhaul?

Just FYI: I am drawn to LXQt and a net install to make sure I am running the minimal-ish system so that I have room in memory CPU cycles for a couple big pigs that I need to use.

For me, installing a minimalist desktop is key to being able to run LibreOffice on old-ish hardware.
Sure I can go fetch those after the fact, but a lot of people would probably like to get up and running and have a good browser, maybe an office package, (one that isn’t an oddball collection of crapackages), and a very few other things. (WWYMW What Would Your Mom Want? - with apologies in advance to the tech savvy moms out there).

So maybe some check boxes for “collections” would be a good category to add to your list.
Those should be carefully curated as well so as not to overwhelm. You can add them over time. They are, after all, simple lists.


#80

yes.
no need to download a new ISO. the list of packages is dynamically loaded from github during installation. see below for the file called “chrootcfg-systemd.yaml”.


here is the latest version of the file, which defines the list of packages you can select during installation:

and here are the changes i made:



Manjaro lxqt release date?