Manjaro LXQt 17.0 (net edition)



What a lifesaver this was… my ex’s son has an old laptop that Win10 bogged down to the point of not useable and all I had were CD-Rs (no DVD-Rs and USB wouldn’t boot) so I say thank-you, all worked well except octopi wouldn’t start.

I ran it 3 times from the terminal to see what was happening and so I could post the output (which was different every time) but I solved it by changing branch to testing. Octopi now works fine.

Ooops I was a bit quick to write that! It works from a terminal but not from the lxqt start menu and I’m not yet familiar with where to look!

OK… octopi leaves pacman running after it has closed so any instance after the first fails unless the pacman process is killed.

And, VLC didn’t work - it needed sni-qt.

Manjaro installation problem using iPXE with XFCE version 17

qupzilla is just a simple browser. when you notice deficiencies, i recommend to install firefox or chromium.

you need to create a .desktop file (e.g. on your desktop) in order to create a clickable symbol for starting an application. read here how to do it:

but instead of “poweroff” (in the linked example) you want to execute the following command to start qupzilla:



Would you please fix the listing at SourceForge and/or provide correct sha1 value for the ISO files.
It still lists, e.g.,

manjaro-17.0-stable-x86_64.iso 2017-03-07 718.3 MB

But first time I tried it I got a little over 400MB file. Second time and subsequent tests indicate that it is 685MB, if indeed that is the ISO that was provided and has not been hacked between here and there, ;).


If SF is big hassle, posting the correct sha1sum values here can suffice, at least for me.


SF provides sha1 and md5 sums: simply click on the little “i” to the right of the download counter.

depending on the way you (or your file manager) counts, you get a different size:

  • 718mb: 1kb=1000b
  • 685mb: 1kb=1024b


OK. Thanks. In this case it was KGet, Firefox and chrome/chromium …did not even look at it with FM, file or other.
So by your response I assume that the value SF calculated agrees with the value you have for the original file. …ihope, :roller_coaster:.


yes. this was checked during upload.


possibility to create sub groups with calamares-cli ?

  • vlc ( vlc + qt4 )
  • cantata ( cantata + mpd )
  • manjaro-printer ( manjaro-printer + cups )


sorry, i do not understand what you mean.

vlc, cantata, and manjaro-printer are all in a subgroup called “lxqt-extra”. you can either install the entire subgroup or single packages from it.
vlc depends on qt4.
manjaro-printer depends on cups.
cantata does not depend on mpd.

but what is “calamares-cli” supposed to be? calamares is a GUI installer. are you talking about manjaro-architect?


No Qt4 is only an optional dependency with vlc (have a sub-sub group in lxqt-extra : vlc with 2 elements vlc and qt4)
as mpd for cantata
for cups its more a systemd problem ? service not loaded ?


i do not know, whether sub-subgroups are possible.
but i would certainly like a feature like that.

i would also like to add package description to individual packages (and not just entire groups).

@artoo, do you know of such features in development for calamares?

we maybe should report this issue at the bugtracker:


No, not that I am aware of, because it has to support other packagemanagers on other distros.

Great things to come for lxqt openrc version, switch to elogind, which makes it en par with systemd version, eg powermanagement works.


Maybe what is meant is meta-packages. Packages that install nothing (or virtually nothing) themselves, but merely serve as a vehicle to hold dependencies. I know this is possible because it is done already.

This would be useful for the net edition to serve as a building block for many different spins.

  1. Install net edition.
  2. Then pick the LXQt Meta package and get a fairly complete LXQT.
    Or maybe install a Mint Meta package and get most of mint.
  3. Then maybe pick the LIght-Office meta package to get abiword, gnumeric, Sylpheed etc
    pick the Heavy Office Meta Package to get LibreOffice, Thunderbird, etc.


yes, meta-packages are possible. “lxqt” is such a meta-package. do “pacman -Sg lxqt” to see, which packages it contains.

these meta-packages are introduced by arch linux and usually not modified by manjaro. personally, i see a problem when we want to combine “cantata” and “mpd” in a meta-package. somebody has to do it and maintain those (because dependencies might change in the future). @Ste74 already maintains a lot of packages (and does manjaro gnome). i do not want to make him maintain many more meta-packages.

in my opinion, this problem needs to get solved upstream in calamares. i am sure when other distributions start to use the new netinstall feature, they will quickly discover the limitations we are talking about.

i will ask about that in the calamares issue tracker.

great idea!
i have not looked at the package selection the way you look at it. i will probably re-order the package selection completely.


The difference between a Debian style metapackage and a package group is that you need to uninstall a metapackage to be able to remove one of its dependencies. A good feature for Ubuntu users so they don’t uninstall packages and then ask “Where is my PDF reader?” There are some Manjaro metapackages like manjaro-printer, also some of the manjaro--settings are partially metapackages, but they also have their own functions to define /etc/skel.
I don’t think that metapackages should become more in Manjaro.


i just changed the structure of the available packages dramatically:

(either check out this link or try to install manjaro lxqt (net edition) and see what i have changed).

i have included @papajoke’s recommendations, except for “manjaro-printer”: i will not split this meta-package into single packages, because it changes regularly.
whenever printers are not working, this meta-package gets changed i would like to keep the maintenance for it to a minimum.

i have also included @jsamyth’s tip: i included libreoffice including all language packs.


How does calamares-cli work?
These changes require a new iso or calamares-cli download the file yaml from github ?


There is no calamares-cli mode, but if you don’t select any DE packages and DM, you will get a console only system. There is a hidden base group selected by default.


during installation, calamares downloads this file from github:

this files defines, which packages get installed to your hardware.
as you can see, the first 4 groups are hidden. the packages in these groups will always be installed and cannot be unselected by the user.


I just did the test, with the “old” iso I have indeed the new groups, very good feature for calamares

EDIT: Like ste, I’m not a fan of offering languages for openoffice, after Firefox,kde …?


Well , is time to add another de :grin: ( xfce , kde , gnome or other )… ? Only add the main pkgs… Btw libroffice lang is not recognized by msm ?