Manjaro LXDE 17.0.1

lxde
community-edition

#81

Seems reasonable.


#82

Just a warning not to try to make a bitmap font the font for the LXDE GUI. The session fails, the panel crashes. Verified with Dina font which is the only available from LXappearance anyway.


#83

Yeah same thing is happening with xfce, that’s why there is the /etc/fonts/conf.d/70-no-bitmaps.conf symlink, which disables them. For example terminus fonts aren’t available from lxapperance because of that symlink. I don’t know why dina-font is allowed to be shown even with that…


#84

> Furthermore, lxde is a lot different from lxqt, thats why fedora 26 will provide both lxde and lxqt spins.

> Finally lxde’s slow development can been seen as an advantage because it will be ultra stable and really easy to maintain.

I am very new in Manjaro with my share of trouble (just search grub.cfg hacks and you will find my hacks and fixes).
I agree 100% with the above, and I even like Manjaro’s LXDE better than others. It is not a matter of hardware being old and tired but why waste computing resources on flabber-blabber win10 waste when you can be lean and mean.
You want to play games, go to openbox and start it from terminal … It is like taking the other 3 seats and carpetry from a car to race.

There must be something about gρeeks and LXDE …


#85

I had some time this past weekend so I decided to play with different desktop environments. To each their own but to me nothing compares with LXDE. it is lean and mean, just the way I like it.

I have just one little annoyance. When i use my FN keys to adjust brightness i have a little notification pop up to let me see the adjustment. I don’t get the same notification when I adjust my sound. It adjusts it because I can go to the volume control in the system tray and see it has changed. It worked perfectly in most of desktops i thought to check it in.

Running 4.10 kernel because the FN keys don’t work on 4.9 at all.


#86

Thx for reporting this. I think there’s a chance that this is a LXDE problem and not something specific to this edition. If it’s easy for you, can you try with a Lubuntu live image to see if you get any notification there?

Also can you check if there is a line

 <keybind key="XF86AudioRaiseVolume">

at the file ~/.config/openbox/lxde-rc.xml?


#87

…again “Don’t Call Me Lenny” , he loves lxde
https://www.youtube.com/watch?v=t8BSa4wKkXs

he is presenting some helpfull scripts
cheers


#88

Doesn’t work there either.

Don’t have that at all.


#89

Yeah I added that after the release, I just wanted to be sure. If you haven’t done any manual configurations that you might want to keep in the openbox settings, then make sure that you have updated your system (in order to get the latest manjaro-lxde-settings package) and then copy the file /etc/skel/.config/openbox/lxde-rc.xml to ~/.config/openbox/lxde-rc.xml.

It includes the keyboard shortcuts for audio and brightness which I’ve taken from the “Don’t Calle Me Lenny”'s video that @banjo posted and the Opensuse forum. Tell me if that does the job for you.


#90

Actually that is worse for me. The brightness notification stop working as well, although the brightness did change. Still no audio notification.


#91

Hmmm… I have to do some tests on my brother’s laptop when I find some time, in order to see what’s wrong with the brightness. To revert the brightness changes, just delete the lines from the ~/.config/openbox/lxde-rc.xml:

<keybind key="XF86MonBrightnessDown">
          <action name="Execute">
            <command>xbacklight -20</command>
            <startupnotify>
              <enabled>yes</enabled>
              <name>Decrease screen brightness</name>
            </startupnotify>
          </action>
        </keybind>
        <keybind key="XF86MonBrightnessUp">
          <action name="Execute">
            <command>xbacklight +20</command>
            <startupnotify>
              <enabled>yes</enabled>
              <name>Increase screen brightness</name>
            </startupnotify>
          </action>
</keybind>

It seems that lxde doesn’t support volume notifications, by default. However, you can install xfce4-volumed-pulse from AUR and then add the daemon to startup. Tell me if that does the trick for you.


#92

work well on live mode but cant install it, calamares said X internet bla bla bla i cant remember what it said :smile:
is internet connection is required to install this edition??


#93

Yeah I have stated that in the announcement. Unfortunately internet connection is required even when you don’t want to select any extra packges. That’s the drawback of calamares netinstaller.


#94

If you want volume notifications, bind pulseaudioctl to hotkeys and configure it accordingly (assuming you use pulseaudio). For alsa, write a script that sends notification with notify-send (dunstify does this better) after adjusting volume. I did that with bspwm edition. Check lemonpanel for example

Or if there is demand, I can write it.


#95

Good thing about this approach is that it only sends the notification if you use the script. -> no extra stuff running in the background. The downside: no notification when changing volume through the tray icon. But then again, a tray icon is sufficient graphical indicator of volume change.


#96

hi all,
i found this script

and it worked with jwm/dunst and maybe it works with lxde
the mesagem appears as: [70%]
i would like to leave as: Volume 70%
anyone have any idea?

vlw fwi, Holmes :slight_smile:


#97

I think I did it with 2 simple scripts and a few openbox lines. When I get home I ll do some more tests then I ll do the Pull Request and l will post it here


#98

Can you post the scripts?


#99

@Chrysostomus I decided to include them directly in the lxde-rc.xml file with sh -c"…" commands. You can see the latest commit in this file: https://github.com/ThanosApostolou/desktop-settings/blob/lxde/community/lxde/skel/.config/openbox/lxde-rc.xml (I haven’t done any pull request yet). Apart from the lxde branch on my forked desktop-settings repository, I also have the previous lxde-rc branch in which I have created separate scripts. Both ways have the same outcome.

However, on my 1st laptop it works fine, but on my 2nd it doesn’t work always. I keep logging out and logging in and 1/10 times it works fine (audio changes by 5% and shows notification) but 9/10 times it doesn’t work (audio changes by 2% and no notification shown). I’ve spent many hours in trying to figure this out, but I cannot explain it. I’m testing on live session because I don’t have any empty disk space in order to do an installation but I don’t know if it changes anything.
EDIT:
In order to see it easier, these are the changed openbox/lxde-rc.xml lines:

        <keybind key="XF86AudioRaiseVolume">
          <action name="Execute">
            <command>sh -c "pulseaudio-ctl up; notify-send \"Volume Increased: $(pulseaudio-ctl current)\""</command>
            <startupnotify>
              <enabled>yes</enabled>
              <name>RaiseVolume</name>
            </startupnotify>
          </action>
        </keybind>
        <keybind key="XF86AudioLowerVolume">
          <action name="Execute">
            <command>sh -c "pulseaudio-ctl down; notify-send \"Volume Decreased: $(pulseaudio-ctl current)\""</command>
            <startupnotify>
              <enabled>yes</enabled>
              <name>LowerVolume</name>
            </startupnotify>
          </action>
        </keybind>

@Linj can you try to download the new file from here https://raw.githubusercontent.com/ThanosApostolou/desktop-settings/lxde/community/lxde/skel/.config/openbox/lxde-rc.xml and move it to ~/.config/openbox/lxde-rc.xml, then logout and login (or even better reboot) and tell me if it works for you?


#100

Pulseaudioctl has builtin support for notify-send with icons and all, just enable it from the configuration file. Unless you want to have a single updating notification instead of multiple notifications, in which case you should use dunstify.

~/.config/pulseaudio-ctl/config

 NOTIFY=yes
 BARCHART=yes