Manjaro Live USB Install stuck at "Reached target Graphical Interface"

I’ve been trying to install Manjaro KDE Plasma on my PC, but after having a plethora of issues with successfully installed copies (which I may need to come back to later), my install USB now hangs on “Reached target Graphical Interface”.

Ryzen 5 2600
GTX 1660 Super
Gigabyte B450 Aorus Elite

I’ve already checked a closely related post where someone had a similar issue, and have already gone through a lot of the steps they were suggested.

The ID of my GPU from lspci -nnkkvt:
NVIDIA Corporation TU116 [GeForce GTX 1660 SUPER] [10de:21c4]
For some reason, the output of grep -o "10de" /var/lib/mhwd/ids/pci/nvidia.ids is blank. After manually scouting the file, there appears to be no value between 103c and 1180.

I have attempted sudo mhwd -f --install pci video-nvidia --pmconfig /opt/mhwd/pacman-mhwd.conf (-f as the install complained the drivers were already installed) and the results of the above commands have not changed.

The iso I’m using is manjaro-kde-21.0.7-minimal-210614-linux510.

Really hoping the information provided here is of some use! I’ve been tearing my hair out trying to get this thing to work and it’s getting me fed up to the point of throwing my hands up and just installing Win10…

so I’ve tried installing using a previous version of Manjaro KDE using Linux kernel 5.9, and the problem seems to be solved. The only issue now is I’m not able to update my packages without updating the kernel (or at least I’ve grown too comfortable with casually running sudo pacman -Syu to know any alternatives…)

A solution to this problem for kernel 5.10 would be ideal but otherwise a way to stop certain packages from updating would be great, thank you!