Manjaro live USB drive not booting

Hey all,
I'm having an issue with my laptop (lenovo ideapad 330s) not booting Manjaro KDE from a bootable USB drive I made with Rufus. The key itself definitely works because my desktop can boot from it perfectly fine, but to make sure I also tried writing the image using Etcher. I should note i'm currently dualbooting win10 and Kubuntu, and when I put the USB drive as #1 in my load order, my computer just boots straight to the number 2 slot which is Ubuntu's GRUB. If i go back to setup, the USB drive is now number 2 with ubuntu being number 1. No errors or anything, it just doesn't boot from the USB drive and instead moves on down the load order.
I've made sure that secure boot is disabled and tried messing with other BIOS settings to no avail. I'm posting this right after updating the BIOS, and its still a no go. Any help is appreciated,
Thanks!

Here is a similar thread. Maybe some findings can be transferred to your case.

In arch wiki is a nice summary to this computer and they state that you need to add

ivrs_ioapic[32]=00:14.0

to the kernel command line arguments to make it work, and to be able to boot. You need to add this parameter to the kernel command line arguments for the live image as well.

Reference:
https://wiki.archlinux.org/index.php/Lenovo_ideapad_330s

1 Like

Ah damn, looks like I've got the wrong laptop for the job in some respects. I gave a crack at it, but I'm having trouble getting my kernel args to stick to my live image. Also, since I cant even see Manjaro in grub, I seem unable to do a temporary fix until I install. Anyways, I'm quite the noob but do you know of any way I can make my live copy save what I'm doing? I followed the arch wiki when it comes to making both temporary and permanent parameter changes to the kernel but nothing seems to save for me.

The live image can not save. It resets.
Install Manjaro if that's your goal. Then before you reboot, manjaro-chroot -a in a terminal and then edit the grub file in /etc/default/grub to add the kernel param. Then update-grub. Type exit, reboot.

Issue is, I can't even get to the point of my 330s recognizing Manjaro, all of the live image mangling (or lack thereof) was on my other computer. If I can't get my laptop to boot the live image welcome-screen then I'm not sure where to go.

Ok, I'm a little confused, so bare with me.
It won't boot at all? or it won't load the live desktop environment.

Because if it will boot but never makes it to the live desktop environment.
You can interrupt the boot process by hitting the Esc key to get to grub. Then you can arrow down to boot manjaro blah blah, hit e, add the kernel param, then boot that way.

If it simply will not boot at all. Then... uh.... :woman_shrugging:

Edit: Or you can try Manjaro-Architect. It's not exactly noob friendly but you can add custom kernel params to it during install.

It wont boot at all. Yep, pretty confused here as well. I set the bootable usb key to priority slot 1, and when I restart it doesn't boot to anything other than slot 2 (Kubuntu), as if my usb key isn't even bootable. So without having any opportunity to add the param that Wollie mentioned (which seem to work for others, thanks for that link btw) I feel a bit dead in the water here.

Ok. If all else fails, try the silly stuff.

Have another usb stick? If so, make a new live on that one. Maybe that ones haunted or pissy or something?

Wish that was the case, I've got 6 in front of me here and have tried at least 4 of them over the past few days. It's definitely an issue with the ideapad 330s, but gauging the other forum posts it looks like most people have an easier time changing the kernel params (I assume because they can actually boot to something at all). For example on Wollie's first reply, the linked post implies that Manjaro was booting but not running/installing

Which was why I was confused. You'll have to forgive me, I tend to skim sometimes and I missed some of the steps you'd done.

:thinking:

I got nothing. Without even getting into grub or it even seeing the usb there's really no way to get to the params

I think the arch wiki entry for changing kernel params on a usb stick only works on their liveusbs. Manjaro has some modifications to how it handles things. that might be why it doesn't work.

Short of building your own ISO I have no clue how to make that work.

Quite a big leap to take but if you really want to use Manjaro.

Short of calling in the Devs, I'm out of ideas.

I know you mentioned secure boot is off, but what about fast boot? There could be settings in both windows and the BIOS. If fast boot is enabled, you'll need to shut it off and then boot into windows and then shut down (restart isn't good enough.)

Just to recap - how to write a Manjaro ISO to USB

  1. If you can boot Kubuntu then use dd to write the image or Etcher or Mint Stick.

  2. If using Windows use Rufus and select DD mode when prompted at the beginning of the write process.

I would assume the key is to get the kernel commands inline when booting the LIVE session.

Does this help?

As near as I can tell, step2 (last post) fails. Something is blocking the USB boot. Given that the USB boots on another system, either there is still something in the BIOS crippling USB booting or windows is still interfering either with fast boot or overriding boot order. You could try booting from windows under advanced recovery, use a device. I don't know exactly where that option is anymore, my windows is at least a year behind in updates.

The Number 1 advise is always:

Read the Manual!!!

In your case, read your computer/BIOS manual on how to get to the UEFI Quick Boot Menu. Some key should bring it up during boot (like F8, F12, etc.).
Then look for your USB name. It should have TWO similar entries, one with "UEFI some USB manufacturer name" and one with "Some USB manufacturer name", which is for BIOS Legacy booting. Select and boot to the one with UEFI (I suppose Windows is a UEFI installation?).

If that method still fails, you have to review your UEFI settings for something conflicting...

1 Like

What I not understand is why Ubuntu could be installed via stick and Manjaro does not even show you the boot menu to enter kernel attributes :thinking:

secure boot and fast boot maybe as ubuntu uses it manjaro does not

2 Likes

Make sure to use 'dd' mode.

I've got a new Intel rig. New enough it was necessary to use the latest Manjaro (KDE) RC (release candidate) in order to have a new enough kernel that did recognize it.

New hardware is a continuous development. Same with kernels. Sometimes you have to play dirty until they both sync.

regards

1 Like

Another thing worth trying is to install rEFInd from *buntu and then see if it picks up the bootloader. Also - if you have the latest version of Rufus - dd mode should automatically be set. It might be worth trying etcher - but I recenly did an install with a manjaro image from rufus.

If you need help with rEFInd, feel free to ask. I think there might be more info in the manjaro wiki. The best way is probably to follow the instructions for the distro you are installing it from.

Good luck.

Forum kindly sponsored by Bytemark