Manjaro Live USB doesn't boot

grub
#21

@philm
we have a trouble with some HP bios

systemrescue has jump this month with archlinux base and boot on Grub



0 Likes

#22
[root@sysresccd ~]# pacman -Qs grub
local/grub 2:2.02-8
    GNU GRand Unified Bootloader (2)
[root@sysresccd ~]# pacman -Qs systemd
local/libsystemd 240.34-3
    systemd client libraries
local/netctl 1.19-1 (base)
    Profile based systemd network management
local/systemd 240.34-3 (base-devel)
    system and service manager
local/systemd-sysvcompat 240.34-3 (base)
    sysvinit compat for systemd

There is no output from inxi because pacman on SystemRescueCD seems to have the wrong repos or there is some other issue and I haven’t managed to fix it to install inxi. SystemRescueCD was downloaded from your link, everything else is on the inxi output that I have posted earlier.

0 Likes

#23

Oh no. Well then there is not much that I can do atm. Too bad, I had tried this distro and then decided that I wanted to finally switch from OSX because of it, so I really really hope that this will be solved soon.

I am no expert, but if there is something that I can contribute with please let me know. Thank you for your time and help anyway :grin::+1:

1 Like

#24

this not come from a hackintosh ,
my brother can boot with a clover EFI and a file xml

0 Likes

#25

Yes, if the config.plist (the XML file) is set up properly there should be no problem booting up other OSes. But some systems, usually some kinds of laptops like mine, are so tricky to get to work that once you get MacOS to boot, you just don’t want to touch the config.plist ever again. So now I don’t think it’s worth trying to get Clover to work with Linux, since that bootloader will only be on a backup drive together with my OSX partitions.
Excuse me, what do you mean by this?

Regarding Grub, from some of the threads linked in your previous post it seems like some people have managed to install a previous version of Manjaro and then update it and get it to work. Tomorrow I am going to get a used drive so I can backup the Hackintosh setup and free my main SSD, then I will try to install Manjaro KDE v. 17.0 (last version pre-Grub if I understood) and try to update it. I will update this thread tomorrow/in two days.

1 Like

#26

During initial start up do you press ESC key to get boot menu?

0 Likes

#27

Hi there. Sorry, I didn’t mean to leave this thread unanswered, but I have been quite busy. However, this afternoon I managed to get back to this and finally get it to work.

First a little update that might be relevant: a few days ago I found a used Intel Core i7-2630QM for cheap, so I upgraded the CPU in the laptop. It is still a Sandy Bridge, so as expected Grub didn’t load when trying to boot to the latest Manjaro (i have also tried the latest 18.0.3).

As I said in my last post, I downloaded Manjaro KDE v. 17.0 and flashed it on my USB 3.0 stick. This version booted fine and everything worked from the live USB. So I launched the installer and instructed to erase a SATA HDD and install onto it. After the install I booted from the HDD and I was greeted with a working Grub menu (the Live USB uses a simpler menu for the bootloader that doesn’t even seem to be Grub; maybe the latest versions of Grub have issues with this BIOS when launching from a USB?).

Updating all the packages was however troublesome, because there were 2yrs worth of updates that caused all sorts of conflicts. But with a few quick searches it was quite manageable. The first time that I ran sudo pacman -Syyu the program asked to replace a bunch of packages (or rather relocate them): saying yes to all brought to an error for conflicting dependencies, so you will have to avoid replacing the two packages that cause the conflicts, attica and qca (beware these are not the entire names, I am writing from memory). Afterwards you will have to remove the deprecated package that still depends on the above mentioned packages: sudo pacman -Rncs kdelibs. Then, if I recall correctly, you should be able to update the remaining packages (its possible that I am forgetting something, but if I found the solution by searching the web then you can too :wink: ).

You might notice that after rebooting the browser will fail to launch: I have just replaced the non-working firefox-kde with firefox. Could someone please tell me what Firefox package the latest Manjaro KDE uses? I find it weird that pacman didn’t fix this automatically during the update. The description of the old package said that it better integrated with KDE. There is also an add-on from KDE that claims to do just this, but is it the same thing?

I’m yet to find something else that isn’t working, so I am soon going to clone this install to my SSD.

As time goes on and more updates get pushed, the list of conflicts is potentially going to grow, but I hope to have helped someone here :slight_smile:

2 Likes

Installer GRUB doesn't load on my HP DV6
#28

It may still ship with regular FF, but it seems as the most vocal KDE users have migrated to:

$ pacman -Qi firefox-kde-opensuse
Name            : firefox-kde-opensuse
Version         : 65.0.1-1
Description     : Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
Architecture    : x86_64
URL             : https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
Licenses        : MPL  GPL  LGPL
Groups          : None
Provides        : firefox=65.0.1
Depends On      : gtk3  mozilla-common  libxt  startup-notification  mime-types  dbus-glib  ffmpeg  nss  ttf-font  libpulse  kmozillahelper
Optional Deps   : networkmanager: Location detection via available WiFi networks [installed]
                  libnotify: Notification integration [installed]
                  pulseaudio: Audio support [installed]
                  speech-dispatcher: Text-to-Speech
                  hunspell-en_US: Spell checking, American English [installed]
Required By     : None
Optional For    : None
Conflicts With  : firefox
Replaces        : None
Installed Size  : 179.67 MiB
Packager        : James Kittsmiller (AJSLye) <james@nulogicsystems.com>
Build Date      : Wed 13 Feb 2019 10:43:33 PM EST
Install Date    : Fri 15 Feb 2019 12:04:45 PM EST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

0 Likes

#29

Thank you for the confirmation, I am going to try firefox-kde-opensuse too :+1:

0 Likes

#30

I have discovered something interesting while cloning to my SSD. I have attached the HDD with the working install of Manjaro to a SATA-USB adapter and tried to boot: it acted just like the USB stick did, getting stuck at Welcome to GRUB!. The same disk works just fine via SATA. This confirms what I had hypothesized earlier.

There was another small difference: after cloning to the SSD, I have tried to boot that from the SATA-USB adapter, and instead this went straight to a completely blank screen, not even a command line blinking underscore. The SSD also works flawlessly via SATA.

0 Likes